03-12-2024 02:07 PM
can i create two Port Channel between 2 switches
Solved! Go to Solution.
03-12-2024 02:33 PM
Hello @krutiksojitra567 ,
technically you can configure 2 port channel interfaces between two switches - a sample config would be:
interface Port-channel1
switchport trunk encapsulation dot1q
switchport mode trunk
interface Port-channel2
switchport trunk encapsulation dot1q
switchport mode trunk
interface GigabitEthernet1/0/1
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 1 mode active
interface GigabitEthernet1/0/2
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 1 mode active
interface GigabitEthernet1/0/3
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 2 mode active
interface GigabitEthernet1/0/4
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 2 mode active
I am curious about the reason you would like to have such a configuration. The two port channel interfaces would function as individual links between the switches and you will basically have a loop between the two switches and STP will block one of the links, making it unusable as long as the first port channel interface is up:
sw2#show spanning-tree
VLAN0001
Spanning tree enabled protocol ieee
Root ID Priority 32769
Address 5254.0003.5f19
Cost 4
Port 65 (Port-channel1)
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Bridge ID Priority 32769 (priority 32768 sys-id-ext 1)
Address 5254.0015.14da
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Aging Time 300 sec
Interface Role Sts Cost Prio.Nbr Type
------------------- ---- --- --------- -------- --------------------------------
Gi0/2 Desg FWD 4 128.3 P2p
Gi0/3 Desg FWD 4 128.4 P2p
Gi1/0 Desg FWD 4 128.5 P2p
Gi1/1 Desg FWD 4 128.6 P2p
Gi1/2 Desg FWD 4 128.7 P2p
Gi1/3 Desg FWD 4 128.8 P2p
Po1 Root FWD 4 128.65 P2p
Po2 Altn BLK 4 128.66 P2p
03-12-2024 02:33 PM
Hello @krutiksojitra567 ,
technically you can configure 2 port channel interfaces between two switches - a sample config would be:
interface Port-channel1
switchport trunk encapsulation dot1q
switchport mode trunk
interface Port-channel2
switchport trunk encapsulation dot1q
switchport mode trunk
interface GigabitEthernet1/0/1
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 1 mode active
interface GigabitEthernet1/0/2
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 1 mode active
interface GigabitEthernet1/0/3
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 2 mode active
interface GigabitEthernet1/0/4
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 2 mode active
I am curious about the reason you would like to have such a configuration. The two port channel interfaces would function as individual links between the switches and you will basically have a loop between the two switches and STP will block one of the links, making it unusable as long as the first port channel interface is up:
sw2#show spanning-tree
VLAN0001
Spanning tree enabled protocol ieee
Root ID Priority 32769
Address 5254.0003.5f19
Cost 4
Port 65 (Port-channel1)
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Bridge ID Priority 32769 (priority 32768 sys-id-ext 1)
Address 5254.0015.14da
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Aging Time 300 sec
Interface Role Sts Cost Prio.Nbr Type
------------------- ---- --- --------- -------- --------------------------------
Gi0/2 Desg FWD 4 128.3 P2p
Gi0/3 Desg FWD 4 128.4 P2p
Gi1/0 Desg FWD 4 128.5 P2p
Gi1/1 Desg FWD 4 128.6 P2p
Gi1/2 Desg FWD 4 128.7 P2p
Gi1/3 Desg FWD 4 128.8 P2p
Po1 Root FWD 4 128.65 P2p
Po2 Altn BLK 4 128.66 P2p
03-12-2024 03:06 PM
You can but there is no benefit of that, one PO will be BLK by STP unless you use PVST and load balance.
https://www.cisco.com/c/en/us/support/docs/lan-switching/spanning-tree-protocol/10555-15.html
MHM
03-12-2024 03:48 PM
@krutiksojitra567 wrote:
can i create two Port Channel between 2 switches
As already noted by the others, yes. In fact, you could have more than 2 port-channels.
Although rarely would you do this, one possible reason would be to provide more bandwidth, but to take advantage of it at L2 you would need to direct specific VLANs (or MST regions) to prefer one of the port-channels, as the other(s) would be STP blocked. For L3 switches, you could do ECMP across multiple port channels.
I recall, in the past, platforms like the Catalyst 6500 had some restrictions if you did port channels across non-identical line cards. So, that could be another case where you might need to define multiple port channels to acquire redundancy for line card ports.
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide