02-20-2013 03:21 AM - edited 03-07-2019 11:49 AM
I am trying to put the finishing touches on my network using loopbacks on all my switches, CATALYST 3750G PoE48 switches. This is something that I have done before and has never been an issue until now. I am able to ssh into all of my core and distro switches, however I cannot access my two access switches. Right now I have them trunked to my distro switches. Both of my access switches are passing data, there are users attached to them, through the trunk, however I cannot ping to or from them from either the distro switches or the users computers. Both of the distro are configured the same and the access switches are as well. I have been banging my head against my keyboard for the last 6 hours trying to figure this one out. I need help.
Here are my configs.
Access Switch:
interface Loopback5
description ***Management Loopback 5***
ip address XXX.XXX.44.70 255.255.255.255
!
interface GigabitEthernet1/0/1
description ***Trunk to XXX1***
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface GigabitEthernet1/0/2
description ***Trunk to XXX2***
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface range GigabitEthernet1/0/3 - 48
switchport access vlan 100
switchport mode access
switchport voice vlan 30
spanning-tree portfast
!
interface ranger GigabitEthernet1/0/49 - 52
!
router eigrp XXXX
network XXX.XXX.44.70 255.255.255.255
!
line con 0
logging syncronous
line vty 0 4
logging syncronous
transport input ssh
line vty 5 15
logging syncronous
transport input ssh
!
end
Distro Switch:
interface Loopback1
description ***Management Loopback 1***
ip address XXX.XXX.44.66 255.255.255.255
!
interface GigabitEthernet2/0/1
description ***link to XXXXX03 port g0/11***
no switchport
ip address XXX.XXX.45.14 255.255.255.254
!
interface GigabitEthernet2/0/2
description ***link to XXXXX04 port g0/12***
no switchport
ip address XXX.XXX.45.10 255.255.255.254
!
interface GigabitEthernet2/0/3
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 13 mode on
!
interface GigabitEthernet2/0/4
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 13 mode on
!
interface GigabitEthernet2/0/5
!
interface GigabitEthernet2/0/6
!
interface GigabitEthernet2/0/7
!
interface GigabitEthernet2/0/8
!
interface GigabitEthernet2/0/9
!
interface GigabitEthernet2/0/10
!
interface GigabitEthernet2/0/11
!
interface GigabitEthernet2/0/12
!
interface GigabitEthernet3/0/1
description ***TO XXX FOR XXXXXX***
no switchport
ip address XXX.XXX.47.78 255.255.255.252
!
interface GigabitEthernet3/0/2
description ***XXXXX***
switchport access vlan 30
switchport mode access
switchport voice vlan 30
spanning-tree portfast
!
interface GigabitEthernet3/0/3
description ***XX TO XXXXX BUILDING***
no switchport
ip address XXX.XXX.44.54 255.255.255.252
!
interface GigabitEthernet3/0/4
switchport access vlan 30
switchport mode access
!
interface GigabitEthernet3/0/5
description ***trunk to Helpdesk***
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface GigabitEthernet3/0/6
!
interface GigabitEthernet3/0/7
switchport access vlan 100
switchport mode access
!
interface GigabitEthernet3/0/8
description ***TRUNK TO IMAGING SWITCH***
switchport trunk encapsulation dot1q
switchport mode trunk
shutdown
!
interface GigabitEthernet3/0/9
!
interface GigabitEthernet3/0/10
!
interface GigabitEthernet3/0/11
!
interface GigabitEthernet3/0/12
!
interface GigabitEthernet3/0/13
!
interface GigabitEthernet3/0/14
!
interface GigabitEthernet3/0/15
switchport access vlan 100
switchport mode access
!
interface GigabitEthernet3/0/16
!
interface GigabitEthernet3/0/17
description *** link to XXX Call manager***
switchport trunk encapsulation dot1q
switchport mode trunk
spanning-tree portfast
!
interface GigabitEthernet3/0/18
switchport access vlan 30
switchport mode access
switchport voice vlan 30
spanning-tree portfast
!
interface GigabitEthernet3/0/19
switchport access vlan 30
switchport mode access
switchport voice vlan 30
spanning-tree portfast
!
interface GigabitEthernet3/0/20
!
interface GigabitEthernet3/0/21
!
interface GigabitEthernet3/0/22
!
interface GigabitEthernet3/0/23
!
interface GigabitEthernet3/0/24
!
interface GigabitEthernet3/0/25
!
interface GigabitEthernet3/0/26
!
interface GigabitEthernet3/0/27
!
interface GigabitEthernet3/0/28
!
interface GigabitEthernet3/0/29
!
interface GigabitEthernet3/0/30
!
interface GigabitEthernet3/0/31
description ***User Port***
switchport access vlan 100
switchport mode access
!
interface GigabitEthernet3/0/32
!
interface GigabitEthernet3/0/33
!
interface GigabitEthernet3/0/34
!
interface GigabitEthernet3/0/35
!
interface GigabitEthernet3/0/36
!
interface GigabitEthernet3/0/37
!
interface GigabitEthernet3/0/38
!
interface GigabitEthernet3/0/39
no switchport
no ip address
channel-group 28 mode on
!
interface GigabitEthernet3/0/40
no switchport
no ip address
channel-group 28 mode on
!
interface GigabitEthernet3/0/41
description ***TRUNK to XXXX switch port 48***
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface GigabitEthernet3/0/42
!
interface GigabitEthernet3/0/43
no switchport
no ip address
channel-group 36 mode on
!
interface GigabitEthernet3/0/44
no switchport
no ip address
channel-group 36 mode on
!
interface GigabitEthernet3/0/45
no switchport
no ip address
shutdown
channel-group 28 mode on
!
interface GigabitEthernet3/0/46
no switchport
no ip address
shutdown
channel-group 28 mode on
!
interface GigabitEthernet3/0/47
!
interface GigabitEthernet3/0/48
description ***Trunk to XXXX Switch (G1/0/47)***
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface GigabitEthernet3/0/49
!
interface GigabitEthernet3/0/50
!
interface GigabitEthernet3/0/51
!
interface GigabitEthernet3/0/52
!
interface Vlan100
description ***USER DHCP VLAN***
ip address XXX.XXX.44.130 255.255.255.224
ip helper-address XXX.XXX.44.21
standby 100 ip XXX.XXX.44.129
standby 100 priority 110
standby 100 preempt
!
!
router eigrp 5323
no auto-summary
network XXX.XXX.44.52 0.0.0.3
network XXX.XXX.44.64 0.0.0.15
network XXX.XXX.44.80 0.0.0.7
network XXX.XXX.44.88 0.0.0.7
network XXX.XXX.44.96 0.0.0.31
network XXX.XXX.44.128 0.0.0.31
network XXX.XXX.45.10 0.0.0.1
network XXX.XXX.45.14 0.0.0.1
network XXX.XXX.47.80 0.0.0.3
network XXX.XXX.47.128 0.0.0.3
network XXX.XXX.47.136 0.0.0.3
network XXX.XXX.92.128 0.0.0.3
network XXX.XXX.92.136 0.0.0.3
!
ip classless
ip route XXX.XXX.45.128 255.255.255.192 XXX.XXX.47.137
ip route XXX.XXX.45.192 255.255.255.192 XXX.XXX.47.137
ip route XXX.XXX.47.80 255.255.255.252 XXX.XXX.47.77
ip route XXX.XXX.47.84 255.255.255.252 XXX.XXX.44.53
ip http server
ip http secure-server
!
!
line con 0
logging synchronous
line vty 0 4
exec-timeout 0 0
logging synchronous
transport input ssh
line vty 5 15
access-class 23 in
exec-timeout 0 0
logging synchronous
transport input ssh
!
02-20-2013 03:56 AM
Charles
You have not told us what kind of switches the access switches are and it might be helpful if we knew that.
My experience has been that it is easier to manage access switches when you use IP addresses on vlan interfaces. This is partly because the vlan is carried over the trunk and if the trunk is working then the vlan interface should be reachable. But loopbacks may work. Part of the issue with loopbacks is that they are not members of a vlan and so are not transported over the trunk. So you need something to make them reachable over the trunk. I assume that is why you have configured EIGRP on the access switch and have a network statement for the loopback. But there are no other network statements, so EIGRP is not carried over the trunk. And that is why the loopback is not reachable. My first suggestion would be to put a network statement for at least one of the vlans that will match up with EIGRP on the distro switch.
HTH
Rick
02-20-2013 05:08 AM
I am using CATALYST 3750G 48PoE switches. I did try using my Management Vlan, however I could not get the interfaces on the access switches to go up/up. That is why I have the Loopbacks on all of the switches. Here are the configs that I used to have on the switches:
Distro Switches:
interface Vlan10
description ***Management Vlan***
ip address XXX.XXX.44.66 255.255.255.240
standby 10 XXX.XXX.44.65
standby 10 priority XXX
standby 10 preempt
Access Switches:
interface Vlan10
ip address XXX.XXX.44.71 255.255.255.240
02-20-2013 05:31 AM
Hi Charles,
You need to have this vlan assigned to the interface which is active, else the vlan will be in down down state.
Eg:
Switch(config)#int vlan 10
Switch(config-if)#ip address 10.10.10.1 255.255.255.0
Switch(config-if)#no shut
Switch#sh int vlan 10
Vlan10 is down, line protocol is down <<<< Vlan interface is down.
Now assign this vlan to any active inteface:
Switch(config)#int f0/1
Switch(config-if)#switchport access vlan 10
%LINK-5-CHANGED: Interface Vlan10, changed state to up <<< As soon as you apply the interface vlan comes up.
HTH
Regards
Inayath
*Plz rate helpfull posts.
02-20-2013 05:52 AM
Post Sh ip int Brief Output.
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide