cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
4567
Views
0
Helpful
18
Replies
LEN SNEED
Beginner

Problem changing Vlan 1 ip address

Hi,

I have a 3750 stack that connects to a 3560 at another site.  The are both on the inside of our network and basically a switch to switch connection.  The switchports are in vlan 901.  When I telnet from the 3750 to the 3560 and attempt to change the 3560's vlan 1 ip address I lose connectivity and can only get it back by going to the site and consoling into the 3560 to change the vlan 1 ip address back.  The 3750 vtp mode is server and the remote 3560 is vtp transparent.  Any ideas why this is happening?

Thanks,

Len.

18 REPLIES 18
mlund
Rising star

Hi Len

I still think it's a routing problem for the return traffic(from 3560 towards terminalserver).

The starting point is as follow.

The 3560 looks up in the routing table , there are no specific route to 10.1.0.0 so it uses the static default to reach 10.1.5.38. The default points to 10.255.255.1 wich is the 3750 wich in turn will routes this packet out on vlan 1.

Now You change the ip address on vlan1 to 10.1.255.73 , I suppose You will use the same mask as on 3750 wich is 255.255.0.0.

What will happen now is that when 3560 looks in routingtable to find 10.1.5.38 it sees that this network is local connected, and will send the traffic out on his own vlan1 interface.

For this to work, You have to have a layer2 connection between the 3560 and the 3750.

If You will share the configuration for the ports that is connecting the 3560 and 3750 it will help us understand better.

/Mikael

Mikael,

Thanks for getting back with me.  Here are the interface configs:

remote 3560
-------------

interface GigabitEthernet0/22
switchport access vlan 901
speed 100
duplex full

interface Vlan901
description Connection To Corporate
ip address 10.255.255.2 255.255.255.0

router eigrp 100
network 10.255.251.0 0.0.0.255
network 10.255.252.0 0.0.0.255
network 10.255.253.0 0.0.0.255
network 10.255.254.0 0.0.0.255
network 10.255.255.0 0.0.0.255
redistribute static metric 100000 10 255 1 1500
no eigrp log-neighbor-changes
!
ip classless
ip route 0.0.0.0 0.0.0.0 10.255.255.1
ip route 170.53.32.0 255.255.224.0 10.255.254.1
ip route 170.53.64.0 255.255.224.0 10.255.254.1
ip route 170.53.72.12 255.255.255.255 10.255.255.1
ip route 170.53.75.0 255.255.255.0 10.255.255.1
ip route 170.53.230.0 255.255.255.0 10.255.254.1


core 3750
-----------

interface GigabitEthernet4/0/1
switchport access vlan 901
switchport mode access
speed 100
duplex full

interface Vlan901
ip address 10.255.255.1 255.255.255.0
!
!
router eigrp 100
default-metric 100000 10 255 1 1500
no auto-summary
eigrp stub static
network 10.255.255.0 0.0.0.255
!
ip classless
ip route 0.0.0.0 0.0.0.0 10.255.1.2
ip route 170.53.72.12 255.255.255.255 10.255.1.2
ip route 170.53.75.35 255.255.255.255 10.255.1.2

Hello Lan,

try to add below routes

3750

ip route 10.1.0.0 255.255.0.0 170.53.73.56 10
ip route 10.1.0.0 255.255.0.0 10.1.255.73 20

3560

ip route 170.53.73.0 255.255.255.0 10.1.0.0 10
ip route 10.1.255.73 255.255.255.0 10.1.0.0 20

by doing this, once you delete vlan 1 from switch, traffic will find reverse path and once you will change vlan 1 IP address, delete  ip route 170.53.73.0 255.255.255.0 10.1.0.0 10 from 3560 and ip route 10.1.0.0 255.255.0.0 170.53.73.56 10 from 3750.

- Jigar

mlund
Rising star

Hi Len

The reason this is not working is because the vlan1 is not forwarded between the switches.

As I described in my previous contribution You have to have vlan1 forwarded between the switches.

The config You have now are only connecting vlan901, by making the g0/22 and g4/0/1 a trunkport and allowing vlan 1 and 901 will solve the problem.

Or You can connect a new cable between the switches and forward vlan1 that way.

Or, You can give the vlan1 interface on 3560 an ip address that is not overlapping with other neetworks.

/Mikael