cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
476
Views
5
Helpful
7
Replies

Problem Programming Catalyst 2960x

PNKTech1
Beginner
Beginner

I'm encountering a problem getting a Cisco 2960x to accept a line of programming. I'm setting it up currently:

 

Switch#config t

switch(config)#hostname 3560_10

3560_10(config)#enable secret zxcvbnm

3560_10(config)#enable password cisco

3560_10(config)#line con 0

3560_10(config-line)#password cisco

3560_10(config-line)#login

3560_10(config-line)#exit

3560_10(config)#line vty 0 4

3560_10(config-line)#password cisco

3560_10(config-line)#login

3560_10(config-line)#exit

3560_10(config)#line vty 5 15

3560_10(config-line)#password cisco

3560_10(config-line)#login

3560_10(config-line)#exit

3560_10(config)#service password-encryption

3560_10(config)#vlan 10

3560_10(config-vlan)#name Surveillus

3560_10(config-vlan)#exit

3560_10(config)#interface vlan 1

3560_10(config-if)#ip address 10.20.85.20 255.255.0.0

3560_10(config-if)#no shutdown

3560_10(config-if)#exit

3560_10(config)#spanning-tree mode pvst

3560_10(config)#interface port-channel10

3560_10(config-if)#switchport mode trunk

3560_10(config-if)#exit

3560_10(config)#interface range gigabitethernet0/1 - 48

                                                                               ^                                                              

% Invalid input detected at '^' marker.

3560_10(config-if-range)#switchport access vlan 10

3560_10(config-if-range)#switchport mode access

3560_10(config-if-range)#spanning-tree portfast

3560_10(config-if-range)#exit

3560_10(config)#interface range gigabitethernet0/49 - 52

3560_10(config-if-range)#switchport mode trunk

3560_10(config-if-range)#exit

3560_10(config)#interface range gigabitethernet0/51 - 52

3560_10(config-if-range)#channel-group 10 mode active

3560_10(config-if-range)#end

3560_10#clock set 09:50:00 26 dec 2017

3560_10#wr mem

 

The line in bold is the one that won't take. The error arrow is pointing to the 0 in case formatting sets it off. Not sure why it won't take the command. Any useful advice would be much appreciated.

 

Thank you!

7 Replies 7

tredgrove
Beginner
Beginner

first thought was whether the switch was in a stack -   are all the ports set with the same properties? for range to work all the ports have to have the same base config.  might trigger a thought from another. watching.

 

The switch is not in a stack, but the 3750's that are next in the chain are, but I don't think that matters does it?

Joseph W. Doherty
Hall of Fame Master Hall of Fame Master
Hall of Fame Master
Hmm, looks right - i.e. one would expect it to work. What's the IOS image?

For ha ha's sake, you might also try "int range g0/1 - 48" or "int range g 0/1 - 48".

BTW
for:
spanning-tree mode pvst
I would recommend you use:
spanning-tree mode rapid-pvst

also rather for access interfaces':
spanning-tree portfast
you might use instead (global):
spanning-tree portfast default
spanning-tree portfast bpduguard default

Ben Walters
Participant
Participant

It looks like you might be missing some part of the interface identifier, if you do a sho int status it should give you the correct format for your interface numbers in the port column.

 

For the 2960x switches we have deployed interfaces are listed as X/0/1-48 with X being the switch number in the stack which starts at 1.

 

If you have just the one switch the correct command should be

int range gigabitEthernet 1/0/1-48

 

 

Ben is correct.

The command for a single switch would be...

int range gi1/0/1 - 48

 

Mike

Ben and Mike, yea a switch number on the interface would make sense except for OP showing range g0/49 - 52 and g0/51 - 52 appeared to have been accepted.

The 2960X's I have configured show this as the interface

interface GigabitEthernet1/0/5

Also the above was for a 3560 I think, or at least the host name was setup that way.

If he would post the output of show run for one of the interfaces we would be able to help.

 

Mike

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: