cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Join Customer Connection to register!
612
Views
0
Helpful
5
Replies
Highlighted
Beginner

Problem with IP-helper.. I am stumped.

So this started suddenly after working for about a year. Clients are not getting IP addresses. We are using IP-helper for dhcp relaying. We are using 3750s across the board BUT we have an MPLS network between the client switch and the server switch.  I have enabled debug and get this. It looks like it is forwarding the request but not getting anywhere afterwards. I had enabled debug IP udp but it didnt show anything.

Mar 11 16:52:19.611: DHCPD: Reload workspace interface Vlan2 tableid 0.

Mar 11 16:52:19.611: DHCPD: tableid for 172.18.2.3 on Vlan2 is 0

Mar 11 16:52:19.611: DHCPD: client's VPN is .

Mar 11 16:52:19.611: DHCPD: using received relay info.

Mar 11 16:52:19.611: DHCPD: DHCPDISCOVER received from client 013c.970e.3165.53 on interface Vlan2.

Mar 11 16:52:19.611: DHCPD: using received relay info.

Mar 11 16:52:19.611: DHCPD: Looking up binding using address 172.18.2.3

Mar 11 16:52:19.611: DHCPD: setting giaddr to 172.18.2.3.

Mar 11 16:52:19.611: DHCPD: BOOTREQUEST from 013c.970e.3165.53 forwarded to 10.33.11.21.

Sniffing 10.33.11.21 shows it is not getting discover requests form the giaddress. (it is from other vlans on other switches and is working fine there)

Rebooting the switch didnt help. dont know what else to try :/

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted

If the DHCP server is not getting the request then most likely the packet was lost in transit? IS there a firewall between the client and DHCP server?

 

Could you please post the running config of your switch? Just remove the sensitive lines i.e. username/password/snmp/etc.

Please rate replies and mark question as "answered" if applicable.

View solution in original post

5 REPLIES 5
Highlighted
Enthusiast

Conduct a packet capture on the DHCP server, check if it is receiving and replying to the request.

Please rate replies and mark question as "answered" if applicable.
Highlighted

Hey Rejohn.. so sorry.. I should have included that I did that and did NOT get any traffic on the dhcp server..  

The DHCP server servers several switches and vlans and wireshark shows requests from all the vlan interfaces except for the ones on the switch in question.

Highlighted

If the DHCP server is not getting the request then most likely the packet was lost in transit? IS there a firewall between the client and DHCP server?

 

Could you please post the running config of your switch? Just remove the sensitive lines i.e. username/password/snmp/etc.

Please rate replies and mark question as "answered" if applicable.

View solution in original post

Highlighted

Sure. There is no firewalls in the path. There is an MPLS network between the switch and the dhcp server.. .

workstation <->3750 w/DHCP Relay <->Router<->MPLS<->Router<->3750<-> DHCP

Has been working fine for over a year now. Talked to the MPLS provider and they see no issues on their hardware

 

 

errdisable recovery cause udld

errdisable recovery cause bpduguard

errdisable recovery cause security-violation

errdisable recovery cause channel-misconfig (STP)

errdisable recovery cause pagp-flap

errdisable recovery cause dtp-flap

errdisable recovery cause link-flap

errdisable recovery cause sfp-config-mismatch

errdisable recovery cause gbic-invalid

errdisable recovery cause l2ptguard

errdisable recovery cause psecure-violation

errdisable recovery cause port-mode-failure

errdisable recovery cause dhcp-rate-limit

errdisable recovery cause pppoe-ia-rate-limit

errdisable recovery cause mac-limit

errdisable recovery cause vmps

errdisable recovery cause storm-control

errdisable recovery cause inline-power

errdisable recovery cause arp-inspection

errdisable recovery cause loopback

errdisable recovery cause small-frame

!

vlan internal allocation policy ascending

!

!

class-map match-all AUTOQOS_VOIP_DATA_CLASS

match ip dscp ef

class-map match-all AUTOQOS_DEFAULT_CLASS

match access-group name AUTOQOS-ACL-DEFAULT

class-map match-all AUTOQOS_VOIP_SIGNAL_CLASS

match ip dscp cs3

!

!

policy-map AUTOQOS-SRND4-CISCOPHONE-POLICY

class AUTOQOS_VOIP_DATA_CLASS

set dscp ef

police 128000 8000 exceed-action policed-dscp-transmit

class AUTOQOS_VOIP_SIGNAL_CLASS

set dscp cs3

police 32000 8000 exceed-action policed-dscp-transmit

class AUTOQOS_DEFAULT_CLASS

set dscp default

police 10000000 8000 exceed-action policed-dscp-transmit

!

!

!

interface FastEthernet0

no ip address

no ip route-cache cef

no ip route-cache

no ip mroute-cache

shutdown

!

interface GigabitEthernet0/1

switchport access vlan 2

switchport trunk encapsulation dot1q

switchport trunk native vlan 2

switchport trunk allowed vlan 2,31

switchport mode trunk

switchport voice vlan 31

srr-queue bandwidth share 1 30 35 5

priority-queue out

mls qos trust device cisco-phone

mls qos trust cos

auto qos voip cisco-phone

storm-control broadcast level 1.00

storm-control action shutdown

spanning-tree portfast

spanning-tree bpduguard enable

spanning-tree guard root

service-policy input AUTOQOS-SRND4-CISCOPHONE-POLICY

!

! ect etc etc

interface GigabitEthernet0/47

description MPLS

switchport access vlan 102

switchport mode access

storm-control broadcast level 1.00

storm-control action shutdown

!

interface Vlan1

ip address 10.43.40.1 255.255.255.0

!

interface Vlan2

ip address 172.8.2.3 255.255.255.0

ip helper-address 10.40.11.21

ip helper-address 10.42.11.21

!

interface Vlan31

ip address 172.8.1.3 255.255.255.0

ip helper-address 10.42.11.21

ip helper-address 10.40.11.21

!

interface Vlan44

description BAY_EXT

ip address 172.29.44.2 255.255.255.0

!

interface Vlan102

description VLAN_MPLS

ip address 172.18.1.26 255.255.255.248

ip ospf hello-interval 5

!

router ospf 1

log-adjacency-changes

auto-cost reference-bandwidth 10000

redistribute static metric 1000 subnets

network 10.43.0.0 0.0.255.255 area 0

network 172.18.1.26 0.0.0.0 area 0

network 172.8.1.0 0.0.0.255 area 0

network 172.8.2.0 0.0.0.255 area 0

network 172.9.44.0 0.0.0.255 area 0

!

ip classless

ip route 0.0.0.0 0.0.0.0 172.18.1.25

ip http server

ip http secure-server

!

ip access-list extended AUTOQOS-ACL-DEFAULT

permit ip any any

Highlighted

Ok.. forgot to update this.. sorry. SO we have our hardware.. our ISP has their hardware.. but they were using another provider in that city and the OTHER ISP did a maintenance that killed our DHCP.. they fixed it and everythign worked.. thanks all!

Content for Community-Ad