cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
2533
Views
0
Helpful
3
Replies
Highlighted
Beginner

Problem with "switchport trunk allowed vlan add"

I'm using a SG300-52MP Cisco Layer 3 switch.

Here is the situation - each port is configured with "switchport trunk allowed vlan add 10" (vlan 1 is the default and vlan 10 is our voice vlan).

When the phone boots up - it seems to encounter a broadcast storm (???) the port goes from this:

interface gigabitethernet36

switchport trunk allowed vlan add 10

to this:

interface gigabitethernet36

storm-control broadcast enable

storm-control broadcast level 10

storm-control include-multicast

port security max 10

port security mode max-addresses

port security discard trap 60

spanning-tree portfast

switchport trunk allowed vlan add 10

macro description ip_phone

!next command is internal.

macro auto smartport dynamic_type ip_phone

Then in a minute or two I'm no longer able to ping the voicelan - and when I do a show run - gi36 isn't even visible.  However, the PC that is also on gi36 works fine.

If I then reissue the 'switchport trunk allowed vlan add 10' to gi36 - the phone is pingable - and works continuously until the phone is rebooted. 

Has anyone encountered this situation before and know how to resolve it? My config is below - any help would be greatly appreciated.

Thanks,

-mjg

config-file-header

switch43f66d

v1.3.0.62 / R750_NIK_1_3_647_260

CLI v1.0

set system mode router

file SSD indicator encrypted

@

ssd-control-start

ssd config

ssd file passphrase control unrestricted

no ssd file integrity control

ssd-control-end

!

cdp pdu filtering

no cdp run

no cdp appliance-tlv enable

vlan database

vlan 10

exit

voice vlan id 10

voice vlan oui-table add 0001e3 Siemens_AG_phone________

voice vlan oui-table add 00036b Cisco_phone_____________

voice vlan oui-table add 00096e Avaya___________________

voice vlan oui-table add 000fe2 H3C_Aolynk______________

voice vlan oui-table add 0060b9 Philips_and_NEC_AG_phone

voice vlan oui-table add 00d01e Pingtel_phone___________

voice vlan oui-table add 00e075 Polycom/Veritel_phone___

voice vlan oui-table add 00e0bb 3Com_phone______________

ip dhcp relay address 192.168.1.11

ip dhcp relay enable

hostname switch43f66d

!

interface vlan 1

ip address 192.168.1.5 255.255.255.0

no ip address dhcp

ip dhcp relay enable

!

interface vlan 10

ip address 192.168.99.1 255.255.255.0

ip dhcp relay enable

!

interface gigabitethernet1-48

switchport trunk allowed vlan add 10

!

interface gigabitethernet49

spanning-tree link-type point-to-point

switchport trunk allowed vlan add 10

macro description switch

!next command is internal.

macro auto smartport dynamic_type switch

!

exit

no macro auto processing cdp

ip default-gateway 192.168.1.1

3 REPLIES 3
Highlighted
Beginner

Not sure if this helps or not - but the phone worked perfectly all week until the switch had to be rebooted.  Upon reboot, the same thing as above happened.  To get the phone working, all I had to do was issue the 'switchport trunk allowed vlan add 10'.

Any suggestions?

Highlighted

Hi,

did you save your running config after  adding this command ?

Regards

Alain

Don't forget to rate helpful posts.

Don't forget to rate helpful posts.
Highlighted

Thanks for the reply - yes I did save it.  All the other ports have the command.  But when the phone boots up - it ends up disappearing after the above occurs:

When the phone boots up - it seems to encounter a broadcast storm (???) the port goes from this:

interface gigabitethernet36

switchport trunk allowed vlan add 10

to this:

interface gigabitethernet36

storm-control broadcast enable

storm-control broadcast level 10

storm-control include-multicast

port security max 10

port security mode max-addresses

port security discard trap 60

spanning-tree portfast

switchport trunk allowed vlan add 10

macro description ip_phone

!next command is internal.

macro auto smartport dynamic_type ip_phone

Then in a minute or two I'm no longer able to ping the voicelan - and when I do a show run - gi36 isn't even visible.  However, the PC that is also on gi36 works fine.

If I then reissue the 'switchport trunk allowed vlan add 10' to gi36 - the phone is pingable - and works continuously until the phone is rebooted.

So I'm not really sure what happens during the bootup that causes this to happen, or a way to try and prevent it from occuring.

Content for Community-Ad