cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
440
Views
15
Helpful
3
Replies

Problem with VPC between C9500 and N5K

mfilser
Beginner
Beginner

Hi all.

I have a problem between Nexus 5K and Catalyst 9500 (C9500-48Y4C / Stack Wise Virtual).
The VPC is reporting an error (vpc port channel mis-config due to vpc links in the 2 switches connected to different partners)
The N5K's were connected to a C6509-VSS-system and I've replaced it by C9500-Stack-Wise-Virtual.
Connected to the C6509, the VPC was working fine. But now I have an error.
It seems, the C9500 is reporting two different mac-adresses to the N5K's.

I've controlled the configuration, but I can't find any misconfiguration.
On N5K the configuration was not changed. On C9500 booth links are configured identical and bundeled into a port-channel.
Mode is configured as activ.

The solution about this issue I found in the Internet, is to shut/no shut the port-channel on C9500-site. But this is not an option,
because I can't interrupt the traffic to the server-farm behind the N5K's (live operation).

Is there a possibility to bring up the VPC without interrupting the connection?

I would be able to establish a second VPC between the Systems, but I'm not really familiar with Nexus. So I would need a "How-To" to configure it and step-by-step for a non-interrupting-operation.

If you need additional information, please let me know.


Hope, someone can help

 

Best regards

Markus

 

 

Here you will find some informations:


C9500# ==> Cisco IOS XE Software, Version 16.12.04
==> Model Number: C9500-48Y4C

C9500# sh run int po126

interface Port-channel126
description Uplink_DAC
switchport mode trunk

sh run int twe 1/0/43 (identical to 2/0/43)

interface TwentyFiveGigE1/0/43
description Uplink_DAC
switchport mode trunk
channel-group 126 mode active


#######################################

 

C9500# sh lacp 126 neigh

sh lacp 126 neigh
Flags: S - Device is requesting Slow LACPDUs
F - Device is requesting Fast LACPDUs
A - Device is in Active mode P - Device is in Passive mode

Channel group 126 neighbors

LACP port Admin Oper Port Port
Port Flags Priority Dev ID Age key Key Number State
Twe1/0/43 SA 32768 0023.04ee.be65 28s 0x0 0x802B 0x12B 0x3D
Twe2/0/43 SP 0 0000.0000.0000 856328s 0x0 0x0 0x0 0x0


###########################################

 

 

###########################################
Nexus 5K 01 and Nexus 5K 02
###########################################

Software
BIOS: version 2.1.7
Power Sequencer Firmware:
Module 1: v4.0
Module 1: v4.0
Fabric Power Sequencer Firmware: Module 1: version v4.0
Microcontroller Firmware: version v0.0.0.15
QSFP Microcontroller Firmware:
Module 1: v2.0.0.0
SFP Microcontroller Firmware:
Module 1: v1.3.0.0
CXP Microcontroller Firmware:
Module not detected
kickstart: version 7.3(5)N1(1)
system: version 7.3(5)N1(1)
BIOS compile time: 06/16/2016
kickstart image file is: bootflash:///n6000-uk9-kickstart.7.3.5.N1.1.bin
kickstart compile time: 2/11/2019 2:00:00 [02/11/2019 16:36:57]
system image file is: bootflash:///n6000-uk9.7.3.5.N1.1.bin
system compile time: 2/11/2019 2:00:00 [02/11/2019 16:38:54]


Hardware
cisco Nexus 5672UP Chassis ("Nexus 5672UP Supervisor")
Intel(R) Xeon(R) CPU @ 1.80 with 8243276 kB of memory.
Processor Board ID FOC22362EVZ

Device name: xxxxxxxx
bootflash: 7208960 kB

Kernel uptime is 700 day(s), 22 hour(s), 47 minute(s), 22 second(s)

Last reset at 336703 usecs after Mon Jun 10 09:26:28 2019

Reason: Disruptive upgrade
System version: 7.3(3)N1(1)
Service:

plugin
Core Plugin, Ethernet Plugin

Active Package(s)


############################################################################

 

N5K_01# sh vpc brief
Legend:
(*) - local vPC is down, forwarding via vPC peer-link

vPC domain id : 101
Peer status : peer adjacency formed ok
vPC keep-alive status : peer is alive
Configuration consistency status : success
Per-vlan consistency status : success
Type-2 consistency status : success
vPC role : primary
Number of vPCs configured : 15
Peer Gateway : Enabled
Peer gateway excluded VLANs : -
Dual-active excluded VLANs : -
Graceful Consistency Check : Enabled
Operational Layer3 Peer-router : Enabled
Auto-recovery status : Enabled (timeout = 240 seconds)

vPC Peer-link status
---------------------------------------------------------------------
id Port Status Active vlans
-- ---- ------ --------------------------------------------------
1 Po100 up 1-2,10,35,85,100,108,136,151,156,177-178,200,2061-
2062,3000,3004,3008,3099

vPC status
----------------------------------------------------------------------------
id Port Status Consistency Reason Active vlans
------ ----------- ------ ----------- -------------------------- -----------
1 Po1 up success success 1-2,10,35,8
5,100,108,1
51,177-178,
200,2061-20
62
3 Po3 up success success 1-2,10,35,8
5,100,108,1
51,177-178,
200,2061-20
62
43 Po43 up success success 1-2,10,35,8
5,100,108,1
36,151,156,
177-178,200
,2061-20....

.
.
.

################################################################################################################

 


N5K_02# sh vpc brief
Legend:
(*) - local vPC is down, forwarding via vPC peer-link

vPC domain id : 101
Peer status : peer adjacency formed ok
vPC keep-alive status : peer is alive
Configuration consistency status : success
Per-vlan consistency status : success
Type-2 consistency status : success
vPC role : secondary
Number of vPCs configured : 15
Peer Gateway : Enabled
Peer gateway excluded VLANs : -
Dual-active excluded VLANs : -
Graceful Consistency Check : Enabled
Operational Layer3 Peer-router : Enabled
Auto-recovery status : Enabled (timeout = 240 seconds)

vPC Peer-link status
---------------------------------------------------------------------
id Port Status Active vlans
-- ---- ------ --------------------------------------------------
1 Po100 up 1-2,10,35,85,100,108,136,151,156,177-178,200,2061-
2062,3000,3004,3008,3099

vPC status
----------------------------------------------------------------------------
id Port Status Consistency Reason Active vlans
------ ----------- ------ ----------- -------------------------- -----------
1 Po1 up success success 1-2,10,35,8
5,100,108,1
51,177-178,
200,2061-20
62
3 Po3 up success success 1-2,10,35,8
5,100,108,1
51,177-178,
200,2061-20
62
43 Po43 down* failed vpc port channel -
mis-config due to vpc
links in the 2 switches
connected to different
partners

.
.
.


################################################################################################################

 

N5K_01 and N5K_02

sh run int po43
interface port-channel43
description Uplink_Core
switchport mode trunk
switchport trunk allowed vlan 1-2,10,35,85,100,108,136,151,156,177-178,200,2061-2062,3000,30
04,3099
speed 10000
vpc 43


sh run int Eth1/43
interface Ethernet1/43
description Uplink_Core
switchport mode trunk
switchport trunk allowed vlan 1-2,10,35,85,100,108,136,151,156,177-178,200,2061-2062,3000,30
04,3099
channel-group 43 mode active


N5K_01# sh lacp port-channel
port-channel43
System Mac=0-3a-9c-26-47-c1
Local System Identifier=0x8000,0-3a-9c-26-47-c1
Admin key=0x802b
Operational key=0x802b
Partner System Identifier=0x8000,cc-7f-76-43-c0-c0
Operational key=0x7e
Max delay=0
Aggregate or individual=0
Member Port List=43

N5K_02# sh lacp port-channel ==> no information about lacp (because link Eth1/43 is suspended by vpc)

 

 

 

 

3 Replies 3

marce1000
VIP Mentor VIP Mentor
VIP Mentor

 

 Ref : https://community.cisco.com/t5/server-networking/has-anybody-seen-this-vpc-error-on-the-5k/td-p/1417364

                      Check if the Resolving-reply of this thread can be applied to your case.

 M.

Hi.

Thx for the answer.

But it's not an option, because it will interrupt the traffic. And I'm searching for a solution without any cut ....

 

Best regards

 

Markus

 

 - Afraid it looks quite  indicative it may be required, for business-continuity launch case with TAC and state your business-needs on this matter.

 M.

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers