cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Join Customer Connection to register!
1390
Views
0
Helpful
8
Replies
DaeHeon Kang
Beginner

Problem with vPC

I currently test vPC on the base of lab. The vPC status shows it as "down" from the output of command "show vpc" and the status of etherchannel from L3 switch connecting to the vPC link shows it as (w).

Any points or tickets for this issue?

The followings are the diagram of the lab and outputs from commands of Nexus switches and L3 switches.

 

vPC test.jpgsd

Switch#show etherchannel summary
Flags: D - down P - bundled in port-channel
I - stand-alone s - suspended
H - Hot-standby (LACP only)
R - Layer3 S - Layer2
U - in use f - failed to allocate aggregator

M - not in use, minimum links not met
u - unsuitable for bundling
w - waiting to be aggregated
d - default port


Number of channel-groups in use: 1
Number of aggregators: 1

Group Port-channel Protocol Ports
------+-------------+-----------+-----------------------------------------------
2 Po2(SU) LACP Et0/0(w) Et0/1(w)

 

NX9K_1# show vpc
Legend:
(*) - local vPC is down, forwarding via vPC peer-link

vPC domain id : 100
Peer status : peer adjacency formed ok
vPC keep-alive status : peer is alive
Configuration consistency status : success
Per-vlan consistency status : success
Type-2 consistency status : success
vPC role : primary
Number of vPCs configured : 1
Peer Gateway : Disabled
Dual-active excluded VLANs : -
Graceful Consistency Check : Enabled
Auto-recovery status : Disabled
Delay-restore status : Timer is off.(timeout = 30s)
Delay-restore SVI status : Timer is off.(timeout = 10s)
Operational Layer3 Peer-router : Disabled

vPC Peer-link status
---------------------------------------------------------------------
id Port Status Active vlans
-- ---- ------ -------------------------------------------------
1 Po1 up 1

vPC status
----------------------------------------------------------------------------
Id Port Status Consistency Reason Active vlans
-- ------------ ------ ----------- ------ ---------------
2 Po2 down* success success -

Please check "show vpc consistency-parameters vpc <vpc-num>" for the
consistency reason of down vpc and for type-2 consistency reasons for
any vpc.

 

NX9K_2# show vpc
Legend:
(*) - local vPC is down, forwarding via vPC peer-link

vPC domain id : 100
Peer status : peer adjacency formed ok
vPC keep-alive status : peer is alive
Configuration consistency status : success
Per-vlan consistency status : success
Type-2 consistency status : success
vPC role : secondary
Number of vPCs configured : 1
Peer Gateway : Disabled
Dual-active excluded VLANs : -
Graceful Consistency Check : Enabled
Auto-recovery status : Disabled
Delay-restore status : Timer is off.(timeout = 30s)
Delay-restore SVI status : Timer is off.(timeout = 10s)
Operational Layer3 Peer-router : Disabled

vPC Peer-link status
---------------------------------------------------------------------
id Port Status Active vlans
-- ---- ------ -------------------------------------------------
1 Po1 up 1

vPC status
----------------------------------------------------------------------------
Id Port Status Consistency Reason Active vlans
-- ------------ ------ ----------- ------ ---------------
2 Po2 down* success success -

Please check "show vpc consistency-parameters vpc <vpc-num>" for the
consistency reason of down vpc and for type-2 consistency reasons for
any vpc.

 

NX9K_1# show vpc consistency-parameters global

Legend:
Type 1 : vPC will be suspended in case of mismatch

Name Type Local Value Peer Value
------------- ---- ---------------------- -----------------------
QoS (Cos) 2 ([0-7], [], [], [], ([0-7], [], [], [],
[], []) [], [])
Network QoS (MTU) 2 (1500, 1500, 1500, (1500, 1500, 1500,
1500, 0, 0) 1500, 0, 0)
Network Qos (Pause: 2 (F, F, F, F, F, F) (F, F, F, F, F, F)
T->Enabled, F->Disabled)
Input Queuing (Bandwidth) 2 (0, 0, 0, 0, 0, 0) (0, 0, 0, 0, 0, 0)
Input Queuing (Absolute 2 (F, F, F, F, F, F) (F, F, F, F, F, F)
Priority: T->Enabled,
F->Disabled)
Output Queuing (Bandwidth 2 (100, 0, 0, 0, 0, 0) (100, 0, 0, 0, 0, 0)
Remaining)
Output Queuing (Absolute 2 (F, F, F, T, F, F) (F, F, F, T, F, F)
Priority: T->Enabled,
F->Disabled)
Vlan to Vn-segment Map 1 No Relevant Maps No Relevant Maps
STP Mode 1 Rapid-PVST Rapid-PVST
STP Disabled 1 None None
STP MST Region Name 1 "" ""
STP MST Region Revision 1 0 0
STP MST Region Instance to 1
VLAN Mapping
STP Loopguard 1 Disabled Disabled
STP Bridge Assurance 1 Enabled Enabled
STP Port Type, Edge 1 Normal, Disabled, Normal, Disabled,
BPDUFilter, Edge BPDUGuard Disabled Disabled
STP MST Simulate PVST 1 Enabled Enabled
Nve Admin State, Src Admin 1 None None
State, Secondary IP, Host
Reach Mode
Nve Vni Configuration 1 None None
Allowed VLANs - 1 1
Local suspended VLANs - - -

 

 

NX9K_2# show vpc consistency-parameters global

Legend:
Type 1 : vPC will be suspended in case of mismatch

Name Type Local Value Peer Value
------------- ---- ---------------------- -----------------------
QoS (Cos) 2 ([0-7], [], [], [], ([0-7], [], [], [],
[], []) [], [])
Network QoS (MTU) 2 (1500, 1500, 1500, (1500, 1500, 1500,
1500, 0, 0) 1500, 0, 0)
Network Qos (Pause: 2 (F, F, F, F, F, F) (F, F, F, F, F, F)
T->Enabled, F->Disabled)
Input Queuing (Bandwidth) 2 (0, 0, 0, 0, 0, 0) (0, 0, 0, 0, 0, 0)
Input Queuing (Absolute 2 (F, F, F, F, F, F) (F, F, F, F, F, F)
Priority: T->Enabled,
F->Disabled)
Output Queuing (Bandwidth 2 (100, 0, 0, 0, 0, 0) (100, 0, 0, 0, 0, 0)
Remaining)
Output Queuing (Absolute 2 (F, F, F, T, F, F) (F, F, F, T, F, F)
Priority: T->Enabled,
F->Disabled)
Vlan to Vn-segment Map 1 No Relevant Maps No Relevant Maps
STP Mode 1 Rapid-PVST Rapid-PVST
STP Disabled 1 None None
STP MST Region Name 1 "" ""
STP MST Region Revision 1 0 0
STP MST Region Instance to 1
VLAN Mapping
STP Loopguard 1 Disabled Disabled
STP Bridge Assurance 1 Enabled Enabled
STP Port Type, Edge 1 Normal, Disabled, Normal, Disabled,
BPDUFilter, Edge BPDUGuard Disabled Disabled
STP MST Simulate PVST 1 Enabled Enabled
Nve Admin State, Src Admin 1 None None
State, Secondary IP, Host
Reach Mode
Nve Vni Configuration 1 None None
Allowed VLANs - 1 1
Local suspended VLANs - - -

 

 

NX9K_1# show vpc consistency-parameters vpc 2

Legend:
Type 1 : vPC will be suspended in case of mismatch

Name Type Local Value Peer Value
------------- ---- ---------------------- -----------------------
STP Port Type 1 Default Default
STP Port Guard 1 Default Default
STP MST Simulate PVST 1 Default Default
vPC card type 1 N9K TOR N9K TOR
Allowed VLANs - 1-4094 1-4094
Local suspended VLANs - - -

 

NX9K_2# show vpc consistency-parameters vpc 2

Legend:
Type 1 : vPC will be suspended in case of mismatch

Name Type Local Value Peer Value
------------- ---- ---------------------- -----------------------
STP Port Type 1 Default Default
STP Port Guard 1 Default Default
STP MST Simulate PVST 1 Default Default
vPC card type 1 N9K TOR N9K TOR
Allowed VLANs - 1-4094 1-4094
Local suspended VLANs - - -

 

NX9K_1# show run int port-channel 2

!Command: show running-config interface port-channel2
!Time: Fri Nov 3 01:13:47 2017

version 7.0(3)I5(1)

interface port-channel2
switchport mode trunk
vpc 2

 

NX9K_2# show run int port-channel 2

!Command: show running-config interface port-channel2
!Time: Fri Nov 3 01:14:05 2017

version 7.0(3)I5(1)

interface port-channel2
switchport mode trunk
vpc 2

 

 

Switch#show run int port-channel 2
Building configuration...

Current configuration : 104 bytes
!
interface Port-channel2
switchport
switchport trunk encapsulation dot1q
switchport mode trunk
end

8 REPLIES 8
Reza Sharifi
Hall of Fame Expert

Can you post "sh run" from both switches?

 

The followings are the output from "show run"

 

NX9K_1# show run

!Command: show running-config
!Time: Fri Nov 3 01:33:51 2017

version 7.0(3)I5(1)
power redundancy-mode combined force

hostname NX9K_1
vdc NX9K_1 id 1
limit-resource vlan minimum 16 maximum 4094
limit-resource vrf minimum 2 maximum 4096
limit-resource port-channel minimum 0 maximum 511
limit-resource u4route-mem minimum 248 maximum 248
limit-resource u6route-mem minimum 96 maximum 96
limit-resource m4route-mem minimum 58 maximum 58
limit-resource m6route-mem minimum 8 maximum 8

cfs eth distribute
feature lacp
feature vpc

username admin password 5 $5$KgXKlfjC$JHebppf4aQMhD4lCixTP8XAdPlEMp5nPdixbqUvr65
4 role network-admin
ip domain-lookup
snmp-server user admin network-admin auth md5 0xa029b397099702ec108eed698125288d
priv 0xa029b397099702ec108eed698125288d localizedkey
rmon event 1 description FATAL(1) owner PMON@FATAL
rmon event 2 description CRITICAL(2) owner PMON@CRITICAL
rmon event 3 description ERROR(3) owner PMON@ERROR
rmon event 4 description WARNING(4) owner PMON@WARNING
rmon event 5 description INFORMATION(5) owner PMON@INFO

vlan 1

vrf context management
vrf context vpc
vpc domain 100
peer-keepalive destination 10.1.1.2 source 10.1.1.1 vrf vpc

interface port-channel1
switchport mode trunk
spanning-tree port type network
vpc peer-link

interface port-channel2
switchport mode trunk
vpc 2

interface Ethernet1/1
no switchport
vrf member vpc
ip address 10.1.1.1/30
no shutdown

interface Ethernet1/2
switchport mode trunk
channel-group 1 mode active

interface Ethernet1/3
switchport mode trunk
channel-group 1 mode active

interface Ethernet1/4
switchport mode trunk
channel-group 2 mode active

interface Ethernet1/5

interface Ethernet1/6

interface Ethernet1/7

interface Ethernet1/8

interface Ethernet1/9

interface mgmt0
vrf member management
line console
line vty
boot nxos bootflash:/nxos.7.0.3.I5.1.bin

 

NX9K_2# show run

!Command: show running-config
!Time: Fri Nov 3 01:34:51 2017

version 7.0(3)I5(1)
power redundancy-mode combined force

hostname NX9K_2
vdc NX9K_2 id 1
limit-resource vlan minimum 16 maximum 4094
limit-resource vrf minimum 2 maximum 4096
limit-resource port-channel minimum 0 maximum 511
limit-resource u4route-mem minimum 248 maximum 248
limit-resource u6route-mem minimum 96 maximum 96
limit-resource m4route-mem minimum 58 maximum 58
limit-resource m6route-mem minimum 8 maximum 8

cfs eth distribute
feature lacp
feature vpc

username admin password 5 $5$0jE4t.7T$6MPYE4.IaQp.jpK2Ai2QxHUiRJ87ybos2JyAgQB4U1
0 role network-admin
ip domain-lookup
snmp-server user admin network-admin auth md5 0xd00e889e95429ac0d902a738b3796d1d
priv 0xd00e889e95429ac0d902a738b3796d1d localizedkey
rmon event 1 description FATAL(1) owner PMON@FATAL
rmon event 2 description CRITICAL(2) owner PMON@CRITICAL
rmon event 3 description ERROR(3) owner PMON@ERROR
rmon event 4 description WARNING(4) owner PMON@WARNING
rmon event 5 description INFORMATION(5) owner PMON@INFO

vlan 1

vrf context management
vrf context vpc
vpc domain 100
peer-keepalive destination 10.1.1.1 source 10.1.1.2 vrf vpc

interface port-channel1
switchport mode trunk
spanning-tree port type network
vpc peer-link

interface port-channel2
switchport mode trunk
vpc 2

interface Ethernet1/1
no switchport
vrf member vpc
ip address 10.1.1.2/30
no shutdown

interface Ethernet1/2
switchport mode trunk
channel-group 1 mode active

interface Ethernet1/3
switchport mode trunk
channel-group 1 mode active

interface Ethernet1/4
switchport mode trunk
channel-group 2 mode active

interface Ethernet1/5

interface Ethernet1/6

interface Ethernet1/7

interface Ethernet1/8

interface Ethernet1/9

interface mgmt0
vrf member management
line console
line vty
boot nxos bootflash:/nxos.7.0.3.I5.1.bin

 

 

Switch#show run
Building configuration...

Current configuration : 1018 bytes
!
! Last configuration change at 01:14:37 EET Fri Nov 3 2017
!
version 15.1
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
service compress-config
!
hostname Switch
!
boot-start-marker
boot-end-marker
!
!
!
no aaa new-model
clock timezone EET 2 0
!
ip cef
!
!
no ipv6 cef
ipv6 multicast rpf use-bgp
!
!
!
!
!
!
!
spanning-tree mode pvst
spanning-tree extend system-id
!
!
!
!
vlan internal allocation policy ascending
!
!
!
!
!
!
!
!
!
!
interface Port-channel2
switchport
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface Ethernet0/0
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 2 mode active
!
interface Ethernet0/1
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 2 mode active
!
interface Ethernet0/2
duplex auto
!
interface Ethernet0/3
duplex auto
!
!
no ip http server
!
!
!
!
!
control-plane
!
!
line con 0
logging synchronous
line aux 0
line vty 0 4
login
!
end

Can you test using the global routing table for the vpc peering and the interface(no vrf)?

It appears the keep-alive with VRF is fine as the following command output. Is there any thing to cause this problem regarding VRF? 

 

NX9K_1# show vpc peer-keepalive

vPC keep-alive status : peer is alive
--Peer is alive for : (10363) seconds, (372) msec
--Send status : Success
--Last send at : 2017.11.03 02:01:24 864 ms
--Sent on interface : Eth1/1
--Receive status : Success
--Last receive at : 2017.11.03 02:01:24 867 ms
--Received on interface : Eth1/1
--Last update from peer : (0) seconds, (957) msec

vPC Keep-alive parameters
--Destination : 10.1.1.2
--Keepalive interval : 1000 msec
--Keepalive timeout : 5 seconds
--Keepalive hold timeout : 3 seconds
--Keepalive vrf : vpc
--Keepalive udp port : 3200
--Keepalive tos : 192

When creating vPC, did you bring up the vpc-keep-alive link first?

It should be vpc-keep-alive

than

vpc peer-link

HTH

I configured it ( vPC domain -> vPC keepalive link -> vPC peer link -> vPC).

Anyway, I will try to configure as you mention.

( vPC domain -> vPC keepalive link -> vPC peer link -> vPC)

This is the correct order.

The result is same when I try to check first keepalive link up.