cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Cisco Community Designated VIP Class of 2020

135
Views
0
Helpful
2
Replies
Highlighted
Participant

QoS based on MAC address

I have a stack of 2960Xs that currently has QoS configured for voice traffic based on dscp.  I have been asked to extend this to a few IoT devices that are having issues w/ audio quality when traffic goes to internet.  I configured this on the stack:

 

mac access-list extended IoTTrustedDevices
  permit host 0001.0001.0005 any
  permit host 0001.0001.0006 any

 

class-map match-any IoTTrustedDevices_CM
  match access-group name IoTTrustedDevices

policy-map IoTTrustedDevices_PM
  class IoTTrustedDevices_CM
    set dscp ef
  class class-default

 

interface GigabitEthernet4/0/7
 description Connection to Phone or PC
 switchport access vlan 123
 switchport mode access
 switchport voice vlan 126
 srr-queue bandwidth share 1 30 35 5
 priority-queue out 
 mls qos trust cos
 auto qos trust
 spanning-tree portfast edge
 service-policy input IoTTrustedDevices_PM

 

I then have the upstream ASA set w/ priority queue and set to prioritize dscp ef but I'm getting reports that users are still having issues.  And when i issue a "show policy-map interface Gi4/0/7" I get the following as if it's not being hit at all.

 

GigabitEthernet4/0/7

 Service-policy input: IoTTrustedDevices_PM

  Class-map: IoTTrustedDevices_CM (match-any)
  0 packets, 0 bytes
  5 minute offered rate 0000 bps, drop rate 0000 bps
Match: access-group name IoTTrustedDevices
  0 packets, 0 bytes
  5 minute rate 0 bps

Class-map: class-default (match-any)
  0 packets, 0 bytes
  5 minute offered rate 0000 bps, drop rate 0000 bps
Match: any

 

Just wanted to know what i'm doing wrong in this case.

2 REPLIES 2
Cisco Employee

Re: QoS based on MAC address

Hi @mumbles202 ,

 

To manually match voice IP traffic, try using a standard or extended IP ACL in your class map, instead of the MAC ACL. MAC ACL would be for non ip traffic matching.

 

Configuration guide reference below:

https://www.cisco.com/c/en/us/td/docs/switches/lan/catalyst2960x/software/15-0_2_EX/qos/configuration_guide/b_qos_152ex_2960-x_cg/b_qos_152ex_2960-x_cg_chapter_010.html

 

Hope this helps!

 

Regards

 

Rob

Participant

Re: QoS based on MAC address

Thanks.  I updated the configuration like this:

 

access-list 50 permit 192.168.123.134
access-list 50 permit 192.168.123.166
access-list 50 permit 192.168.123.165
access-list 50 permit 192.168.123.169
access-list 50 permit 192.168.123.168

 

class-map match-any IoTTrustedDevices_CM_2
match access-group 50
!
policy-map IoTTrustedDevices_PM
  class IoTTrustedDevices_CM
     set dscp ef
  class IoTTrustedDevices_CM_2
     set dscp ef
  class class-default

 

But noticed i'm still not getting any increments on the counters.  I left the same service-policy in place on the interface since I just added the class to the existing policy-map.

CreatePlease to create content
Content for Community-Ad