07-23-2012 04:38 AM - edited 03-07-2019 07:55 AM
Hey Guys,
I'm in the process of configuring QOS on a 3560 routing switch in a GOLD, SILVER, BRONZE priority type scenario.
Firstly, I understand that this config will add a tag of "precedence 5" to a packet if it matches the "ACL_QOS_GOLD_In" access list. Question is does the router see this "precedence 5" tag and then sets the priority, or am I missing something in my config where at present it just sees the "precedence 5" and doesn’t act on it ?
Secondly, Since the "precedence 5" tag has already been added to the packets, do downstream routers see this tag and act accordingly or so I need to configure those is well ?
Here’s the coding
mls qos
interface GigabitEthernet0/1
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 52
switchport mode trunk
mls qos vlan-based
interface Vlan52
ip address 10.x.x.x 255.255.255.240
service-policy input PM_QOS_IN
class-map match-all CM_QOS_GOLD_In
match access-group name ACL_QOS_GOLD_In
policy-map PM_QOS_IN
class CM_QOS_GOLD_In
set precedence 5
ip access-list extended ACL_QOS_GOLD_In
permit ip host 192.168.1.52 10.70.0.0 0.0.1.255
permit ip host 192.168.1.53 10.70.0.0 0.0.1.255
permit ip host 192.168.1.54 10.70.0.0 0.0.1.255
permit ip any host 10.70.6.10
Many Thanks
07-23-2012 04:51 AM
Looks correct to me ....
http://www.cisco.com/en/US/docs/ios/qos/command/reference/qos_m2.html#wp1044534
Alessio
07-23-2012 07:31 AM
Disclaimer
The Author of this posting offers the information contained within this posting without consideration and with the reader's understanding that there's no implied or expressed suitability or fitness for any purpose. Information provided is for informational purposes only and should not be construed as rendering professional advice of any kind. Usage of this posting's information is solely at reader's own risk.
Liability Disclaimer
In no event shall Author be liable for any damages whatsoever (including, without limitation, damages for loss of use, data or profit) arising out of the use or inability to use the posting's information even if Author has been advised of the possibility of such damage.
Posting
Whether your 3560 will act on your IPPrec 5 setting depends on its configuration. "mls qos", alone, enables a default egress configuration, although don't recall what it uses, by default, for egress classification.
Regarding downstream devices, whether IPPrec 5 will be treated differently depends on those device configurations (and capabilities). Often the default is no special treatment.
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide