cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
770
Views
11
Helpful
7
Replies

QoS: Need help with MQS

haji_akhundov
Level 1
Level 1

Hello everyone!

I would like to know what I'm doing wrong here: on the serial interface I have this 'policy-map output serial' applied. Although I have specified bandwidth percent 50, it seems that it's using all 100. I later tried changing that value from 50 to 10, 20, 30 etc. and it's all the same. It just prioritizes all the DSCP af11 packets and ignores (sort of drops) all other unmarked packets. Is there something else that must be written in the class class-default?

p.s. I used jperf to check this.

Any help is appriciated!

class-map match-all dscpAF11

match  dscp af11

class-map match-all HI-PRI

match cos  5

!

policy-map serial

class dscpAF11

  bandwidth percent 50

class class-default

  fair-queue

policy-map marker

class HI-PRI

  set dscp af11

interface FastEthernet0/0.3

encapsulation dot1Q 3

ip address 192.168.1.1 255.255.255.0

service-policy input marker

!

interface FastEthernet0/1

no ip address

shutdown

duplex auto

speed auto

!

interface Serial0/0/0

ip address 172.23.0.2 255.255.255.252

service-policy output serial

!

7 Replies 7

cadet alain
VIP Alumni
VIP Alumni

Hi,

all this will do is guarantee 50 % of bandwidth to traffic marked with AF11 only in case of Congestion.

But as long as there is no congestion this will have no effect.

Regards.

Alain

Don't forget to rate helpful posts.

Don't forget to rate helpful posts.

Dear Alain,

I understand this. But why is it dropping all other traffic that is not marked with AF11?

Regards,

Haji

Hi,

what do you mean by that:

Post following sh policy-map interface f0/0.3 and sh policy-map interface s0/0/0

Regards.

Alain

Don't forget to rate helpful posts.

Don't forget to rate helpful posts.

Router1#show policy-map interface f0/0.3

FastEthernet0/0.3

  Service-policy input: marker

    Class-map: HI-PRI (match-all)

      5542530 packets, 2485604057 bytes

      5 minute offered rate 0 bps, drop rate 0 bps

      Match: cos  5

      QoS Set

        dscp af11

          Packets marked 5542530

    Class-map: class-default (match-any)

      88560 packets, 81356616 bytes

      5 minute offered rate 0 bps, drop rate 0 bps

      Match: any

Router1#show policy-map interface s0/0/0

Serial0/0/0

  Service-policy output: serial

    Class-map: dscpAF11 (match-all)

      4390915 packets, 1137861836 bytes

      5 minute offered rate 0 bps, drop rate 0 bps

      Match:  dscp af11 (10)

      Queueing

        Output Queue: Conversation 265

        Bandwidth 50 (%)

        Bandwidth 772 (kbps)Max Threshold 64 (packets)

        (pkts matched/bytes matched) 664061/935814284

        (depth/total drops/no-buffer drops) 0/0/0

    Class-map: class-default (match-any)

      51232 packets, 43152697 bytes

      5 minute offered rate 0 bps, drop rate 0 bps

      Match: any

      Queueing

        Flow Based Fair Queueing

        Maximum Number of Hashed Queues 256

        (total queued/total drops/no-buffer drops) 0/0/0

But nothing is running at the moment, I mean no data streams. Hope it helps you to help me

Hi,

I need these infos when you use jperf to do the Qos testing and also how you do the testing and what results you find abnormal.

Regards.

Alain

Don't forget to rate helpful posts.

Don't forget to rate helpful posts.

Dear Alain,

I have attached a file that shows how I did the testing and where I see abnormalities.

Thank you again.

Alain,

I fixed this issue by replacing this:

policy-map serial

class dscpAF11

  bandwidth percent 50

class class-default

  fair-queue


with

policy-map serial

class dscpAF11

  bandwidth percent 50

class class-default

  bandwidth percent 25

Now other unmarked packets don't get droped.

I would still like to know why wasn't it working previously. Also I am wondering should I have a parent policy that has a shaper? What are the benefits and usage of it?

Thanks

Review Cisco Networking products for a $25 gift card