cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
545
Views
30
Helpful
9
Replies
Richard Dumag
Beginner

QoS on 3750 switch

I did the following basic MQC entries on a switch to see if packets will be marked with af31:

mls qos

access-list 100 permit ip host 192.168.1.1 any

class-map match-all CLASS1

     match access-group 100

policy-map QOS1

     class CLASS1

     set dscp af31

service-policy input QOS1 (on interface g1/0/1)

Is this suppose to mark the packets (i.e icmp) with dscp af31?

Somehow I am not seeing the packets being marked.  They are marked with default value of 0.

Am I missing something?  Any comment is appreciated.

9 REPLIES 9
paul driver
VIP Mentor

Basically you are saying anything from host 192.168.1.1 to  any destination mark dscp of af31 ( dscp26) coming in on gig1/0/1

To see to qos being marked, setup a clasification on the destination host interface


class-map dscp

match dscp 26

policy-map TST

class dscp

int fa0/0

service-policy input TST

Sh policy-map interface fa0/0



kind regards
Paul

Please rate and mark posts accordingly if you have found any of the information provided useful.
It will hopefully assist others with similar issues in the future
Gabriel Hill
Beginner

access-list 100 permit ip host 192.168.1.1 any

As ICMP is part of "IP" your policy should be marking everything from 192.168.1.1 out with AF31.

On Catalyst, most if not all counters are retrieved from hardware (at least that is my understanding). I guess my question is how are you verifying if anything is getting marked with AF31?

Does a:  "show mls qos interface gig1/0/1 statistics" show anything?

Joseph W. Doherty
Hall of Fame Expert

Disclaimer

The  Author of this posting offers the information contained within this  posting without consideration and with the reader's understanding that  there's no implied or expressed suitability or fitness for any purpose.  Information provided is for informational purposes only and should not  be construed as rendering professional advice of any kind. Usage of this  posting's information is solely at reader's own risk.

Liability Disclaimer

In  no event shall Author be liable for any damages whatsoever (including,  without limitation, damages for loss of use, data or profit) arising out  of the use or inability to use the posting's information even if Author  has been advised of the possibility of such damage.

Posting

Do you have QoS enabled globally?

Thanks for the replies! 

Mls qos is enabled on the switch.  As I understand from following the QoS example configuration using MQC, set dscp af31 on the policy-map should mark any traffic coming in to the interface.

http://www.cisco.com/en/US/products/hw/switches/ps5023/products_tech_note09186a0080883f9e.shtml

I use wireshark to look at the icmp packet's dscp value, which is still marked with the default value (0).

I'm doing this test as I will need to implement QoS on 3750 switches that will be used for voice, video, and PCoIP devices.

Currently, auto QoS is the setting for voice.  With the addition of video and PCoIP, I'm thinking about using MQC.

paul driver
VIP Mentor

Richard,

Providing this is the only switch between the source and destination the qos marking will work, as you have enabled mls qos on the switch and specified traffic to be marked. The command i stated earlier was to for you verify the dscp marking as traffic originated from the switch with the newly assigned dscp marking to destination interface.

Another way is to capture is to apply an acl.

access-list 101 permit ip any any dscp
access-list 101 permit ip any any log

Int xx
access-group 101 in


Now if there are multiple switches with mls qos is enabled  then the default action is not to trust and to rewrite dscp value to 0, in this case you will have to specify to trust dscp so to allow the new qos marking or to turn off the rewrite of dscp for it to reach its destination without being overwritten.

res

Paul



kind regards
Paul

Please rate and mark posts accordingly if you have found any of the information provided useful.
It will hopefully assist others with similar issues in the future

Can you post the output of  show policy-map interface gig1/0/1

This will tell us if you have hits in the Class1

You could also test first without acl:

class-map match-all CLASS1

     match any

Please rate helpfull posts ;-)

Thanks again everyone for the replies! 

After connecting a second pc and setting the same policy on the port, I now see that packets are marked.  Initially I only had one pc and was pinging the loopback.  Ran a few tests by removing the policy and changing the dscp markings and everything tested successfully. 

The only issue now however is that the show policy-map interface output is showing 0 packets and 0 bytes.

Excellent news Richard - Would you please rate any of the answers if you think they assisted you.

res

Paul



kind regards
Paul

Please rate and mark posts accordingly if you have found any of the information provided useful.
It will hopefully assist others with similar issues in the future

Paul thanks for the reminder!  5 stars for everyone!