02-05-2009 09:47 AM - edited 03-06-2019 03:52 AM
Hi,
Please see attached diagram with setup.
Links between core and access layer switches, SwitchA and SwitchB, are configured in Port-channel, Here is the interfaces config:
SwitchA
interface GigabitEthernet1/0/49
switchport trunk encapsulation dot1q
switchport mode dynamic desirable
mls qos trust dscp
channel-group 10 mode active
interface GigabitEthernet1/0/50
switchport trunk encapsulation dot1q
switchport mode dynamic desirable
mls qos trust dscp
channel-group 10 mode active
interface Port-channel10
description ----- Channel to MILA-B-3750 -----
switchport trunk encapsulation dot1q
switchport mode dynamic desirable
SwitchB
interface GigabitEthernet1/0/1
switchport trunk encapsulation dot1q
switchport mode dynamic desirable
mls qos trust dscp
channel-group 10 mode active
interface GigabitEthernet3/0/1
switchport trunk encapsulation dot1q
switchport mode dynamic desirable
mls qos trust dscp
channel-group 10 mode active
interface Port-channel10
description ----- Channel to MILA-A-3750 -----
switchport trunk encapsulation dot1q
switchport mode dynamic desirable
We have a deal with MPLS service provider that we can configure QoS marking (DSCP) and they will trust that marking and usid with policy that prioritises traffic. This gives us quite a lot of flexibility.
We have a similar scenario in number of our offices and we have following approach in configuring QoS.
1) We configure policy map on acore switch - policy map marsk traffic
2) Then apply policy map outbound on interface towards MPLS provider router
However this approach is not applicable her because on 3750 switch I can not apply policy map outbound on interface. Therefore I have tried applying policy inbound on core switch to interfaces between core and access switch (to physical interfaces as applying policy map to port-channel interface is not suported on 3570. This would be appropriate as all WAN traffic which needs to be prioritised other then default, is initiated on hosts connected to access switch.
When I try to aply the policy to interfaces, I got following error message:
"Remove policy failed for interface GigabitEthernet1/0/49"
Here are relevant parts of the config:
ip access-list extended Business1 # this is for Video only
permit ip host A.B.C.D any
permit ip any host A.B.C.D
ip access-list extended Business2 # this is for Business Apps
permit tcp any any eq 3200
permit tcp any any eq 3300
permit tcp any any eq 8000
permit tcp any any eq 3600
permit tcp any any eq 8100
permit tcp any host A.B.C.D eq www
permit tcp any any eq 8470
permit tcp any any eq 8471
permit tcp any any eq 8472
permit tcp any any eq 8473
permit tcp any any eq 8474
permit tcp any any eq 8475
permit tcp any any eq 8476
permit tcp any any eq 446
permit tcp any any eq 447
permit tcp any any eq 448
permit tcp any any eq 1414
permit tcp any host A.B.C.D eq 1433
permit tcp any host A.B.C.D eq 1433
permit tcp any host A.B.C.D eq www
permit tcp any host A.B.C.D eq www
permit tcp any host A.B.C.D eq 3389
ip access-list extended Business3 # this is for WamNet
permit ip any host A.B.C.D
permit ip any host A.B.C.D
permit ip any host A.B.C.D
permit ip any host A.B.C.D
permit ip any host A.B.C.D
permit ip any host A.B.C.D
class-map match-any Business1Class
description video traffic class
match ip dscp af31
match access-group name Business1
class-map match-any Business2Class
description Business Apps traffic class
match access-group name Business2
match ip dscp af21
class-map match-any Business3Class
description WamNet traffic class
match access-group name Business3
match ip dscp af11
policy-map MPolicy
description QoS Policy for M
class Business1Class
set ip dscp af31
class Business2Class
set ip dscp af21
class Business3Class
set ip dscp af11
class class-default
Any idea how can I deal with this?
Thanks,
Sasa
02-05-2009 10:44 AM
If the packets coming frm the access 3750 have already have their DSCP marked and on the core which is the exit point to the MPLS provider router is already trusting these packets, why do you want to remark them again? It should just trust those DSCP and retain them. They should not get reset.
02-06-2009 04:13 AM
Hi bosalaza,
Thanks for your input.
Not all of the packets are marked, or are marked correctly, before reaching core router. Actually, only video packets are marked correctly (marked on Polycom Video Conference Units), while no other packets are marked.
I need to mark traffic going into WAN as per my access list/class map/policy map so I can control traffic and make sure business apps are protected from WamNet (huge file transfers with WamNet propriatory technology) and VCU traffic, while assuring that this traffic also get the allocated slice of bandwidth.
Regards,
Sasa
02-05-2009 11:34 AM
Based on 3750 QoS configuration guide, you can only use one "match" command in class-map.
"Only one ACL per class map and only one match class-map configuration command per class map are supported. The ACL can have multiple ACEs, which match fields against the contents of the packet. "
02-06-2009 04:27 AM
Hi kwu2,
Thanks for pointing this out. It definitely clarifies why my configuration does not work.
Any idea how I can implement the QoS, as per my requirement?
Regards,
Sasa
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide