cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1735
Views
0
Helpful
2
Replies

QoS on the 4510 SW.

sadik.bash
Level 1
Level 1

Hi all,

I am new to QoS but I fully understand the concept. I inherited 3750(Stacked) and have the following QoS statements that I need to implement on the 4510:

mls qos map cos-dscp 0 8 16 24 32 46 48 56
mls qos srr-queue input bandwidth 90 10
mls qos srr-queue input threshold 1 8 16
mls qos srr-queue input threshold 2 34 66
mls qos srr-queue input buffers 67 33
mls qos srr-queue input cos-map queue 1 threshold 2 1
mls qos srr-queue input cos-map queue 1 threshold 3 0
mls qos srr-queue input cos-map queue 2 threshold 1 2
mls qos srr-queue input cos-map queue 2 threshold 2 4 6 7
mls qos srr-queue input cos-map queue 2 threshold 3 3 5
mls qos srr-queue input dscp-map queue 1 threshold 2 9 10 11 12 13 14 15
mls qos srr-queue input dscp-map queue 1 threshold 3 0 1 2 3 4 5 6 7
mls qos srr-queue input dscp-map queue 1 threshold 3 32
mls qos srr-queue input dscp-map queue 2 threshold 1 16 17 18 19 20 21 22 23
mls qos srr-queue input dscp-map queue 2 threshold 2 33 34 35 36 37 38 39 48
mls qos srr-queue input dscp-map queue 2 threshold 2 49 50 51 52 53 54 55 56
mls qos srr-queue input dscp-map queue 2 threshold 2 57 58 59 60 61 62 63
mls qos srr-queue input dscp-map queue 2 threshold 3 24 25 26 27 28 29 30 31
mls qos srr-queue input dscp-map queue 2 threshold 3 40 41 42 43 44 45 46 47
mls qos srr-queue output cos-map queue 1 threshold 3 5
mls qos srr-queue output cos-map queue 2 threshold 3 3 6 7
mls qos srr-queue output cos-map queue 3 threshold 3 2 4
mls qos srr-queue output cos-map queue 4 threshold 2 1
mls qos srr-queue output cos-map queue 4 threshold 3 0
mls qos srr-queue output dscp-map queue 1 threshold 3 40 41 42 43 44 45 46 47
mls qos srr-queue output dscp-map queue 2 threshold 3 24 25 26 27 28 29 30 31
mls qos srr-queue output dscp-map queue 2 threshold 3 48 49 50 51 52 53 54 55
mls qos srr-queue output dscp-map queue 2 threshold 3 56 57 58 59 60 61 62 63
mls qos srr-queue output dscp-map queue 3 threshold 3 16 17 18 19 20 21 22 23
mls qos srr-queue output dscp-map queue 3 threshold 3 32 33 34 35 36 37 38 39
mls qos srr-queue output dscp-map queue 4 threshold 1 8
mls qos srr-queue output dscp-map queue 4 threshold 2 9 10 11 12 13 14 15
mls qos srr-queue output dscp-map queue 4 threshold 3 0 1 2 3 4 5 6 7
mls qos queue-set output 1 threshold 1 138 138 92 138
mls qos queue-set output 1 threshold 2 138 138 92 400
mls qos queue-set output 1 threshold 3 36 77 100 318
mls qos queue-set output 1 threshold 4 20 50 67 400
mls qos queue-set output 2 threshold 1 149 149 100 149
mls qos queue-set output 2 threshold 2 118 118 100 235
mls qos queue-set output 2 threshold 3 41 68 100 272
mls qos queue-set output 2 threshold 4 42 72 100 242
mls qos queue-set output 1 buffers 10 10 26 54
mls qos queue-set output 2 buffers 16 6 17 61

Int gi2/0/51:

mls qos trust dscp

My question is, can I simply copy and paste the above QoS statements onto the 4510 and also add that mls command on the interface?  If not, can you please point me in the right direction?

Best, ~sK

1 Accepted Solution

Accepted Solutions

InayathUlla Sharieff
Cisco Employee
Cisco Employee

Hi SK,

If you are using4 4510R-E with Sup 6E then the "mls qos trust dscp" will not be supported instead you need to use.

Please check the same in below thread:

https://supportforums.cisco.com/thread/2002527

Cat 4500 with Sup6-E is different. Here is what I did to trust DSCP

class-map match-all AutoQos-VoIP-Bearer-Dscp

match  dscp ef

class-map match-all AutoQos-VoIP-Control-Dscp26

match  dscp af31

class-map match-all AutoQos-VoIP-Control-Dscp24

match  dscp cs3

policy-map AutoQos-VoIP-Input-Dscp-Policy

class AutoQos-VoIP-Bearer-Dscp

  set qos-group 46

class AutoQos-VoIP-Control-Dscp26

  set qos-group 26

class AutoQos-VoIP-Control-Dscp24

  set qos-group 24

class class-default

interface GigabitEthernet6/24

description CALLMANAGER-1

switchport access vlan 101

spanning-tree portfast

service-policy input AutoQos-VoIP-Input-Dscp-Policy

switchport access vlan 101

spanning-tree portfast

service-policy input AutoQos-VoIP-Input-Dscp-Policy

22-

http://www.cisco.com/en/US/prod/collateral/switches/ps5718/ps4324/white_paper_c11-539588.html

HTH

Regards

Inayath

*Plz dont forget to rate the usefull posts.

View solution in original post

2 Replies 2

InayathUlla Sharieff
Cisco Employee
Cisco Employee

Hi SK,

If you are using4 4510R-E with Sup 6E then the "mls qos trust dscp" will not be supported instead you need to use.

Please check the same in below thread:

https://supportforums.cisco.com/thread/2002527

Cat 4500 with Sup6-E is different. Here is what I did to trust DSCP

class-map match-all AutoQos-VoIP-Bearer-Dscp

match  dscp ef

class-map match-all AutoQos-VoIP-Control-Dscp26

match  dscp af31

class-map match-all AutoQos-VoIP-Control-Dscp24

match  dscp cs3

policy-map AutoQos-VoIP-Input-Dscp-Policy

class AutoQos-VoIP-Bearer-Dscp

  set qos-group 46

class AutoQos-VoIP-Control-Dscp26

  set qos-group 26

class AutoQos-VoIP-Control-Dscp24

  set qos-group 24

class class-default

interface GigabitEthernet6/24

description CALLMANAGER-1

switchport access vlan 101

spanning-tree portfast

service-policy input AutoQos-VoIP-Input-Dscp-Policy

switchport access vlan 101

spanning-tree portfast

service-policy input AutoQos-VoIP-Input-Dscp-Policy

22-

http://www.cisco.com/en/US/prod/collateral/switches/ps5718/ps4324/white_paper_c11-539588.html

HTH

Regards

Inayath

*Plz dont forget to rate the usefull posts.

Thank you,  Inayath!

Much apprecaited.

Best, ~sK

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Review Cisco Networking products for a $25 gift card