cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

418
Views
0
Helpful
4
Replies
Highlighted
Contributor

redistributing routes using distribute-list

Hi everybody

My book says we can use " distribute-list with  " out" option to redistribute routes.

I have been trying to test this feature but I can not get it working.

Below R2 is supposed to redistribute route 1.0.0.0/8 learned via rip into eigrp  using distribute list.

loopback 1.0.0.0/8( R1)-----rip---------f0/0 (R2)---f0/1---Eigrp----R3

R2#show ip route


Gateway of last resort is not set

C    200.200.200.0/24 is directly connected, FastEthernet0/0
C    199.199.199.0/24 is directly connected, FastEthernet0/1
R    1.0.0.0/8 [120/1] via 200.200.200.1, 00:00:22, FastEthernet0/0

router eigrp 1

network 199.199.199.0

default-metric 100 10 255 1 1500

distribute-list 4 out rip

auto-summary

access-list 4 permit 1.0.0.0 0.255.255.255

I am expecting 1.0.0.0 should be redistributed into eigrp and R3 should have it in its routing table:

But It does not:

R3#show ip route
C    199.199.199.0/24 is directly connected, FastEthernet0/0
R3#

I have pasted the show runnning outputs below.

Thanks and have a great weekend.

========================================================================================================

R1#show running-config
Building configuration...

Current configuration : 959 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
no ip domain lookup
ip domain name lab.local
!
!
!
!
!
voice service voip
no allow-connections any to pots
no allow-connections pots to any
allow-connections h323 to h323
!
!
interface Loopback1
ip address 1.1.1.1 255.0.0.0
!
interface FastEthernet0/0
ip address 200.200.200.1 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
router rip
network 1.0.0.0
network 200.200.200.0
!
no ip http server
ip forward-protocol nd
control-plane
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
line vty 0 4
login
!
!
end

R1#

--------------------------------------------------------

R2#SHOW RUNNING-CONFIG
Building configuration...

Current configuration : 1063 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
no ip domain lookup
ip domain name lab.local
!
!
!
!
!
voice service voip
no allow-connections any to pots
no allow-connections pots to any
allow-connections h323 to h323
!
!
interface FastEthernet0/0
ip address 200.200.200.2 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 199.199.199.2 255.255.255.0
duplex auto
speed auto
!
router eigrp 1
network 199.199.199.0
default-metric 100 10 255 1 1500
distribute-list 4 out rip
auto-summary
!
router rip
network 200.200.200.0
!
no ip http server
ip forward-protocol nd
!
!
!
access-list 4 permit 1.0.0.0 0.255.255.255
!
!
!
control-plane
!
!
!
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
line vty 0 4
login
!
!
end

R2#

----------------------------------------------------------------------------------------

R3#SHOW RUNNING-CONFIG
Building configuration...

Current configuration : 908 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R3
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
no ip domain lookup
ip domain name lab.local
!
!
!
!
!
voice service voip
no allow-connections any to pots
no allow-connections pots to any
allow-connections h323 to h323
!
!
interface FastEthernet0/0
ip address 199.199.199.3 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
router eigrp 1
network 199.199.199.0
auto-summary
!
no ip http server
ip forward-protocol nd
!
!
control-plane
!
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
line vty 0 4
login
!
!
end

R3#

=====================================================

Everyone's tags (3)
1 ACCEPTED SOLUTION

Accepted Solutions
Cisco Employee

redistributing routes using distribute-list

Hi

Function of Distribute-list is to filter the routes. It cannot do redistribution

You need to use redistribution command for redistribution to work from RIP to EIGRP

Thanks

Raju

4 REPLIES 4
Cisco Employee

redistributing routes using distribute-list

Hi

Function of Distribute-list is to filter the routes. It cannot do redistribution

You need to use redistribution command for redistribution to work from RIP to EIGRP

Thanks

Raju

Contributor

redistributing routes using distribute-list

Hi Raju

That is exactly I thought.  But the book says we can also use distribute-list  with " option"  to redistribute routes into igp

It also gives an example but when i lab it up, I don't see any routes being redistributed.

Thanks anyway.

Beginner

Re: redistributing routes using distribute-list

I would look for a better book, if I were you.


Which book is it? We need to contact the author/publisher to get it corrected if possible.

Sent from Cisco Technical Support iPad App

Cisco Employee

redistributing routes using distribute-list

Hi

"distribute-list 4 out rip"

The RIP in the end says to apply the distribute-list only for RIP routes. But still you need redistribution statement

Thanks

Raju

CreatePlease to create content
Content for Community-Ad
July's Community Spotlight Awards