cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Join Customer Connection to register!
594
Views
0
Helpful
1
Replies
mariov652
Beginner

Restrict IGMP Snooping Querier per VLAN

Hi all,

I have a 4948 switch (IOS v. 12.2(50)SG), for simplicity my scenario is as follows:

1) One VLAN with multicast, no queriers within the VLAN.

2) A second VLAN, received via a trunk restricting only this VLAN.  Multicast routers available within this VLAN.

In order to restrict multicast being broadcasted to all ports in the first VLAN, IGMP Snooping Querier is enabled on the switch and this is working fine ion this VLAN.

The problem I'm finding is that with IGMP Snooping Querier enabled on my switch, two things occur in the second VLAN:

     a) If the VLAN interface has no IP Address, I receive ALL multicast down the trunk link,  This is not what I want.

     b) If the VLAN interface is given an IP Address, I receive only interested multicast down the trunk link, however, every so often, my switch sends out an IGMP membership query in this VLAN with that IP, causing remote workstations to respond their subscriptions and subsequently ALL multicast is brought down the link for a period of time.

Is there a way to restrict the IGMP Snooping Querier feature only to the VLAN / VLAN Interfaces that need it?

I've looked at documentation and while it mentions adding the Snooping Querier while in interface mode, the command is not available on my switch in this mode.

If I remove IGMP Snooping Querier, my second VLAN behaves, but then the multicast in the first VLAN is broadcasted to all ports.

I've also tried setting "ip igmp snooping vlan X mrouter interface x" for the second VLAN on the trunk port, but this seems to make no difference.

Thanks,

Mario

1 REPLY 1
mariov652
Beginner

Hello again,

Just for future reference in case anyone experience a similar issue...

This seems to be related to differences in querier-intervals and querier-timeouts between devices in the local and remote VLAN.  This seems to be causing erratic querier elections.

By setting the timings the same throughout, and / or increasing the querier interval on the local 4948 switch, querier elections should stabilize and my switch shouldn't need to send out membership queries any longer.

Cheers,

Mario