cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
850
Views
0
Helpful
1
Replies

restricting bandwidth using class-map, policy-map and service-policy

donnie
Level 1
Level 1

Hi,

I am trying to use class-map, policy-map and service-policy on a cisco 1841 to do a test to ensure that traffic between 192.168.5.x and 192.168.6.x network is at only 10Kbps. As i want to achieve traffic restriction for certain protocols eventually. However when i do a data transfer between the 2 networks it is still at more than 10Mbps. Below is my 1841 config. Pls advise what is wrong, thks in advance.

version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec

no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
logging buffered 52000 debugging
!
no aaa new-model
!
resource policy
!
mmi polling-interval 60
no mmi auto-configure
no mmi pvc
mmi snmp-timeout 180
ip subnet-zero
ip cef
!
!
no ip dhcp use vrf connected
ip dhcp excluded-address 192.168.5.101 192.168.5.254
!
ip dhcp pool pbxpool
   network 192.168.5.0 255.255.255.0
   default-router 192.168.5.254
   lease 0 8
!
!
ip domain name yourdomain.com
!
username ciscoadm privilege 15 secret 5 $1$iJEz$WHEd17LLFVRpAbyTtMpLn.
!
!
class-map match-any maptest
match access-group 101
!
!
policy-map policytest
class maptest
  bandwidth 10
!
!
!
interface FastEthernet0/0
description $ETH-SW-LAUNCH$$INTF-INFO-FE 0$$ETH-LAN$
ip address 192.168.5.254 255.255.255.0
duplex auto
speed auto
service-policy output policytest
!
interface FastEthernet0/1
description $ETH-LAN$
ip address 192.168.6.254 255.255.255.0
duplex auto
speed auto
service-policy output policytest
!
ip classless

!
ip http server
ip http authentication local
ip http timeout-policy idle 60 life 86400 requests 10000
!
access-list 101 permit ip 192.168.5.0 0.0.0.255 192.168.6.0 0.0.0.255
access-list 101 permit ip 192.168.6.0 0.0.0.255 192.168.5.0 0.0.0.255
access-list 102 permit ip any any
access-list 102 permit icmp any any
!
control-plane
!
banner login ^C
-----------------------------------------------------------------------
Cisco Router and Security Device Manager (SDM) is installed on this device.
This feature requires the one-time use of the username "cisco"
with the password "cisco". The default username and password have a privilege le
vel of 15.

Please change these publicly known initial credentials using SDM or the IOS CLI.

Here are the Cisco IOS commands.

username <myuser>  privilege 15 secret 0 <mypassword>
no username cisco

Replace <myuser> and <mypassword> with the username and password you want to use
.

For more information about SDM please follow the instructions in the QUICK START

GUIDE for your router or go to http://www.cisco.com/go/sdm
-----------------------------------------------------------------------
^C
!
line con 0
login local
line aux 0
line vty 0 4
privilege level 15
login local
transport input telnet
line vty 5 15
privilege level 15
login local
transport input none
!
end

1 Reply 1

cadet alain
VIP Alumni
VIP Alumni

Hi,

to limit traffic bandwidth you must do CB-policing and so you must replace the bandwidth command in

policy-map policytest
class maptest
  bandwidth 10

by police 10000  conform-action transmit exceed-action drop

Then apply this policy inbound on fastethernet interface

Regards.

Alain

Don't forget to rate helpful posts.
Review Cisco Networking for a $25 gift card