12-10-2013 05:45 PM - edited 03-07-2019 05:01 PM
Hello,
I am working an ASR1000 router with the configuration below.
------------------------------------------------------------------------------------------
router ospf 1
redistribute connected metric-type 1 subnets route-map TO-OSPF
!
route-map TO-OSPF permit 10
match ip address 100
set tag 200
!
access-list 100 permit ip 10.1.0.0 0.0.0.255 any
access-list 100 permit ip 10.2.0.0 0.0.0.255 any
access-list 100 deny ip any any
!
interface GigabitEthernet0/0/1
ip address 192.168.0.253 255.255.255.0
ip address 10.1.0.253 255.255.255.0 secondary
ip address 10.2.0.253 255.255.255.0 secondary
standby 1 ip 192.168.0.254
standby 1 ip 10.1.0.254 secondary
standby 1 ip 10.2.0.254 secondary
------------------------------------------------------------------------------------------
I appended a secondary and standby address, and updated the access-list 100.
But the route newly redistributed into OSPF didn't have the tag 200.
I recreated and reapplied the route-map and ACL, but the problem was not solved.
Is there any solution?
Thanks,
Jun
12-11-2013 03:01 AM
Hi Jun,
Can you attach the output for the following command:
sh ip ospf da external 10.1.0.0
Regards
12-11-2013 07:05 PM
12-17-2013 06:48 AM
I am not sure if I am right, but if you want the external routes to be tagged, like the 10.3.0.0/24 which you have mentioned, I believe you should have had that mentioned in the route-map.
route-map TO-OSPF permit 10
match ip address 100
set tag 200
!
access-list 100 permit ip 10.1.0.0 0.0.0.255 any
access-list 100 permit ip 10.2.0.0 0.0.0.255 any
access-list 100 deny ip any any
From the above and the logs you have attached, I understand that anything which is permit in the route-map will get tagged whereas the one's which are denied will not get tagged.
A simple test can be made, where in you can do permit ip any any on the route-map and check if the tagging is happening to the routes you expect. If yes, then those routes should be in the permit list and the others in the deny.
Hope this makes sense.
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide