cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
4972
Views
5
Helpful
3
Replies

Router on a Stick Etherchannel

CSCO12801420
Level 1
Level 1

Good-day All, 

I am just working on my home lab currently and tried to implement a Etherchannel on a router-on-a-stick topology. 
My hardware is an old 3560-8port switch and 887VAG Router. What I would like to accomplish is to have a 200Mbps uplink from
switch to router, and send tagged traffic over the etherchannel. 

I have tried assigning sub-interfaces to the etherchannel, but without any luck. This is only for testing/learning purposes to double the uplink bandwidth from the switch to the router.

If this is not possible, or the correct way to implement if different can you please give brief explanation/guidance ?

Router config - 887VAG
!
interface Port-channel 1
no ip address
!
interface FastEthernet0/0
channel-group 1
no ip address
duplex auto
speed auto
!
interface FastEthernet0/0.20
encapsulation dot1Q 20
ip address 10.0.20.1 255.255.255.0
!
interface FastEthernet0/0.50
encapsulation dot1Q 50
ip address 10.0.50.1 255.255.255.0
!
interface FastEthernet0/1
channel-group 1
no ip address
duplex auto
speed auto
!
interface FastEthernet0/1.20
encapsulation dot1Q 20
!
interface FastEthernet0/1.50
encapsulation dot1Q 50
!

DHCP-Server

!
ip dhcp pool VLAN20
network 10.0.20.0 255.255.255.0
default-router 10.0.20.1
dns-server 10.0.20.1
ip dhcp pool VLAN50
network 10.0.50.0 255.255.255.0
default-router 10.0.50.1
dns-server 10.0.50.1
!

Switch config - 3560
!
interface Port-channel 1
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface FastEthernet0/1
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 1 mode auto
!
interface FastEthernet0/2
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 1 mode auto
!

Access ports

!
interface FastEthernet0/3
switchport access vlan 20
switchport mode access
!
interface FastEthernet0/4
switchport access vlan 50
switchport mode access
!

VLAN's

!
interface Vlan1
no ip address
shutdown
!
interface Vlan20
ip address 10.0.20.2 255.255.255.0
!
interface Vlan50
ip address 10.0.50.2 255.255.255.0
!

Thanks all !!! 

P

1 Accepted Solution

Accepted Solutions

Hi

I have not made an ether channel on this kind of router, but if you are using L2 etherchannel on the switch it should be the same on the router, you should remove the sub-interface to make it works and use channel-group <id> mode auto.

I dont recommend to use auto, you could use lacp instead. 

So you could have on the router

*Shutdown the interface before to configure. 

interface fa0/0 (same for fa0/1)
channel-group 1 mode active
switchport trunk encapsulation dot1q
switchport mode trunk

int po1
switchport trunk encapsulation dot1q
switchport mode trunk
no shutdown.

and change the mode on the switch as well.

Remember to create an etherchannel, the kind of port and configuration must the same (speed, mode, duplex, etc)

Hope it is useful

:-)




>> Marcar como útil o contestado, si la respuesta resolvió la duda, esto ayuda a futuras consultas de otros miembros de la comunidad. <<

View solution in original post

3 Replies 3

Hi

I have not made an ether channel on this kind of router, but if you are using L2 etherchannel on the switch it should be the same on the router, you should remove the sub-interface to make it works and use channel-group <id> mode auto.

I dont recommend to use auto, you could use lacp instead. 

So you could have on the router

*Shutdown the interface before to configure. 

interface fa0/0 (same for fa0/1)
channel-group 1 mode active
switchport trunk encapsulation dot1q
switchport mode trunk

int po1
switchport trunk encapsulation dot1q
switchport mode trunk
no shutdown.

and change the mode on the switch as well.

Remember to create an etherchannel, the kind of port and configuration must the same (speed, mode, duplex, etc)

Hope it is useful

:-)




>> Marcar como útil o contestado, si la respuesta resolvió la duda, esto ayuda a futuras consultas de otros miembros de la comunidad. <<

Thank you all for feedback, 

After a bit of confusion, I apply the LACP config and deleted the sub-interfaces and
applying the tagging on the portchannel.

Regards

P

Hello

FYI -

L2 etherchannel


1) default physical interfaces and shut them down (if possible)
2) configure port-channel in physical interfaces
 
-- port-channel will be created automatically

3)create trunking encapsulation or access port mode directly in port-channel interface
4)enable physical interfaces "no shut"


conf t
default int ran x/x1 -1 ( if applicable)

int ran x/x/1 -2
shut ( if applicable)
channel-group 1 mode xxx


int port-channel 1
switchport trunk encap dot1q
switchport- mode trunk

or

switchport vlan x/x
swithport mode access


int ran fa0/1 -2
no shut ( if applicable)


L3 etherchannel

1) default physical interfaces ans shut them down (if possible)
2) Config the port-channel interface
3)configure port-channel on physical interfaces with NO switchport and then Ip adddress
4) config physical interrfaces with NO switchport
5) Assign the port-cahnnel ID using channel-group commamd
6) reset the physical interfaces shut and than No shut

conf t
default int ran x/x/1 -2

int port-channel 1
no switchport
ip address xxxx yyyyy

int ran x/x/1 -2
shut (if possible
no switchport)
channel-group 1 mode xxx
no shut

res
Paul


Please rate and mark as an accepted solution if you have found any of the information provided useful.
This then could assist others on these forums to find a valuable answer and broadens the community’s global network.

Kind Regards
Paul
Review Cisco Networking for a $25 gift card