10-11-2012 05:54 PM - edited 03-07-2019 09:25 AM
I am having a hard time configuring router on a stick on Boson Netsim.
I have a router connecting to a switch. Below are the configs. Unforuntately i could not paste them in as net boson doesnt seam to let me copy to the clipboard.
__________________________________________________________
ROUTER
Interface Ethernet0
no ip address
no ip directed-broadcast
Interface Ethernet0.2
Description Voice VLAN
Encapsulation dot1q 2
ip address 192.168.2.1 255.255.255.0
SWITCH
interface FastEthernet 0/1
Description trunk-to-router
switchport mode trunk
spanning-tree portfast
interface Vlan 0002
ip address 192.168.2.2 255.255.255.0
vlan name 2 voice
__________________________________________
I can never get the subinterfaces to go into an up status even though the physical interface is in an up status.
Any help would be appreciated it.
Thank you.
10-11-2012 11:26 PM
Hi Winner,
Please check this example and correct your errors:
see the example:If you are configuring on Router
Create sub-interfaces, set 802.1Q trunking protocol and ip address on each sub-interface
Router(config)#interface f0/0
Router(config-if)#no shutdown
(Note: The main interface f0/0 doesn’t need an IP address but it must be turned on)
Router(config)#interface f0/0.0
Router(config-subif)#encapsulation dot1q 15
Router(config-subif)#ip address 192.168.15.1 255.255.255.0
Router(config-subif)#interface f0/0.1
Router(config-subif)#encapsulation dot11 20
Router(config-subif)#ip address 192.168.20.1 255.255.255.0
(Note: In the “encapsulation dot1q 15″ command, 15 is the VLAN ID this interface operates in)
Configure VLAN
Switch(config)#vlan 15
Switch(config-vlan)#name SALES
Switch(config-vlan)#vlan 20
Switch(config-vlan)#name TECH
Set ports to access mode & assign ports to VLAN
Switch(config)#interface range fa0/1
Switch(config-if)#no shutdown
Switch(config-if)# switchport mode access
Switch(config-if)# switchport access vlan 15
Switch(config-if)#interface range fa0/3
Switch(config-if)#no shutdown
Switch(config-if)#switchport mode access
Switch(config-if)# switchport access vlan 20
Regards
Please rate if it helps.
10-14-2012 07:14 AM
While I appreciate your help you pretty much described what I already had configured.
Sometimes I think that the boson software doesnt always function properly...
10-14-2012 08:41 AM
Hi Winner,
If you do show vlan brief, do you see the vlan in the vlan database (you can also check to see if your SVI is up/up)? Also, is vlan 2 a native vlan? If it is, you will need to modify your configuration to look like this:
Interface Ethernet0.2
Description Voice VLAN
Encapsulation dot1q 2 native
Thanks,
Nick
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide