cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1175
Views
5
Helpful
3
Replies

Router on Stick port channel config C3900 router

Hi i have C3900 series router .

currently we have configured router on stick on it hence the switch is not supporting for routing .

currently we have only one interface connected with switch , we need to connect redundant interface .

so we plan to configure port-channel . so guide me how to do it.

the config as below.

interface GigabitEthernet0/1
 description nls01
 no ip address
 duplex full
 speed auto
 no mop enabled
 service-policy input in-mark-af41
 service-policy output out-parent
!
interface GigabitEthernet0/1.30
 description waas
 encapsulation dot1Q 30
 ip address xxxx
 ip wccp redirect exclude in
!
interface GigabitEthernet0/1.80
 description data
 encapsulation dot1Q 80 native
 ip address xxxx
 ip helper-address xxx
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 ip wccp 61 redirect in
!
interface GigabitEthernet0/1.81
 description voice
 encapsulation dot1Q 81
 ip address xxx
 ip helper-address xxxx
 no ip redirects
 no ip unreachables
 no ip proxy-arp
!
interface GigabitEthernet0/1.82
 description wireless
 encapsulation dot1Q 82
 ip address xxxx
 ip helper-address xxx
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 ip wccp 61 redirect in
!
interface GigabitEthernet0/1.482
 description byod
 encapsulation dot1Q 482
 ip address xxxx
 ip access-group BYOD in
 ip helper-address xxxx
 ip helper-address xxx
 ip wccp 61 redirect in

3 Replies 3

I plan to do :-

int port-channel 1 and create desired sub interface on port channel .

and map it with physical interface gi0/1 and gi0/2  ... is it work ?

prajithtr_2
Level 1
Level 1

Hi vasanthmanoharan,

I think this document will you help you out in this..

http://www.cisco.com/c/en/us/support/docs/switches/catalyst-2950-series-switches/24042-158.html

Regards

Prajith

Hi,

Using interface port 1 should work.
You need to use manual ether channel on the switch as the router does not support
lacp or pagp negotiation.


interface port1
 description nls01
 no ip address
 duplex full
 speed auto
 no mop enabled
 service-policy input in-mark-af41
 service-policy output out-parent
!
interface port1.30
 description waas
 encapsulation dot1Q 30
 ip address xxxx
 ip wccp redirect exclude in
!
interface port1.80
 description data
 encapsulation dot1Q 80 native
 ip address xxxx
 ip helper-address xxx
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 ip wccp 61 redirect in
!
interface port1.81
 description voice
 encapsulation dot1Q 81
 ip address xxx
 ip helper-address xxxx
 no ip redirects
 no ip unreachables
 no ip proxy-arp
!
interface port1.82
 description wireless
 encapsulation dot1Q 82
 ip address xxxx
 ip helper-address xxx
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 ip wccp 61 redirect in
!
interface port1.482
 description byod
 encapsulation dot1Q 482
 ip address xxxx
 ip access-group BYOD in
 ip helper-address xxxx
 ip helper-address xxx
 ip wccp 61 redirect in
!

Then glue the the interfaces on the router together

!
int g0/1
channel-group 1
!
!
int g0/2
channel-group 1
!

=================

On the switch lets say it int fas 0/23 & 0/24 and they are in deafault configuration

!
int port 1
desc *** ETHERCHAN TO ROUTER ***
switchport
switchport trunk encap dot1q
switchport mode trunk
!
int fas 0/23
switchport
channel-group 1 mode on
!
!
int fas 0/23
switchport
channel-group 1 mode on
!

Hope this helps
Regards
Alex

Regards, Alex. Please rate useful posts.
Review Cisco Networking products for a $25 gift card