cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1322
Views
0
Helpful
7
Replies

Router to Switch Connectivity

vishal-patil
Level 1
Level 1

Hi,

I am trying to connect switch (loaded ios 3725 in GNS3) to two routers.

I have configured both interfaces fa0/0 and fa0/1. I also disabled ip routing on SW

But somehow I cannot ping R2 from R3 and vice versa.

Am I missing something?

Please see attached topology

Regards,

Vish

7 Replies 7

please share configurations of SW,R2 and R3

thanks

R2#sh run
Building configuration...

Current configuration : 1333 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
no ip icmp rate-limit unreachable
ip cef
!
!
!
!
no ip domain lookup
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
archive
 log config
  hidekeys
!
!
!
!
ip tcp synwait-time 5
!
!
!
!
interface Loopback0
 ip address 178.8.3.3 255.255.255.0
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/0
 ip address 178.8.1.2 255.255.255.0
 clock rate 2000000
!
interface FastEthernet0/1
 ip address 178.8.2.2 255.255.255.0
 duplex auto
 speed auto
!
interface Serial1/0
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/3
 no ip address
 shutdown
 serial restart-delay 0
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
no cdp log mismatch duplex
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line vty 0 4
 login
!
!
end

_____________________________________________________________________________

SW#sho running-config
Building configuration...

Current configuration : 1549 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname SW
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
no ip routing
no ip icmp rate-limit unreachable
no ip cef
!
!
!
!
no ip domain lookup
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
archive
 log config
  hidekeys
!
!
!
!
ip tcp synwait-time 5
!
!
!
!
interface FastEthernet0/0
 no ip address
 no ip route-cache
 shutdown
 duplex auto
 speed auto
!
interface Serial0/0
 no ip address
 no ip route-cache
 shutdown
 clock rate 2000000
!
interface FastEthernet0/1
 no ip address
 no ip route-cache
 shutdown
 duplex auto
 speed auto
!
interface FastEthernet1/0
!
interface FastEthernet1/1
!
interface FastEthernet1/2
!
interface FastEthernet1/3
!
interface FastEthernet1/4
!
interface FastEthernet1/5
!
interface FastEthernet1/6
!
interface FastEthernet1/7
!
interface FastEthernet1/8
!
interface FastEthernet1/9
!
interface FastEthernet1/10
!
interface FastEthernet1/11
!
interface FastEthernet1/12
!
interface FastEthernet1/13
!
interface FastEthernet1/14
!
interface FastEthernet1/15
!
interface Vlan1
 no ip address
 no ip route-cache
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
no cdp log mismatch duplex
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line vty 0 4
 login
!
!
end

____________________________________________________________________________

R3#sho run
Building configuration...

Current configuration : 1540 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R3
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
no ip icmp rate-limit unreachable
ip cef
!
!
!
!
no ip domain lookup
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
archive
 log config
  hidekeys
!
!
!
!
ip tcp synwait-time 5
!
!
!
!
interface Tunnel0
 ip address 10.0.12.2 255.255.255.0
 tunnel source 178.8.2.1
 tunnel destination 178.8.1.1
!
interface FastEthernet0/0
 ip address 178.8.2.1 255.255.255.0
 duplex auto
 speed auto
!
interface Serial0/0
 no ip address
 shutdown
 clock rate 2000000
!
interface FastEthernet0/1
 ip address 10.0.3.1 255.255.255.0
 duplex auto
 speed auto
!
interface Serial1/0
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/3
 no ip address
 shutdown
 serial restart-delay 0
!
router eigrp 10
 network 10.0.2.0 0.0.0.255
 network 10.0.3.0 0.0.0.255
 network 10.0.12.0 0.0.0.255
 no auto-summary
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 178.8.2.2
!
!
no ip http server
no ip http secure-server
!
no cdp log mismatch duplex
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line vty 0 4
 login
!
!
end

Hello,

Your configuration on interfaces seems to be correct. When you are using 16ESW on router, it is easy to mess up the link numbers for connection.

Go on the router which you are using as a switch and check the output of this command.

Show cdp neighbor detail.

Check the connection(fa0/1 to fa1/0 as an example) and also IP addresses. On your switch, you should see both routers IPs with this command.

If the connections are correct, remove your tunnel interface and also route commands  and try again.

If you are not successful again, change the IOS of your SW.

For switch configuration, packet tracer is more suggested. It is free to download.

Hope it helps,

Masoud

Hello Vish,

In GNS these switches are layer 2 switches, Try assigning a common vlan tag on switch for both the ports connecting router and then check is it pinging or not.

Hope it Helps..

-GI

I don't see any routing on R2

you have router eigrp 10 on R3, need to configure the same on R2

Hi Richard,

Actually I am configuring GRE tunnel with IPSec

When i checked today, it was working. But thank you for your help

Must the no ip routing command on sw. Somehow it was not working when configured for the first time

Hi Vishal, 

You have a static route ip route 0.0.0.0 0.0.0.0 178.8.2.2 from the router R3 but no static route observed over the Router R2 .. Configure static ip route over the Router R2 as:

ip route 0.0.0.0 0.0.0.0 178.8.2.1

once done.. try to reach R3 from R2 and vice versa

Review Cisco Networking for a $25 gift card