cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
328
Views
5
Helpful
2
Replies

Routing http traffic

terrencepayet
Level 1
Level 1

Hi Guys,

Quick question.

Lets say i have two ISP's (ISP 1 and ISP 2). Can i route all http and https traffic to one ISP1 and route smtp,vpn etc to ISP 2?

Thanks & regards,

Terence

2 Replies 2

cadet alain
VIP Alumni
VIP Alumni

Hi,

yes you can using PBR.

access-list 100 permit tcp any any eq 80

access-list 100 permit tcp any any eq 8080

access-list 100 permit tcp any any eq 443

access-list 110 permit tcp any any eq smtp

route-map PBR permit 10

match ip address 100

set ip next-hop x.x.x.x   where x.x.x.x is ISP1 next-hop

route-map PBR permit 20

match ip address 110

set ip next-hop y.y.y.y  where y.y.y.y is ISP2 next-hop

int fx/x

ip policy route-map PBR  where fx/x is your router LAN ip address

if you are doing NAT then you'll have to do this also

route-map ISP1

match interface

route-map ISP2

match interface

ip nat inside source route-map ISP1 interface

ip nat inside source route-map ISP2 interface

Regards.

Alain.

Don't forget to rate helpful posts.

Hi Alain,

Thanks.

I was reading about PBR before posting the question. But i wasn't sure, but now you've cleared my mind.

I will try it and will let you know the outcome.

Thanks again.

Best Regards,

Terence

Review Cisco Networking for a $25 gift card