cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
14404
Views
0
Helpful
10
Replies
Highlighted

Routing VLANs between two routers

Hello all,

Been doing some research on this topic and wanted to make sure I am on the right track. I have a point to point fiber connection between two routers, each of those two routers have a Catalyst switch with a trunk port. Each switch has a vlan configured. There is a computer in that VLAN that needs to talk to the computer on the other switch. The VLAN are the same numbers but the switches are in different VTP domains.

Currently each router is configured as so:

PC1 ----- SW1 ------ R1------FIBER------R2------SW2------PC2

Router1

interface FastEthernet0/0

description LAN

ip address 192.168.1.1 255.255.255.0

no ip redirects

no ip unreachables

no ip proxy-arp

duplex auto

speed auto

!
interface FastEthernet0/0.100
description VLAN100
encapsulation dot1Q 100
ip address 10.10.10.1 255.255.255.0
no ip redirects
no ip unreachables
no ip proxy-arp
ip virtual-reassembly

interface FastEthernet0/1

description Point to Point Fiber

ip address 192.168.254.1 255.255.255.0

no ip redirects

no ip unreachables

no ip proxy-arp

duplex auto

speed auto

ip route 10.10.11.0 255.255.255.0 192.168.254.2

IP on PC1 = 10.10.10.2

-----------------------------------------------------------------------------------------------------

Router 2

interface FastEthernet0/0

description LAN

ip address 192.149.2.1 255.255.255.0

no ip redirects

no ip unreachables

no ip proxy-arp

duplex auto

speed auto

interface FastEthernet0/0.100

description VLAN100

encapsulation dot1Q 100

ip address 10.10.11.1 255.255.255.0

no ip redirects

no ip unreachables

no ip proxy-arp

ip virtual-reassembly

no cdp enable

interface FastEthernet0/1

description Point to Point Fiber

ip address 192.168.254.2 255.255.255.0

no ip redirects

no ip unreachables

no ip proxy-arp

duplex auto

speed auto

no mop enabled

ip route 0.0.0.0 0.0.0.0 192.168.254.1

IP on PC2 = 10.10.11.2

Since the switches are separate VTP domains, I assume I need to use some sort of routing to get PC1 and PC2 talking. Is this as easy as putting the vlan100 interfaces on each router into the same bridge-group 1 and enabling bridge 1 protocol ieee?

Just as a side note, when I ping the virtual interfaces from the opposite routers and workstations I am getting replies, so the connectivity through the fiber looks good. If I do a traceroute from the PC, it hits my local router, the opposite subinterface and then just responds with * and never completes.


Thanks!

Everyone's tags (5)
1 ACCEPTED SOLUTION

Accepted Solutions
Advisor

Re: Routing VLANs between two routers

Christie,

It's actually easier than that. Run a routing protocol between the 2 routers and you'll be able to get to the other side with no issue. Or, if you don't want to do that, you can do it with static routing.

HTH,

John

HTH, John *** Please rate all useful posts ***
10 REPLIES 10
Advisor

Re: Routing VLANs between two routers

Christie,

It's actually easier than that. Run a routing protocol between the 2 routers and you'll be able to get to the other side with no issue. Or, if you don't want to do that, you can do it with static routing.

HTH,

John

HTH, John *** Please rate all useful posts ***

Re: Routing VLANs between two routers

With static routing you're just refering to ip routes? That's what I wanted to do but it's not working

Beginner

Re: Routing VLANs between two routers

I have tried both the things. But its not working. 

show ip route

its shows the static routing and direct connection but still its not working

Advisor

Re: Routing VLANs between two routers

Sure. On router 2 you'd put a route like:

Ip route 10.10.10.0 255.255.255 192.168.254.1

On router 1, you'd put:

Ip route 10.10.11.0 255.255.255.0 192.168.254.2

You should be able to ping between hosts. I'm doing this from my iPhone, so I hope I have your addressing correct since I can't see your original post from this window :)

Hth,
John

Sent from Cisco Technical Support iPhone App

HTH, John *** Please rate all useful posts ***

Re: Routing VLANs between two routers

I have tried exactly that with no luck

Re: Routing VLANs between two routers

It's almost like when the packet gets to the other side it does not know where to go. I do not have an ip set on the actually VLAN100.

Advisor

Re: Routing VLANs between two routers

Can you ping 10.10.11.1 from the 10.10.10.2 host? If so, can you ping 10.10.10.1 from the 10.10.11.2 host?

HTH, John *** Please rate all useful posts ***

Re: Routing VLANs between two routers

Yes, they can ping both interfaces but not each other.

Advisor

Routing VLANs between two routers

Christie,

Out of curiosity, are these the primary ip addresses on the workstation? Can you post "route print" from one of the workstations? Also, can you post, from Router 1, "trace 10.10.11.1".

John

HTH, John *** Please rate all useful posts ***

Re: Routing VLANs between two routers

The issue was a misconfiguration on a switch in the main location, the trunk port was not properly configured. There were multiple switches and I missed that one So the routes do work so I will mark that as correct. Thanks!

CreatePlease to create content
Content for Community-Ad
July's Community Spotlight Awards