cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Join Customer Connection to register!
1103
Views
0
Helpful
9
Replies
Nelsonmejia09
Beginner

RSPAN OVER OTN/SDH (not ethernet Layer two) Network

I have the following Topology:

Server <SW 2960S > OTN Network  < SW 3750X > PC With Sniffer.

The purpose of this monitor is monitor the server installed in the LAN behind the SW 2960 and get the this traffic in the PC with the sniffer that is installed behind the SW 3750. All traffic betwen both swicthes is carried over the  OTN Network (supported like OMS). OTN network is a Layer 2 network.

it is posible use RSPAN to get the traffic from the server in the PC with the sniffer in the other side?.

1 ACCEPTED SOLUTION

Accepted Solutions

Nelson,

I do not know much about the OTN devices so I wouldnot comment on those. Logically, you have to configure that on OTN devices to take care of extra header size. Cisco switches do no play much here unless you have an application running on a server connected to the switch, which needs bigger MTU size. You have then configure it end to end between the Client and server path.

Depending upon the requairements, if you want to change MTU on the Cisco switches, use "system mtu " command in global config mode.

HTH,

-amit singh

View solution in original post

9 REPLIES 9
Amit Singh
Cisco Employee

Is this a trunk link between 2960S and 3750X? If yes, are you able to pass traffic for multiple vlans on this link.

If not, Please configure it as a trunk and configure the RSPAN VLAN to carry the sniffed traffice over the trunk link.

If you can pass the multiple vlan traffic over this link configured as trunk link, RSPAN should work for you.

Cheers,

-amit singh

Hi Amit, thank you for your answer.

Both switches have your respectives ports configured as a trunk (three vlans for data plus the RSPAN VLAN), the RSPAN VLAN have been configured in both switches too (RSPAN VLAN is 201).

I can pass traffic for the other vlans accross the OTN network (one device in each side in the same VLAN and it works fine), but i can´t get traffic from the server in the pc with the sniffer.

Is there some requirements for the OTN network betwen switches?.

let me know if you need the configuration in both switches about the RSPAN.

How can test that the traffic is carried in the RSPAN VLAN across the OTN network to the oher side?.

Well nothing special has to be done for carrying the RSPAN traffic to the other side, it will just treated as the normal VLAN traffic with the standard tagging and encapsulation.

Please could you paste the switch configs and also " show vlan " from both the switches along with the " show version".

Cheers,

-amit singh

Hi Amot,

this is the real Topology:

Server --> SW1 2960S <-trunk-> SW2 2960S <-trunk->  Device OTN 1 --- F.O. --- Device ONT 2 <-trunk-> SW3 3750X --> PC With Sniffer.

The config about three switches are in the file atachment and the show version too.

I have some quiestions:

- Tthe ONT Network remove 8 bytes of the header from de IEEE 820.3 Frame (8 bytes of prembule) and put the own header (12 bytes).

- Do i need change the MTU in any device en the topology to RSPAN can work fine?. if it is yes what is the new value for the MTU and each device

This are the config for each device

SWITCH 1: 2960S Config:

======================

hostname SWTVESJES01

vlan 2

!

vlan 6

!

vlan 8

!

vlan 201

name RSPAN

remote-span

!

interface GigabitEthernet1/0/4

description Server

switchport access vlan 2

switchport mode access

spanning-tree portfast

!

interface GigabitEthernet1/0/25

description Enlace SWTVESSTL01

switchport trunk allowed vlan 2,6,8,201

switchport mode trunk

!

monitor session 1 source interface Gi1/0/4

monitor session 1 destination remote vlan 201

SWITCH 2: 2960S Config:

======================

!

hostname SWTVESSTL01

!

vlan 2

!

vlan 6

!

vlan 8

!

vlan 201

name RSPAN

remote-span

!

interface GigabitEthernet1/0/24

description Enlace a Equipo OTN 1

switchport trunk allowed vlan 2,6,8,201

switchport mode trunk

!

interface GigabitEthernet1/0/25

description Enlace SWTVESJES01

switchport trunk allowed vlan 2,6,8,201

switchport mode trunk

!

monitor session 1 destination remote vlan 201

SWITCH 3: 3750 Config

=====================

vlan 2

!

vlan 6

!

vlan 8

!

vlan 201

name RSPAN

remote-span

!

interface GigabitEthernet1/0/43

description PC with Sniffer

switchport mode access

spanning-tree portfast

!

interface GigabitEthernet1/0/48

description Enlace Equipo OTN 2

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 2,6,8,201

switchport mode trunk

!

monitor session 1 destination interface Gi1/0/43

monitor session 1 source remote vlan 201

Nelson,

If your toplogy is working as expected right now, you dont have to do anything extra for the RSPAn configuration. if you need to change the MTU, to take of extra 4 bytes ( 12 byte OTN header - 8 Byte of Preamble), it should be 1508 ( 4 bytes 802.1q header + 4 extra bytes of OTN header) with a standard 1500 byte packet.

One thing that I noticed is that you have defined " monitor session 1 destination remote vlan 201" on the 2960-2 switch connected to OTN network. You dont need this configuration on the middle switch. You have to just add RSPAN vlan 201 and defined it as (remote-span). Please try removing it and let us know the behaviour.

Cheers,

-amit singh

Amit, Where do I change the zise of MTU in the cisco Switches or in the OTN Devices?.

I have tested the same sceneario with 3 switches ( the third switch has replaced to the OTN) the third swittch had the configuration "monitor session 1 destination remote vlan 201" and the VLAN RSPAN and it worked fine. It woked fine without this configuration too.

Thank you.

Nelson,

I do not know much about the OTN devices so I wouldnot comment on those. Logically, you have to configure that on OTN devices to take care of extra header size. Cisco switches do no play much here unless you have an application running on a server connected to the switch, which needs bigger MTU size. You have then configure it end to end between the Client and server path.

Depending upon the requairements, if you want to change MTU on the Cisco switches, use "system mtu " command in global config mode.

HTH,

-amit singh

View solution in original post

Hi Ami,

I have done the following topology and it didn,t work:

Server --> SW1 2960S <-trunk-> Device OTN 1 --- F.O. --- Device ONT 2 <-trunk-> SW3 3750X --> PC With Sniffer.

I don,t recive anything in the CP with sniffer.

I have seen that OTN device is not passing the VTP, CDP protocols too.

Could you please send me the technical documentation from cisco about VTP, CDP, RSAPN protocols (Frames and encapsulations), because I need to request to  the network administrator of OTN the this device allow this kind of traffic, becasuse i supose this device are filtering some kind of propetary traffic.

This is thecnical documentacion about OTN device:

IEEE802.3/Trama MAC Ethernet:

- El servicio ET100(HX) programado en la OTN actua como una serie de conmutadores de capa 2 (OSI) que hace pasar todas las tramas MAC de Ethernet/IEEE802.3 (Excepto tramas de control MAC, segun la clausula 31 del IEEE802.3)

- para lac comunicaciones internas de la OTN, la red OTN elimina el preambulo de IEEE802.3/Ethernet y lo susutituye por su propia cebecera ET100.

- La red OTN es transparente para cualquier protocolo de superior (IP,IPX, ARP, TCP, STP, ...) y cualquier metodo de direccionamiento (unicast, multicast, broadcast) , no se permiten tramas ISL.

I hopr your answer ans coments.