04-25-2005 09:07 AM - edited 03-05-2019 11:31 AM
Greetings,
I have two DSL lines coming into a 2811 router. Due to helping out with bandwidth, I need to seperate groups of interneal IP addresses and assign them to different gateways (DSL lines). I want to ask what commands I need to use to do this. Here is my configuration on the router:
!version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname ***
!
boot-start-marker
boot-end-marker
!
no logging buffered
!
username *** privilege 15 password 0 ***
no network-clock-participate aim 0
no network-clock-participate aim 1
no aaa new-model
ip subnet-zero
!
!
ip cef
!
!
no ftp-server write-enable
!
!
!
!
interface FastEthernet0/0
description $ETH-LAN$
ip address **.**.**.*21 255.255.255.240
ip nat outside
load-interval 30
duplex auto
speed auto
!
interface FastEthernet0/1
description $ETH-LAN$
ip address 192.168.1.2 255.255.255.0
ip nat inside
duplex auto
speed auto
!
interface FastEthernet0/0/0
no ip address
!
interface FastEthernet0/0/1
no ip address
shutdown
!
interface FastEthernet0/0/2
no ip address
shutdown
!
interface FastEthernet0/0/3
no ip address
shutdown
!
interface Vlan1
no ip address
ip nat outside
!
ip classless
ip route 0.0.0.0 0.0.0.0 **.**.**.*22
ip route 0.0.0.0 0.0.0.0 **.**.**.*09
ip http server
ip http authentication local
ip nat pool overload **.**.**.*14 **.**.**.*15 netmask 255.255.255.240
ip nat inside source list 7 interface FastEthernet0/0 overload
ip nat inside source static tcp 192.168.1.3 20 **.**.**.*10 20 extendable
ip nat inside source static tcp 192.168.1.3 21 **.**.**.*10 21 extendable
ip nat inside source static tcp 192.168.1.3 25 **.**.**.*10 25 extendable
ip nat inside source static tcp 192.168.1.3 80 **.**.**.*10 80 extendable
ip nat inside source static tcp 192.168.1.1 3389 **.**.**.*11 3389 extendable
ip nat inside source static udp 192.168.1.1 3389 **.**.**.*11 3389 extendable
ip nat inside source static tcp 192.168.1.4 1723 **.**.**.*12 1723 extendable
ip nat inside source static tcp 192.168.1.4 3389 **.**.**.*12 3389 extendable
ip nat inside source static udp 192.168.1.4 3389 **.**.**.*12 3389 extendable
ip nat inside source static tcp 192.168.1.5 3389 **.**.**.*13 3389 extendable
!
!
control-plane
!
!
line con 0
line aux 0
line vty 0 4
privilege level 15
login local
transport input telnet
!
scheduler allocate 20000 1000
!
end
I have the feeling it has to do with the ip route commands and changing them to reflect my internal ip ranges to what route I want.
Solved! Go to Solution.
04-29-2005 12:33 AM
you cannot use "ip route" to redirect traffic based on source address.
Actually I have answered your question in Tek-tips
http://www.tek-tips.com/viewthread.cfm?qid=1051646&page=1
Use policy-based routing instead.
04-25-2005 01:34 PM
All you have is two default routes. I dont see any specific internal routes on your router. First you need to identify, which internal routes you want to reassign to the new gateway. If you can post that all you will need to do is,
ip route x.x.x.x y.y.y.y
04-26-2005 05:56 AM
I have these internal address:
192.168.1.1
192.168.1.3
192.168.1.4
192.168.1.5
192.168.1.29
192.168.1.32
192.168.1.38
192.168.1.62
I want those to go to the **.**.**.*22 gateway.
Everything else:
192.168.1.6 - 192.168.1.28
192.168.1.30 - 192.168.1.31
192.168.1.33 - 192.168.1.37
192.168.1.39 - 192.168.1.61
192.168.1.63 - 192.168.1.99
I want these to use the **.**.**.*09 gateway.
Right now, I have it set to route everything through both. It lags at times so I want to seperate the ones that really depend on the internet to one gateway and the rest who use it just to surf on the other gateway. Trying to help out on bandwidth.
So, will my command would be so:
ip route 192.168.1.1 255.255.255.255 **.**.**.*22
ip route 192.168.1.3 255.255.255.255 **.**.**.*22
ip route 192.168.1.4 255.255.255.255 **.**.**.*22
ip route 192.168.1.5 255.255.255.255 **.**.**.*22
ip route 192.168.1.29 255.255.255.255 **.**.**.*22
ip route 192.168.1.32 255.255.255.255 **.**.**.*22
ip route 192.168.1.38 255.255.255.255 **.**.**.*22
ip route 192.168.1.62 255.255.255.255 **.**.**.*22
To do the rest of them to the 09 gateway, can you do groups of IP's if my command above is correct?
04-29-2005 12:33 AM
you cannot use "ip route" to redirect traffic based on source address.
Actually I have answered your question in Tek-tips
http://www.tek-tips.com/viewthread.cfm?qid=1051646&page=1
Use policy-based routing instead.
05-02-2005 05:42 AM
Thanks!
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide