cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Join Customer Connection to register!
63824
Views
5
Helpful
8
Replies
mustardtiger
Beginner

Setting VTY lines for SSH % Telnet only

Hello,

First off I apologize if this is the wrong section to post in or if there has already been a thread made for this particular problem however I've yet to find a solution that works.

I am configuring a 1841 router running IOS Version 12.4(15)T1

I am trying to set the vty lines to accept only telnet and ssh connections.

I am using these commands:

R1(config)# line vty 0 15

R1(config-line)# password ciscovtypass

R1(config-line)# login local

R1(config-line)#transport input telnet ssh

When I enter the "transport input telnet ssh" , I receive the error "Invalid input detected at '^' marker" and points to the word ssh.  I can successfully use "transport input telnet" and "transport input ssh" by themselves, however when I try to set them both on the same line is when i get the error.  And setting them both one after another overwrites the previous.  Any help would be much appreciated, thanks. 

2 ACCEPTED SOLUTIONS

Accepted Solutions
Jose Solano
Enthusiast

Hi,

You can try "transport input all" --> all the supported protocols, that includes both telnet and ssh.

http://www.cisco.com/en/US/docs/ios/termserv/command/reference/tsv_s1.html#wp1069219

Hope this helps.

View solution in original post

The suggestion from Leo would certainly allow both telnet and SSH. But it also allows some other protocols (they are not common in today's networking environment - but the original question was quite specific that they want to allow only 2 protocols and not all protocols). So let us look for answers that may help Michael.

My first thought was to wonder if SSH has been fully enabled and whether this might be a factor in the problem. Michael indicates that transport input ssh works ok and that seems to indicate that enabling SSH is not the issue. But I would still feel better if Michael would post the output of show ip ssh

I wonder if there is an order dependency in which one of the protocols must be entered first. I suggest trying this

line vty 0 15

transport input telnet ?

and

transport input ssh ?

and see if one of them indicates that the other protocol is an option.

HTH

Rick

HTH

Rick

View solution in original post

8 REPLIES 8
Jose Solano
Enthusiast

Hi,

You can try "transport input all" --> all the supported protocols, that includes both telnet and ssh.

http://www.cisco.com/en/US/docs/ios/termserv/command/reference/tsv_s1.html#wp1069219

Hope this helps.

View solution in original post

The suggestion from Leo would certainly allow both telnet and SSH. But it also allows some other protocols (they are not common in today's networking environment - but the original question was quite specific that they want to allow only 2 protocols and not all protocols). So let us look for answers that may help Michael.

My first thought was to wonder if SSH has been fully enabled and whether this might be a factor in the problem. Michael indicates that transport input ssh works ok and that seems to indicate that enabling SSH is not the issue. But I would still feel better if Michael would post the output of show ip ssh

I wonder if there is an order dependency in which one of the protocols must be entered first. I suggest trying this

line vty 0 15

transport input telnet ?

and

transport input ssh ?

and see if one of them indicates that the other protocol is an option.

HTH

Rick

HTH

Rick

View solution in original post

Leo Laohoo
VIP Community Legend

Must be a bug in the IOS or the IOS could be old. I have used "transport input ssh telnet" and I've never had a problem.

Sent from Cisco Technical Support Nintendo App

devils_advocate
Rising star

The main question is why are you still allowing the use of Telnet in your network?

Once SSH is configured, you should be using this and not Telnet.

mustardtiger
Beginner

I've got it working now, thanks for the help.

I am glad that you have got it working. Thank you for posting back to the forum to let us know that it is fixed. Can you tell us what the issue was and what you did to resolve the problem?

Thank you for using the rating system to indicate that this problem is resolved.

HTH

Rick

HTH

Rick

You forgot to tell what u did to get it working right !!!!!

would have helped me and some more !!

anyways good post !!

what a scambag, solved the issue and venished