06-07-2016 02:25 AM - edited 03-08-2019 06:06 AM
I have two router R1 and R2, ibgp
R2: interface Loopback0
ip address 2.2.2.2 255.255.255.0
interface Lo1
ip address 22.22.22.22 255.255.255.0
!
interface FastEthernet0/0
ip address 155.1.12.2 255.255.255.0
no shut
!
router bgp 1
network 0.0.0.0 mask 255.255.255.255
neighbor 155.1.12.1 remote-as 1
R1 config:
interface Loopback0
ip address 1.1.1.1 255.255.255.0
!
interface FastEthernet0/0
ip address 155.1.12.1 255.255.255.0
no shut
!
router bgp 1
network 0.0.0.0 mask 255.255.255.255
neighbor 155.1.12.2 remote-as 1
in R1, I issue show ip bgp, I can't see 2.2.2.0, how to resolve issue?
06-07-2016 02:42 AM
You need update-source loopback set and multihop for ebgp loopback connection
neighbour 1.1.1.1 remote-as 1
neighbor 1.1.1.1 update-source Loopback0
neighbor 1.1.1.1 ebgp-multihop 2
06-07-2016 02:50 AM
as I mentioned, we use ibgp not ebgp between R1 and R2, why we need to config multihop?
also if without use update-souce, can we see 2.2.2.0 ? i see someone without using this command, they still can see bgp route
06-07-2016 02:59 AM
you don't need the multihop statement then if ebgp just the source-loopback , if want your peering using loopbacks you need to use the update-source for ebgp or ibgp
06-07-2016 07:11 PM
No, even i use update source with my Ibgp, it still not working
R1:
router bgp 1
no synchronization
bgp log-neighbor-changes
network 0.0.0.0 mask 255.255.255.255
neighbor 2.2.2.2 remote-as 1
neighbor 2.2.2.2 update-source Loopback0
neighbor 155.1.12.2 remote-as 1
no auto-summary
R2:
router bgp 1
no synchronization
bgp log-neighbor-changes
network 0.0.0.0 mask 255.255.255.0
neighbor 1.1.1.1 remote-as 1
neighbor 1.1.1.1 update-source Loopback0
neighbor 155.1.12.1 remote-as 1
no auto-summary
but show ip bgp summary
Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd
2.2.2.2 4 1 0 0 0 0 0 never Active
155.1.12.2 4 1 22 18 1 0 0 00:01:26 0
no route in BGP. pls assist.
06-08-2016 12:57 AM
have you configured routing either dynamic or static for these ips to reach each other , bgp is tranport protocol it requires some form of igp/statics for reach-ability when using ibgp
06-08-2016 07:48 PM
no, I'm examing BGP table not routing table, only two router R1 and R2, there is no need for IGP.
06-09-2016 12:21 AM
Yes there is need for IGP its a rule , if your using the loopbacks as the neighbour peer how do they know how to route to each other , IBGP requires IGP not like EBGP
http://www.cisco.com/c/en/us/support/docs/ip/border-gateway-protocol-bgp/13751-23.html
06-09-2016 12:22 AM
BGP is not a routing protocol its a transport protocol that requires an IGP to route it , layer 4 not layer 3
06-07-2016 03:00 AM
Good day.
Multihop not used for IBGP.
Sometimes session established if on other side was configured update-source Loopback0.
Best regards. Alexey Nesterkin
06-07-2016 03:35 AM
Hello
You cannot advertise an ibgp network to another ibgp peer, it just wont happen - Its set by default to prevent loops as both neighbours are in the same ASN and their aspath attribute will not change for these routes.
However you can redistribute them into bgp, that will work.
route-map STAN permit 10
match interface loopback 0 loopback 1
router bgp 1
no network 0.0.0.0 mask 255.255.255.255
redistribute connected route-map STAN
res
Paul
06-07-2016 03:45 AM
"You cannot advertise an ibgp network to another ibgp peer"
Are you sure?
AS-Path change only when update send to EBGP peer, so loop detection based on AS=path don't work in IBGP session.
Best regards. Alexey Nesterkin
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide