01-14-2017 08:35 AM - edited 03-08-2019 08:54 AM
Hello,
I recently got a new ASR1001-X running Cisco IOS XE Software, Version 16.04.01.
After trying now 4 days without success creating a simple bridge between 2 ethernet interfaces I decided asking here.
All documentation that I found stated something like this:
interface GigabitEthernet0/0/1
no ip address
negotiation auto
service instance 999 ethernet
encapsulation untagged
bridge-domain 10
!
interface GigabitEthernet0/0/2
no ip address
negotiation auto
service instance 999 ethernet
encapsulation untagged
bridge-domain 10
!
interface BDI10
ip address 192.168.55.1 255.255.255.0
I also tried it with
!
bridge-domain 10
member GigabitEthernet0/0/1 service-instance 999
member GigabitEthernet0/0/2 service-instance 999
....
what seems to be the new method doing it.
I connect my computer to GigabitEthernet0/0/1 or GigabitEthernet0/0/2 and can't reach 192.168.55.1 (of course I'm in the same network).
Before someone will ask: yes, the BDI if is not shutdown. ;)
Any ideas for this simple task?
Best regards,
Marc.
01-14-2017 01:12 PM
Hello,
your first configuration is almost right. The service instance is associated with the bridge domain:
interface GigabitEthernet0/0/1
no ip address
negotiation auto
service instance 10 ethernet
encapsulation untagged
bridge-domain 10
!
interface GigabitEthernet0/0/2
no ip address
negotiation auto
service instance 10 ethernet
encapsulation untagged
bridge-domain 10
!
interface BDI10
ip address 192.168.55.1 255.255.255.0
01-15-2017 10:53 AM
Hello,
thank you very much for your reply. Unfortunately it doesn't work.
I connected a simple IP device with 192.168.30.1 on my GigabitEthernet0/0/4.
When assigning the IP directly to this port without any bridge I can reach 192.168.30.1
without any problem.
As soon as I do this:
interface GigabitEthernet0/0/4
no ip address
service instance 10 ethernet
encapsulation untagged
bridge-domain 10
!
interface BDI10
ip address 192.168.30.5 255.255.255.0
I can't reach the 192.168.30.1 anymore.
A show interfaces BDI10 shows me my output packets (pings counting) but there is written "Last input never"...
As in some forums I read that you probably need to set "enable irb" - I tried it with and without - no difference...
I would appreciate any ideas!
Thank you!
Marc.
01-15-2017 11:02 AM
Hello,
try and add the below (in bold) to your BDI configuration:
interface GigabitEthernet0/0/1
no ip address
negotiation auto
service instance 10 ethernet
encapsulation untagged
bridge-domain 10
!
interface GigabitEthernet0/0/2
no ip address
negotiation auto
service instance 10 ethernet
encapsulation untagged
bridge-domain 10
!
interface BDI10
ip address 192.168.55.1 255.255.255.0
encapsulation dot1Q 1 second-dot1q 1
mac-address 1.1.3
01-15-2017 11:26 AM
Hi,
thank you for your reply on Sunday evening ;).
Unfortunately no change... It can't be so difficult bridging two interfaces...
Is there anything that needs to be activated in general? Some config statement or some license or so? I have adventerprise...
Thank you!
Marc.
01-15-2017 11:32 AM
Marc,
I sent you the config with a small mistake. Second dot1q should be 2. Also, I think the mac address is optional, try to leave it out.
interface GigabitEthernet0/0/1
no ip address
negotiation auto
service instance 10 ethernet
encapsulation untagged
bridge-domain 10
!
interface GigabitEthernet0/0/2
no ip address
negotiation auto
service instance 10 ethernet
encapsulation untagged
bridge-domain 10
!
interface BDI10
ip address 192.168.55.1 255.255.255.0
encapsulation dot1Q 1 second-dot1q 2
mac-address 1.1.3
01-15-2017 11:55 AM
Hello Marc,
looking at your config again, the problem might be with the untagged encapsulation. Check if the config below works:
interface GigabitEthernet0/0/1
no ip address
negotiation auto
service instance 10 ethernet
encapsulation dot1q any
bridge-domain 10
!
interface GigabitEthernet0/0/2
no ip address
negotiation auto
service instance 10 ethernet
encapsulation dot1q any
bridge-domain 10
!
interface BDI10
ip address 192.168.55.1 255.255.255.0
encapsulation dot1Q any second-dot1q any
01-15-2017 12:08 PM
Hi,
the "encapsulation dot1q any" statement in the GE interface I already tried too without success. I tried setting the mac address also. In the BDIxx interface the any parameter behind encapsulation doesn't exist. Tried with 1 and 2... but still the same behavior.
Maybe any other ideas? :).
Marc.
01-15-2017 12:11 PM
Marc,
what is the output of:
show interfaces bdi
01-15-2017 12:13 PM
grey#show interfaces bdi10
BDI10 is up, line protocol is up
Hardware is BDI, address is 843d.c601.423f (bia 843d.c601.423f)
Internet address is 192.168.30.5/24
MTU 1500 bytes, BW 1000000 Kbit/sec, DLY 10 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation ARPA, loopback not set
Keepalive not supported
ARP type: ARPA, ARP Timeout 04:00:00
Last input never, output 00:00:38, output hang never
Last clearing of "show interface" counters never
Input queue: 0/375/0/0 (size/max/drops/flushes); Total output drops: 0
Queueing strategy: fifo
Output queue: 0/40 (size/max)
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
529 packets input, 98892 bytes, 0 no buffer
Received 0 broadcasts (0 IP multicasts)
0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
130 packets output, 10330 bytes, 0 underruns
0 output errors, 0 interface resets
0 unknown protocol drops
0 output buffer failures, 0 output buffers swapped out
01-15-2017 12:23 PM
Hello,
weird indeed. I am desperately googling...:(
Try to add this under your BDI interface:
vrf forwarding YOURVRFNAME
01-15-2017 12:26 PM
Hello,
did you try encapsulate the interfaces with the service instance value ?
interface GigabitEthernet0/0/1
no ip address
negotiation auto
service instance 10 ethernet
encapsulation dot1q 10
bridge-domain 10
!
interface GigabitEthernet0/0/2
no ip address
negotiation auto
service instance 10 ethernet
encapsulation dot1q 10
bridge-domain 10
!
interface BDI10
ip address 192.168.55.1 255.255.255.0
01-15-2017 12:32 PM
doesn't help too :(
01-15-2017 12:48 PM
Hello,
I am not sure in how far CDP is important here, but try the bwlo:
interface GigabitEthernet0/0/1
no ip address
negotiation auto
cdp enable
service instance 10 ethernet
encapsulation dot1q 10
bridge-domain 10
!
interface GigabitEthernet0/0/2
no ip address
negotiation auto
cdp enable
service instance 10 ethernet
encapsulation dot1q 10
bridge-domain 10
!
interface BDI10
ip address 192.168.55.1 255.255.255.0
encapsulation dot1Q 10
01-15-2017 12:54 PM
about cdp enable I also read on some sites but it also doesn't help :(
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide