cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
3265
Views
5
Helpful
3
Replies
Highlighted
Beginner

Slow SSH connection from Console

Hi,

in a very simple lab composed of:

- Access Switch (IE3000)

- Distribution Switch (ME3600X)

- Laptop (connected via LAN and console to Access Switch)

I found the following SSH issue (using Putty). Please note that the issue is not at the login time (authorization) but after login in the prompt response time of commands (e.g. show run):

- If from the Laptop I connect via SSH, using the Laptop LAN connection, to Access Switch the prompt response is very Fast

- If from the Laptop I connect via SSH, using the Laptop LAN connection, to Distribution Switch the prompt response is very Fast

- If from the Laptop I connect via SSH, using the Laptop LAN connection, to Access Switch and from Access I connect via SSH to Distribution Switch the prompt response is very Fast

But:

- If from the Laptop I connect via console to Access Switch and from Access I connect via SSH to Distribution Switch the prompt response is Slow

In our test i have only basic configuration.

Access Switch:

hostname Access

aaa new-model
username cisco password 0 cisco
enable secret cisco
ip domain-name rtp.cisco.com
crypto key generate rsa
ip ssh time-out 60
ip ssh authentication-retries 2
line vty 0 4
transport input SSH
interface Vlan1
   ip address 192.168.0.10 255.255.255.0
interface GigabitEthernet1/1 ! connected to Distribution Switch
   switchport mode trunk

Distribution Switch:

hostname Access
aaa new-model
username cisco password 0 cisco
enable secret cisco
ip domain-name rtp.cisco.com
crypto key generate rsa
ip ssh time-out 60
ip ssh authentication-retries 2
line vty 0 4
transport input SSH
interface Vlan1
   ip address 192.168.0.1 255.255.255.0
interface GigabitEthernet0/1 ! connected to Distribution Switch
   switchport mode trunk

 

3 REPLIES 3
Highlighted
Beginner

Generating a smaller key causes the sme issue?

crypto key generate rsa modulus 768

Highlighted
Enthusiast

Hard to tell what is meant when imprecise terms like slow and fast are used.  But access via the serial console is generally going to be much slower than via ssh or telnet.  It is by default only 9600 bps after all.  Is this what you are experiencing?

-Jeff

Highlighted
Rising star

Looks to me like you're having a management access bottleneck at the console.  Your output on the switch that you've SSH'ed to from the console connection will not be presented to you any faster than the console can support, which is 9600 bps.  Your direct SSH access is faster because it's at LAN speed from end to end.  You don't have that when you SSH through console.

Content for Community-Ad