cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
570
Views
0
Helpful
1
Replies
Highlighted
Beginner

Spanning Tree Cost

Can "spanning-tree cost" and "spanning-tree vlan 200 cost" both be used on the same interface at the same time?

My goal would be to set a new default cost for all vlans and modify just one or two from that new default.

Thank You

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Hall of Fame Master

Hello Jeff,

yes this is possible there is no ambiguity in these two commands

I tried on a ge port of a C4500

sh run int g1/4

Building configuration...

Current configuration : 256 bytes

!

interface GigabitEthernet1/4

description link verso RT-RM-SXR000-SF-I-E-2

switchport trunk encapsulation dot1q

switchport mode trunk

storm-control broadcast level 1.00

spanning-tree guard loop

spanning-tree vlan 4 cost 6

spanning-tree cost 4

end

sh spanning-tree vlan 4 int g1/4

Vlan Role Sts Cost Prio.Nbr Type

---------------- ---- --- --------- -------- --------------------------------

VLAN0004 Altn BLK 6 128.4 P2p

SW-RM-SXR000-SF-I-C-2#sh spanning-tree vlan 2 int g1/4

Vlan Role Sts Cost Prio.Nbr Type

---------------- ---- --- --------- -------- --------------------------------

VLAN0002 Root FWD 4 128.4 P2p

Hope to help

Giuseppe

View solution in original post

1 REPLY 1
Highlighted
Hall of Fame Master

Hello Jeff,

yes this is possible there is no ambiguity in these two commands

I tried on a ge port of a C4500

sh run int g1/4

Building configuration...

Current configuration : 256 bytes

!

interface GigabitEthernet1/4

description link verso RT-RM-SXR000-SF-I-E-2

switchport trunk encapsulation dot1q

switchport mode trunk

storm-control broadcast level 1.00

spanning-tree guard loop

spanning-tree vlan 4 cost 6

spanning-tree cost 4

end

sh spanning-tree vlan 4 int g1/4

Vlan Role Sts Cost Prio.Nbr Type

---------------- ---- --- --------- -------- --------------------------------

VLAN0004 Altn BLK 6 128.4 P2p

SW-RM-SXR000-SF-I-C-2#sh spanning-tree vlan 2 int g1/4

Vlan Role Sts Cost Prio.Nbr Type

---------------- ---- --- --------- -------- --------------------------------

VLAN0002 Root FWD 4 128.4 P2p

Hope to help

Giuseppe

View solution in original post

Content for Community-Ad