cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
328
Views
0
Helpful
1
Replies

Spanning-tree Uplinkfast question

colombus1
Level 1
Level 1

Hello Community,

I have Cisco Catalyst Swicth 2950T-24 and the following scenario:

Port fa 0/1 : Trunk VLANs 10,20,30  (Providing trunk access to another remote switch in the network in order to re-distribute to customer)

Port fa 0/2: Access VLAN 10 (Customer)

Port fa 0/3: Access VLAN 20 (Customer)

Port  0/4: Access VLAN 30 (Customer)

Port 0/23 : Trunk 10,20,30 (Upstream Primary)

Port 0/24: Trunk 10,20,30 (Upstream Secondary)

Below is the configuration sample:

spanning-tree mode pvst

no spanning-tree optimize bpdu transmission

spanning-tree extend system-id

spanning-tree uplinkfast

interface FastEthernet0/1

description To_Another_Swicth

switchport trunk allowed vlan 10,20,30

switchport mode trunk

!

interface FastEthernet0/2

description Customer_A

switchport access vlan 10

switchport mode access

!

interface FastEthernet0/3

description Customer_B

switchport access vlan 20

switchport mode access

!

interface FastEthernet0/3

description Customer_C

switchport access vlan 30

switchport mode access

!

interface FastEthernet0/23

description Link_to_Upstream_Swicth_Primary

switchport trunk allowed vlan 10,20,30

switchport mode trunk

!

interface FastEthernet0/24

description Link_to_Upstream_Swicth_Secondary

switchport trunk allowed vlan 10,20,30

switchport mode trunk

spanning-tree cost 20

!

Problem:

Whenever I enable the fa 0/24, link to another switch connected from  fa 0/1 becomes unstable. Please help me to accomplish to set fa 0/23 as Primary Upstream port and fa 0/24 as secondary for backup.

Any help will be highly appreciated. Thanks in advance.

1 Reply 1

vincehgov
Level 1
Level 1

It sounds to me that fa0/1 is the current root port and that enabling fa0/24 provides a better path to the root bridge, thus blocking fa0/1.

Even if you set fa0/23 as the root port, the switch may still block fa0/1 and fa0/24.

I'd set the cost of fa0/1 and fa0/24 to be very high so that the bridge would prefer fa0/23.  But like I said, fa0/24 and fa0/1 may still get blocked if they are alternate root ports.

-vg

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Review Cisco Networking products for a $25 gift card