cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
168
Views
0
Helpful
0
Replies

STP over VXLAN issue

Ali Hazim
Level 1
Level 1

Hello everyone,

Screenshot 2024-05-18 110144.png

I have an issue with STP for the topology above, I need to run STP so that one of the customer's links will be in STP Alt state.
The configuration is as follows:

Site1-Eth1/1 (Towards Customer CE):
switchport mode dot1q-tunnel
switchport access vlan 2214
spanning-tree bpdufilter enable 

Site2-Eth1/1 (Towards Customer CE):
switchport mode dot1q-tunnel
switchport access vlan 2214
spanning-tree bpdufilter enable 

Customer CE-Te0/1 & Te0/2:
switchport mode trunk
switchport trunk allowed vlan 400-600

Site1 & Site2 NVE interface:
no shutdown
source-interface loopback0
member vni 2214
    ingress-replication protocol static
      peer-ip x.x.x.x (IP of Main Site)

Main Site NVE interface:
no shutdown
source-interface loopback0
member vni 2214
    ingress-replication protocol static
      peer-ip y.y.y.y (IP of Site1)
      peer-ip z.z.z.z (IP of Site2)

Please note that the VXLAN is run over an IS-IS L3 network, the devices used for the main site, site1, & site2 are cisco nexus n9k
and the customer's CE is cisco catalyst C3750.

I've tried to user the command "l2protocol tunnel stp", and tried to enable L2G-STP, and both of them didn't solve the problem
there will  be a loop unless I shutdown one of the customer's CE interfaces 

Sorry for the long thread
Thank you

0 Replies 0
Review Cisco Networking for a $25 gift card