cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
760
Views
0
Helpful
7
Replies
Beginner

STP root selection error

Hi,

I am setting up a lab exercise and came across this unusual problem when implementing the lab...

The lab is for a simple illustration of STP and its a simple setup with 3 switches: Switch1(3560), Switch2(3550) and Switch3(3560 PoE) connected in a full mesh that looks like a triangle..

I have not made any configurations, all switch ports are in access mode and am using cross-over cables to connect the switches to each other. The switch ports are auto-negotiating to 100/full.

The problem is: Switch2 has the lowest MAC and becomes the Root Bridge and this is acknowledged by Switch3. But Switch1 has a higher MAC than Switch2, and it still claims to be the Root Bridge. Because of this there is a loop and I get a flapping MAC address message.
I tried forcing the root priority values on Switch1 and Switch2, so as to make Switch2 the root, but that does not work and am having the same issue.
I also noticed that Switch1 was not receiving any BPDU messages, only sending them. Switch2 is reciveing and sending BPDU messages, and is correctly neglecting the Switch1 BPDU claims to be root.

I replaced Switch1 with a 4948 switch, and STP works correctly.
I don't know if the problem is with the physical switch itself or if there is some configuration on 3560 switches that I am unaware of.

Appreciate your replies.

Thanks.

7 REPLIES 7
Cisco Employee

Re: STP root selection error

Hello Subish,

How are you doing?

What kind of code are you currently running on those boxes?

Thanks,

Andre

Rising star

Re: STP root selection error

Make sure switch 1 isn't VTP transparent.

Highlighted
Beginner

Re: STP root selection error

Switch1:

Switch1#sh run
hostname Switch1
!
no aaa new-model
system mtu routing 1500
ip subnet-zero
!
spanning-tree mode pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
interface FastEthernet0/1
!
interface FastEthernet0/2
!

Switch1#sh spanning-tree

VLAN0001
  Spanning tree enabled protocol ieee
  Root ID    Priority    32769
            Address     001e.794e.2a00
             This bridge is the root
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    32769  (priority 32768 sys-id-ext 1)
             Address     001e.794e.2a00
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time 300

Interface           Role Sts Cost      Prio.Nbr Type
------------------- ---- --- --------- -------- --------------------------------

Fa0/2               Desg FWD 19        128.4    P2p
Fa0/3               Desg FWD 19        128.5    P2p

Switch1#sh spanning-tree detail

VLAN0001 is executing the ieee compatible Spanning Tree protocol
  Bridge Identifier has priority 32768, sysid 1, address 001e.794e.2a00
  Configured hello time 2, max age 20, forward delay 15
  We are the root of the spanning tree
  Topology change flag not set, detected flag not set
  Number of topology changes 1 last change occurred 00:10:04 ago
          from FastEthernet0/2
  Times:  hold 1, topology change 35, notification 2
          hello 2, max age 20, forward delay 15
  Timers: hello 1, topology change 0, notification 0, aging 300

Port 4 (FastEthernet0/2) of VLAN0001 is designated forwarding
   Port path cost 19, Port priority 128, Port Identifier 128.4.
   Designated root has priority 32769, address 001e.794e.2a00
   Designated bridge has priority 32769, address 001e.794e.2a00
   Designated port id is 128.4, designated path cost 0
   Timers: message age 0, forward delay 0, hold 0
   Number of transitions to forwarding state: 1
   Link type is point-to-point by default
   BPDU: sent 316, received 0

Port 5 (FastEthernet0/3) of VLAN0001 is designated forwarding
   Port path cost 19, Port priority 128, Port Identifier 128.5.
   Designated root has priority 32769, address 001e.794e.2a00
   Designated bridge has priority 32769, address 001e.794e.2a00
   Designated port id is 128.5, designated path cost 0
   Timers: message age 0, forward delay 0, hold 0
   Number of transitions to forwarding state: 1
   Link type is point-to-point by default
  BPDU: sent 308, received 0

Switch1#sh vtp status
VTP Version                     : running VTP1 (VTP2 capable)
Configuration Revision          : 0
Maximum VLANs supported locally : 1005
Number of existing VLANs        : 5
VTP Operating Mode              : Server
VTP Domain Name                 :

On Switch2:

hostname Switch2
!
no aaa new-model
ip subnet-zero
!
no file verify auto
spanning-tree mode pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
interface FastEthernet0/1
switchport mode access
!
interface FastEthernet0/3
switchport mode access

Switch2#sh spanning-tree

VLAN0001
  Spanning tree enabled protocol ieee
  Root ID    Priority    32769
             Address     000e.843a.c780
            This bridge is the root
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    32769  (priority 32768 sys-id-ext 1)
             Address     000e.843a.c780
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time 300

Interface        Role Sts Cost      Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Fa0/1            Desg FWD 19        128.1    P2p
Fa0/3            Desg FWD 19        128.3    P2p

Switch2#sh spanning-tree detail

VLAN0001 is executing the ieee compatible Spanning Tree protocol
  Bridge Identifier has priority 32768, sysid 1, address 000e.843a.c780
  Configured hello time 2, max age 20, forward delay 15
  We are the root of the spanning tree
  Topology change flag not set, detected flag not set
  Number of topology changes 1 last change occurred 00:06:24 ago
          from FastEthernet0/1
  Times:  hold 1, topology change 35, notification 2
          hello 2, max age 20, forward delay 15
  Timers: hello 0, topology change 0, notification 0, aging 300

Port 1 (FastEthernet0/1) of VLAN0001 is forwarding
   Port path cost 19, Port priority 128, Port Identifier 128.1.
   Designated root has priority 32769, address 000e.843a.c780
   Designated bridge has priority 32769, address 000e.843a.c780
   Designated port id is 128.1, designated path cost 0
   Timers: message age 0, forward delay 0, hold 0
   Number of transitions to forwarding state: 1
   Link type is point-to-point by default
  BPDU: sent 208, received 1

Port 3 (FastEthernet0/3) of VLAN0001 is forwarding
   Port path cost 19, Port priority 128, Port Identifier 128.3.
   Designated root has priority 32769, address 000e.843a.c780
   Designated bridge has priority 32769, address 000e.843a.c780
   Designated port id is 128.3, designated path cost 0   Hello is pending
   Timers: message age 0, forward delay 0, hold 0
   Number of transitions to forwarding state: 1
   Link type is point-to-point by default
  BPDU: sent 394, received 197

Switch2#sh vtp status
VTP Version                     : 2
Configuration Revision          : 0
Maximum VLANs supported locally : 1005
Number of existing VLANs        : 5
VTP Operating Mode              : Server

On Switch3:

hostname Switch3
!
boot-start-marker
boot-end-marker
!
no aaa new-model
ip subnet-zero
!
power redundancy-mode redundant
no file verify auto
spanning-tree mode pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
interface GigabitEthernet1/1
!
interface GigabitEthernet1/2
!
interface GigabitEthernet1/3

Switch3#sh spanning-tree

VLAN0001
  Spanning tree enabled protocol ieee
  Root ID    Priority    32769
             Address     000e.843a.c780
             Cost        19
             Port        1 (GigabitEthernet1/1)
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    32769  (priority 32768 sys-id-ext 1)
             Address     0017.9444.f8c0
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time 300

Interface        Role Sts Cost      Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Gi1/1            Root FWD 19        128.1    P2p
Gi1/3            Desg FWD 19        128.3    P2p

Switch3#sh spanning-tree detail

VLAN0001 is executing the ieee compatible Spanning Tree protocol
  Bridge Identifier has priority 32768, sysid 1, address 0017.9444.f8c0
  Configured hello time 2, max age 20, forward delay 15
  Current root has priority 32769, address 000e.843a.c780
  Root port is 1 (GigabitEthernet1/1), cost of root path is 19
  Topology change flag not set, detected flag not set
  Number of topology changes 1 last change occurred 00:08:18 ago
          from GigabitEthernet1/3
  Times:  hold 1, topology change 35, notification 2
          hello 2, max age 20, forward delay 15
  Timers: hello 0, topology change 0, notification 0, aging 300

Port 1 (GigabitEthernet1/1) of VLAN0001 is forwarding
   Port path cost 19, Port priority 128, Port Identifier 128.1.
   Designated root has priority 32769, address 000e.843a.c780
   Designated bridge has priority 32769, address 000e.843a.c780
   Designated port id is 128.1, designated path cost 0
   Timers: message age 1, forward delay 0, hold 0
   Number of transitions to forwarding state: 1
   Link type is point-to-point by default
   BPDU: sent 1, received 278

Port 3 (GigabitEthernet1/3) of VLAN0001 is forwarding
   Port path cost 19, Port priority 128, Port Identifier 128.3.
   Designated root has priority 32769, address 000e.843a.c780
   Designated bridge has priority 32769, address 0017.9444.f8c0
   Designated port id is 128.3, designated path cost 19
   Timers: message age 0, forward delay 0, hold 0
   Number of transitions to forwarding state: 1
   Link type is point-to-point by default
   BPDU: sent 521, received 257

Switch3#sh vtp status
VTP Version                     : 2
Configuration Revision          : 0
Maximum VLANs supported locally : 1005
Number of existing VLANs        : 5
VTP Operating Mode              : Server

IOS on the switches:

Switch1: c3560-advipservicesk9-mz.122-44.SE6.bin

Switch2: c3550-ipbasek9-mz.122-25.SEE.bin

Switch3: Cat4500-ipbasek9-mz.122-25.SG.bin

There isn't much on the switches configuration wise..

Switch1 is not VTP trnsparent, VTP is not configured at all.

I am thinking some IOS issue. Any ideas??

Rising star

Re: STP root selection error

It looks like it, though this is typically a non-issue.  Move switch 1 to a IP BASE-k9 image, and see how it works.

Beginner

Re: STP root selection error

Hi,

   Can you change VTP mode on switch1 to v2?

reg,

Balu

Enthusiast

Re: STP root selection error

Hi,

That's interesting. Looking at the STP BPDU counters for Switch1 it indeed seems like it's not receiving any BPDU at all which is strange.

Have you tried downgrading the 3560 switch to the same version as 3550, which is 12.2(25)SEE according to your description?

Could you check the logs on all 3 switches to see if you observe any errors, especially when you connect them together and STP calculation takes place.

Best regards,

Andras

Beginner

Re: STP root selection error

I'll try using a different IOS image when I get back to work on Sunday.. I'll keep you guys posted..

CreatePlease to create content
Content for Community-Ad