cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Join Customer Connection to register!
370
Views
0
Helpful
4
Replies
florianlocker
Beginner

Strange VLAN forwarding in trunk

I've got a strange behavior on a c3850. We use VLAN 381 as transfer vlan. After the changing the core switches, this vlan doesn't work any more.

 

The output of "sh int trunk":

Port        Mode             Encapsulation  Status        Native vlan
Gi1/0/1     on               802.1q         trunking      1
Gi1/0/2     on               802.1q         trunking      1
Po16        on               802.1q         trunking      1

Port        Vlans allowed on trunk
Gi1/0/1     381,401-499
Gi1/0/2     381,401-499
Po16        1-4094

Port        Vlans allowed and active in management domain
Gi1/0/1     381,401,444
Gi1/0/2     381,401,444
Po16        1,33-37,41-42,100,381,401,444,500

Port        Vlans in spanning tree forwarding state and not pruned
Gi1/0/1     381,401,444
Gi1/0/2     381,401,444
Po16        1,33-37,41,100

So i take a look at the "sh spanning-tree vlan 381"

VLAN0381
  Spanning tree enabled protocol rstp
  Root ID    Priority    8573
             Address     0008.e3xx.xxxx
             Cost        1
             Port        2392 (Port-channel16)
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    33149  (priority 32768 sys-id-ext 381)
             Address     a4b2.39yy.yyyy
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time  300 sec

Interface           Role Sts Cost      Prio.Nbr Type
------------------- ---- --- --------- -------- --------------------------------
Gi1/0/1             Desg FWD 4         128.1    P2p
Gi1/0/2             Desg FWD 4         128.2    P2p
Po16                Root FWD 1         128.2392 P2p

Here is the state on forwarding and he know the Po is his root-port. But there no connection possible to the devices that are connected on Gi1/0/1 and Gi1/0/2.

 

Here the (simple) portconfig:

interface Port-channel16
 switchport mode trunk

interface TenGigabitEthernet1/1/4
 switchport mode trunk
 channel-group 16 mode active

interface TenGigabitEthernet3/1/4
 switchport mode trunk
 channel-group 16 mode active

I connected a third fiber, to fix the problem quick and dirty, and configured this connection as switchport (vlan 381). Then it worked. The devices on the Gi-Ports worked again.

Now I want to get rid of this third fiber and get the trunk working properly. Does anyone an idea whats happend on this trunk? Why doens't came this vlan in the forwarding state? The Portchannel and trunk worked fine before the Core-Switch-Change.

 

 

 

 

 

4 REPLIES 4
pieterh
VIP Collaborator

you only show details on one side of the connection

inspect the port-channel from the coreswitch to this switch! looks like this is not trunking

The core switch was already connected to the edge switch. its working fine for 2 weeks, until I moved die Router IP from the old Core to the new core. the other recent change was the shut down of the old core switches -> spanning-tree change.

 

Before the faulty trunk topology:

old core* <-> new core <-> edge switch

 

Faulty trunk topology:

new core* <-> edge switch

 

*Default Gateway and Root Bridge

paul driver
VIP Mentor

Hello

Did you actually create that vlan at l2 prior to enabling on a access port - I would say now if you shutdown that third fibre it would work just make sure the vlan is propagated to all switches in the vtp domain 



kind regards
Paul

Please rate and mark posts accordingly if you have found any of the information provided useful.
It will hopefully assist others with similar issues in the future

The vlan was created before I created the thrid fibre connection. We used the connection 2 weeks (with all vlans) before the change at the core without any problems. There was no configuration change at the edge or the core side of the trunk. I just moved the IP addresses from the old core to the new one. Then I shut down the old core.

 

VTP is not configured in this network.