cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Join Customer Connection to register!
1963
Views
5
Helpful
13
Replies
John Peterson
Beginner

Stub router not updating routing table - EIGRP

We have small which I'm looking to implement and have built this on GNS3.

We have:

Router A in site 1

Router B in site 2

Router C in site 3

Router A and B are connection via a point to point 100M link and from Router C we have a 2 point to point one of which is 5Mpbs and going to Router A and Router B.

For Router C to reach Router A network it will go via Router B and these are 100M connection. When the link between Router A and B goes down. Router C should update and start using the 5m route.

For some reson, the routes are not updating. I have to do 'clea ip eigrp ne' for the routes to update and if I reload the routers all works well, it seems the problem is intermittent.

Anybody come across this before?

13 REPLIES 13
John Blakley
Advisor

John,

What type of router and IOS version? What does your topology look like?

Router A ----- Rtr C

           \         /

            \      /

              RtrB

Is it like above?

HTH, John *** Please rate all useful posts ***

Yes mate,

I have attached a folder which includes the debug outputs from Router C and a section of the topolgy.

I'm using GNS3 with 3725 routers and IPBASE-M Version 12.4(7).

This is a toplogy which will be going into production, but I wanted to test my design to find any flaws before implmentation.

The connections to the routers are trunked and when access ports on the switches which connect to Router C.

In order to simulate a network down I change the vlan information on the switch or unplug the cable between the switches.

When this is done, Router B1 and B2 do not see the 192.168.2.0 network but Router C has this network in its routing table with the next hop being Router B1 and B2 but it should be 172.16.23.1You can also see from the debug that the routes are updated due to the timer.

Thanks.

Abzal
Rising star

Hi,

I assume routerA2 participating on EIGRP routing? Have you enabled EIGRP on routerA2 interface toward routerC?

routerA2:

sh run | sec eigrp

sh ip protocols

sh ip eigrp topology all-links

show results of commands.

Hope it will help.

Best regards,
Abzal

Hi,

All routers are in eigrp, when I excute the clear ip eigrp neighbors, the route get removed and the correct routes gets inserted into the routing table.

Router A2:

sh run | sec eigrp

router eigrp 200

passive-interface default

no passive-interface FastEthernet0/1.25

no passive-interface FastEthernet1/0

network 172.16.0.0 0.0.0.255

network 172.16.9.0 0.0.0.255

network 172.16.11.0 0.0.0.3

network 172.16.23.0 0.0.0.255

network 192.168.2.0

no auto-summary

RouterA2#

sh ip protocols

Routing Protocol is "eigrp 200"

  Outgoing update filter list for all interfaces is not set

  Incoming update filter list for all interfaces is not set

  Default networks flagged in outgoing updates

  Default networks accepted from incoming updates

  EIGRP metric weight K1=1, K2=0, K3=1, K4=0, K5=0

  EIGRP maximum hopcount 100

  EIGRP maximum metric variance 1

  Redistributing: eigrp 200

  EIGRP NSF-aware route hold timer is 240s

  Automatic network summarization is not in effect

  Maximum path: 4

  Routing for Networks:

    172.16.0.0/24

    172.16.9.0/24

    172.16.11.0/30

    172.16.23.0/24

    192.168.2.0

  Passive Interface(s):

    FastEthernet0/0

    FastEthernet0/1

    FastEthernet0/1.1

    FastEthernet0/1.10

    FastEthernet2/0

sh ip eigrp topology all-links

IP-EIGRP Topology Table for AS(200)/ID(192.168.2.252)

Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,

       r - reply Status, s - sia Status

P 192.168.1.0/24, 2 successors, FD is 261120, serno 68

        via 172.16.0.3 (261120/258560), FastEthernet0/1.25

        via 172.16.0.4 (261120/258560), FastEthernet0/1.25

P 192.168.2.0/24, 1 successors, FD is 258560, serno 6

        via Connected, FastEthernet0/1.1

        via 172.16.0.1 (261120/258560), FastEthernet0/1.25

P 192.168.3.0/24, 2 successors, FD is 157952, serno 70

        via 172.16.0.3 (157952/155392), FastEthernet0/1.25

        via 172.16.0.4 (157952/155392), FastEthernet0/1.25

        via 172.16.23.2 (1380352/128256), FastEthernet1/0

P 172.16.24.0/29, 1 successors, FD is 261120, serno 73

        via 172.16.0.3 (261120/258560), FastEthernet0/1.25

P 172.16.23.0/30, 1 successors, FD is 1252352, serno 5

        via Connected, FastEthernet1/0

P 172.16.0.16/29, 2 successors, FD is 29952, serno 66

        via 172.16.0.3 (29952/27392), FastEthernet0/1.25

        via 172.16.0.4 (29952/27392), FastEthernet0/1.25

P 172.16.0.8/29, 2 successors, FD is 29952, serno 65

Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,

       r - reply Status, s - sia Status

        via 172.16.0.3 (29952/27392), FastEthernet0/1.25

        via 172.16.0.4 (29952/27392), FastEthernet0/1.25

        via 172.16.23.2 (1277952/281600), FastEthernet1/0

P 172.16.11.0/30, 2 successors, FD is 284160, serno 67

        via 172.16.0.3 (284160/281600), FastEthernet0/1.25

        via 172.16.0.4 (284160/281600), FastEthernet0/1.25

P 172.16.0.0/29, 1 successors, FD is 27392, serno 4

        via Connected, FastEthernet0/1.25

RouterA2#


Router C:


sh run | sec eigrp

RouterC#sh run | sec eigrp

router eigrp 200

passive-interface default

no passive-interface FastEthernet0/0

no passive-interface FastEthernet0/1

network 172.16.0.0 0.0.0.255

network 172.16.23.0 0.0.0.255

network 192.168.3.0

no auto-summary

eigrp stub connected

RouterC#

sh ip protocols


RouterC#sh ip protocols

Routing Protocol is "eigrp 200"

  Outgoing update filter list for all interfaces is not set

  Incoming update filter list for all interfaces is not set

  Default networks flagged in outgoing updates

  Default networks accepted from incoming updates

  EIGRP metric weight K1=1, K2=0, K3=1, K4=0, K5=0

  EIGRP maximum hopcount 100

  EIGRP maximum metric variance 1

  EIGRP stub, connected

  Redistributing: eigrp 200

  EIGRP NSF-aware route hold timer is 240s

  Automatic network summarization is not in effect

  Maximum path: 4

  Routing for Networks:

    172.16.0.0/24

    172.16.23.0/24

    192.168.3.0

  Passive Interface(s):

    Loopback1

  Routing Information Sources:

    Gateway         Distance      Last Update

    172.16.23.1           90      00:03:02

    172.16.0.9            90      00:03:02

    Gateway         Distance      Last Update

    172.16.0.10           90      00:03:04

  Distance: internal 90 external 170

sh ip eigrp topology all-links

RouterC#sh ip eigrp topology all-links

IP-EIGRP Topology Table for AS(200)/ID(192.168.3.254)

Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,

       r - reply Status, s - sia Status

P 192.168.1.0/24, 2 successors, FD is 284160, serno 45

        via 172.16.0.9 (284160/258560), FastEthernet0/0

        via 172.16.0.10 (284160/258560), FastEthernet0/0

        via 172.16.23.1 (1280512/261120), FastEthernet0/1

P 192.168.2.0/24, 2 successors, FD is 286720, serno 60

        via 172.16.0.9 (286720/261120), FastEthernet0/0

        via 172.16.0.10 (286720/261120), FastEthernet0/0

        via 172.16.23.1 (1277952/258560), FastEthernet0/1

P 192.168.3.0/24, 1 successors, FD is 128256, serno 3

        via Connected, Loopback1

        via 172.16.23.1 (1408512/157952), FastEthernet0/1

P 172.16.24.0/29, 1 successors, FD is 284160, serno 49

        via 172.16.0.9 (284160/258560), FastEthernet0/0

        via 172.16.23.1 (1280512/261120), FastEthernet0/1

P 172.16.23.0/30, 1 successors, FD is 1275392, serno 18

        via Connected, FastEthernet0/1

        via 172.16.0.9 (1280512/1254912), FastEthernet0/0

        via 172.16.0.10 (1280512/1254912), FastEthernet0/0

Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,

       r - reply Status, s - sia Status

P 172.16.0.16/29, 2 successors, FD is 284160, serno 43

        via 172.16.0.9 (284160/27392), FastEthernet0/0

        via 172.16.0.10 (284160/27392), FastEthernet0/0

        via 172.16.23.1 (1280512/29952), FastEthernet0/1

P 172.16.0.8/29, 1 successors, FD is 281600, serno 17

        via Connected, FastEthernet0/0

        via 172.16.23.1 (1280512/29952), FastEthernet0/1

P 172.16.11.0/30, 2 successors, FD is 307200, serno 44

        via 172.16.0.9 (307200/281600), FastEthernet0/0

        via 172.16.0.10 (307200/281600), FastEthernet0/0

        via 172.16.23.1 (1303552/284160), FastEthernet0/1

P 172.16.0.0/29, 2 successors, FD is 284160, serno 42

        via 172.16.0.9 (284160/27392), FastEthernet0/0

        via 172.16.0.10 (284160/27392), FastEthernet0/0

        via 172.16.23.1 (1277952/27392), FastEthernet0/



Can you post your GNS .net file? Do you get the same problem if you don't have router C configured as a stub?

HTH, John *** Please rate all useful posts ***

Hi J,

I have been testing for the past 3 hours and its seems the problem is intermittent, for example when I remove the connection between the switches, router C1 and C2 will not have a route for the 192.168.2.0 network. On Router C the only route in the routing table is then to router B2, but B2 does not have the route,on Router C the only route at this point would need to be via 23.1.

Therefore is seems that Router B1 is passing the information but Router B2 is not, its bit of a hit and miss. The other times both router b1 and b2 stay in router c routing table.

I have removed the stub command from router c and based on the number of times i have tested this has proven more postive. But I've not had success everytime testing.

I have also checked my CPU and I'm running at 35%.

Thank you.

Please find my .net file..

autostart = False

version = 0.8.3

[127.0.0.1:7200]

    workingdir = working

    udp = 10000

    [[3725]]

        image = /home/user/Downloads/c3725-ipbase-mz.124-7/c3725-ipbase-mz.124-7.image

        ram = 128

        idlepc = 0x6073bf08

        sparsemem = True

        ghostios = True

    [[ROUTER RouterB1]]

        model = 3725

        console = 2001

        aux = 2501

        cnfg = configs/RouterB1.cfg

        f0/0 = RouterB2 f0/0

        f0/1 = SW1 1

        slot1 = NM-1FE-TX

        x = 54.8456710674

        y = -250.325901808

        z = 1.0

    [[ROUTER RouterB2]]

        model = 3725

        console = 2003

        aux = 2503

        cnfg = configs/RouterB2.cfg

        f0/0 = RouterB1 f0/0

        f0/1 = SW1 2

        slot1 = NM-1FE-TX

        x = 55.0883117546

        y = -50.8822509939

        z = 1.0

    [[ROUTER RouterA1]]

        model = 3725

        console = 2006

        aux = 2506

        cnfg = configs/RouterA1.cfg

        f0/0 = RouterA2 f0/0

        f0/1 = SW3 1

        x = -506.414213562

        y = -254.367532368

        z = 1.0

    [[ROUTER RouterA2]]

        model = 3725

        console = 2009

        aux = 2509

        cnfg = configs/RouterA2.cfg

        f0/0 = RouterA1 f0/0

        f0/1 = SW3 3

        slot1 = NM-1FE-TX

        f1/0 = SW4 2

        slot2 = NM-1FE-TX

        x = -511.004184082

        y = -53.1126983722

        z = 1.0

    [[ETHSW SW1]]

        1 = dot1q 1 RouterB1 f0/1

        2 = dot1q 1 RouterB2 f0/1

        3 = access 160 RouterC f0/0

        8 = access 150 SW3 4

        x = -137.600505063

        y = -146.325901808

        z = 1.0

    [[ROUTER RouterC]]

        model = 3725

        console = 2004

        aux = 2504

        cnfg = configs/RouterC.cfg

        f0/0 = SW1 3

        f0/1 = SW4 1

        x = -131.686291501

        y = 156.193867452

        z = 1.0

    [[ETHSW SW3]]

        1 = dot1q 1 RouterA1 f0/1

        3 = dot1q 1 RouterA2 f0/1

        4 = access 158 SW1 8

        x = -346.5

        y = -146.911688245

        z = 1.0

    [[ETHSW SW4]]

        1 = access 1 RouterC f0/1

        2 = access 1 RouterA2 f1/0

        x = -369.25440072

        y = 162.190908859

        z = 1.0

[GNS3-DATA]

    configs = configs

    workdir = working

    m11 = 0.707106781187

    m22 = 0.707106781187

John,

I don't see a problem on my end. I think you're probably running into an issue with GNS. On real equipment, you shouldn't see the issue that you're seeing. Here's another thing you could try, and you may have already done so. Instead of deleting links, which can sometimes wig GNS out, try shutting down the interface of the router. You'll get the same result of eigrp reconverging, but I think you'll find that it does it more consistently for you.

HTH,

John

HTH, John *** Please rate all useful posts ***

Thanks John,

I'm not able to shutdown the interfaces and I have sub interfaces on the physical interface which also serve other networks. My idea on breaking the link would mean that the hello timer would expire and bring the neighbour down.

One of my concern was that Router C has two neighbours, Router B1 and B2. as the subnet is a /29. This was implmeneted in case of one router going down. Could this be a issue with EIGRP, as normally you would have /30 ranges?

John,

EIGRP doesn't require /30s to work. Can you post your gns configs too? I can look at it a little later this morning.

Thanks,

John

HTH, John *** Please rate all useful posts ***

Thought so.

I have attached the config to this post.

Thanks for all your help.

John.

John,

I think it had a lot to do with the GNS switches. I deleted those and put in some L3 switches and configured them for L2. I get the route changes fine on RouterC. I'll attach the saved files so you can look through them:

Here's the routing table after shutting down the link between the 2 switches:

RouterC#sh ip route 192.168.2.0

Routing entry for 192.168.2.0/24

  Known via "eigrp 200", distance 90, metric 1254912, type internal

  Redistributing via eigrp 200

  Last update from 172.16.23.1 on FastEthernet0/1, 00:00:09 ago

  Routing Descriptor Blocks:

  * 172.16.23.1, from 172.16.23.1, 00:00:09 ago, via FastEthernet0/1

      Route metric is 1254912, traffic share count is 1

      Total delay is 200 microseconds, minimum bandwidth is 2048 Kbit

      Reliability 255/255, minimum MTU 1500 bytes

      Loading 1/255, Hops 1

Bolded is RouterA (5Mb link?)

Here's after bringing that link back up:

Routing entry for 192.168.2.0/24

  Known via "eigrp 200", distance 90, metric 33280, type internal

  Redistributing via eigrp 200

  Last update from 172.16.0.9 on FastEthernet0/0, 00:00:00 ago

  Routing Descriptor Blocks:

  * 172.16.0.9, from 172.16.0.9, 00:00:00 ago, via FastEthernet0/0

      Route metric is 33280, traffic share count is 1

      Total delay is 300 microseconds, minimum bandwidth is 100000 Kbit

      Reliability 255/255, minimum MTU 1500 bytes

      Loading 1/255, Hops 2

Toward RouterB...here's a failover test:

RouterC#sh ip route | inc 192.168.2.0

D    192.168.2.0/24 [90/33280] via 172.16.0.10, 00:00:37, FastEthernet0/0

RouterC#

RouterC#ping 192.168.2.254 rep 200

Type escape sequence to abort.

Sending 200, 100-byte ICMP Echos to 192.168.2.254, timeout is 2 seconds:

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!......!!!!!!!!!!!!!!!!!

!!!!!!!!!!!!!!!!!!!!!!.

Success rate is 92 percent (86/93), round-trip min/avg/max = 44/65/96 ms

RouterC#sh ip route | inc 192.168.2.0

D    192.168.2.0/24 [90/1254912] via 172.16.23.1, 00:00:10, FastEthernet0/1

RouterC#

I set a couple of things different. RouterC I changed to max paths of 1 so I'd only see the one route in the routing table. I deleted the GNS switches and configured 2 L3s. I trunked the ports between the 2 switches and then trunked the ports from A1 and A2 and B1 and B2. I made the port that RouterC connected to an access port. One other thing was that I noticed when I created the trunk between the switches, hsrp was giving me problems between the 2 sites. It didn't make a lot of sense. I changed the hsrp group from 1 to 11 on both B routers to keep from getting the "existing group" error.

HTH,

John

***** Please rate all useful posts *****

HTH, John *** Please rate all useful posts ***

Thanks John, really apperciate your time.

I think you are right, I'm going to give it a go.

How did you configure L3 swicthes in GNS, I thought it was not possible?

If you select Etherswitch router, it uses your IOS image. It's really a router with an etherswitch module in it. It's limited in what it can do, but fortunately you can do some spanning-tree stuff, vtp, and vlans:

John

HTH, John *** Please rate all useful posts ***