cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
169
Views
0
Helpful
0
Replies

Switch port configuration for VoIP on a 9300-L switch

HUGH LANCASTER
Beginner
Beginner

I am new to VoIP and we are moving over from an OLD PBX pots phone system. The vendor sent me a list of specifications  and I want to ensure I have all configs correct and no surprises.

Here is my config: 

interface GigabitEthernet1/0/1
switchport access vlan 20
switchport mode access
switchport voice vlan 130
switchport port-security maximum 2
switchport port-security violation restrict
switchport port-security mac-address sticky
switchport port-security mac-address sticky ac91.a1f9.6624
switchport port-security aging time 10
switchport port-security
trust device cisco-phone
storm-control broadcast level 10.00
auto qos voip cisco-phone
spanning-tree portfast
spanning-tree bpduguard enable
service-policy input AutoQos-4.0-CiscoPhone-Input-Policy
service-policy output AutoQos-4.0-Output-Policy
end

The vendor stated my config look good but I need to respond to the vendor specifications below.

We have core switch where my SVI are located. I have multiple VLANs established. Network is in star configuration and trunks are enabled between switches. Our router is managed by an outside source

 

Vendor specifications: 


ð Confirm QoS is globally enabled on each port within the Voice VLAN and is set to trust DSCP. - ?
ð Confirm that Switches are not configured to rewrite DSCP.
ð Confirm LAN is honoring and prioritizing QoS AF31 with COS of 3 for Signaling ?
ð Confirm LAN is honoring and prioritizing COS of 5 at Layer 2 for RTP ?
ð Confirm a Voice VLAN has been created for the VoIP traffic: Complete
ð Confirm each switch port that both a VoIP phone and PC will connect to is configured as a trunk port allowing both
Data and Voice VLAN’s with 802.1Q VLAN tagging enabled. I have the switchport configured as an access port
ð If the VoIP Phones will draw PoE, then confirm the Switch equipment is IEE compliant. (PoE is typically enabled by
Default (PoE Standards: 802.3af-2003 and 802.3at-2009 (PoE+)) Confirmed
ð If the switch is executing “MAC FILTERING” then you will need to allow Multiple MAC addresses per port on the
switch where the VoIP Phones and PC’s will be connected on a single port. I'm good on this
ð In addition to the CoS on all trunk ports for the switched QoS, this can be further optimized by using 3+1 priority
queueing. This means that one queue, typically queue 4, is reserved for priority traffic such as RTP and there are
three weighted round robin queues for normal traffic that can be adjusted to fit a customer’s needs.?
Thanks!!

0 Replies 0
Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: