Showing results for 
Search instead for 
Did you mean: 

Trouble with Windows7 and Gigabit link on Cisco 3560X switch

Roland Theisen


In my company, we are using Cisco IP Phones 7945G (with 2 gigabit network ports) and Cisco 3560X-48P (1GB ports) switches for our users.

Our client computers are running on Windows 7 SP1 (64bit - Enterprise edition) and are connected behind the IP Phone. We use a "Boradcom

Xtreme Gigabit" onboard network card on the computers. All ports (on the switch site and IP Phone side) and on the network card of the computer are configured in "auto negotiation". Duplex and speed are set to "auto".

We tried now to deploy a new engineering software and we are facing a very strange problem. This means that the engineer software fails to download some files from the server. We are using a flat network, all the servers and computers are on the same network segment with no firewall inbetween.

The firewall and Anti-virus on the computers are configured to allow all incoming/outing connections.

To troubleshoot, I tried to change all the network cables but I still get same result --> download fails.

I connected the client computer directly to the Cisco 3560X switch, without the IP Phone and I get the same result.

I installed a separate network card from INTEL (Intel PRO1000 PT) but I get the same result.

As last test, I have connected to same client computer directly to a Cisco 2960-8TC switch (100Mbit; auto negotiate) and here is working fine. The software successfully downloads all the files from the server.

If I connect the computer behind the Cisco 7945 IP Phone, set the speed and duplex of the PC-Port on the Cisco IP Phone 7945G to "100MBit/full duplex" is also working fine.

Is there any know issue with Windows7 and Gigabit network connections?

Do I need to set any Registry key on my Windows 7?

The firmware version of my Cisco 3560X-48P switch is 12.2(53)SE2; do I need to update it?

The firmware version of the IP Phone 7945G is 9.2.1.

Thanks in advanced for your help.

Marc Hoffmann

5 Replies 5

Jeff Van Houten

Have you looked at the server side config? Since its all computers I'd look at the server side.

Sent from Cisco Technical Support iPad App

Roland Theisen

Hello, Thanks for your answers. First of all, I have updated the firmware of my Cisco Catalyst 3560X-48P switch to the version 12.2(55)SE5. Unfortunately, this did not solve my problem. As second step, I ran an TDR test on my 3560X switch but I do not get any result. The "Pair status" always says "not completed". Even if I wait for 5 minutes, the status remains at "Not completed". Am I doing something wrong ? To do the TDR test, I use the commande "test cable-diagnostics tdr interface gigabitEthernet 0/XY". For your information, the port gigabitEthernet 0/XY is in a "Connected" status when I run the "show int status" command. Jeff, I think there is no issue on the server side, because if I connect my workstation on a 100MB switch (example Cisco Catalyst 2960-8TC-L) the application works absolutely fine. Also, if I run the application locally on the server, it works fine. As next step, I will connect the workstation directly on our backbone switch and try the same test. Is there perhaps any Registry key in our Windows7 which could cause this trouble? If you have any other ideas or options, please let me know. Thanks a lot, Marc Hoffmann

Roland Theisen

The problems has been solved. --> Windows updates Marc Hoffmann




Do you recall which windows update was causing your issue?

Leo Laohoo
Hall of Fame Community Legend Hall of Fame Community Legend
Hall of Fame Community Legend
The firmware version of my Cisco 3560X-48P switch is 12.2(53)SE2; do I need to update it?

Not related to your issue, but YES.  DO NOT, under any circumstances, use this version.  It's is as buggy as he11!  I would recommend 12.2(55)SE9 instead.


Now, back to your issue, try to run a TDR test.


NOTE:  When running TDR, 3560G/E/X is a different "beast" to a 3750G/E/X or 2960/G/S.  Instead of waiting for 5 to 7 seconds, I'd recommend you wait for 20 (or so seconds) before running the "show" command. 

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers