cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
729
Views
5
Helpful
6
Replies

Troubling getting NAT to work.

CavanP11
Level 1
Level 1

So I currently have 2 sites, that can ping perfectly within their own sites. I'm trying to get dynamic NAT working, but I still cant ping across the WANs, but the WANs can ping one another. I've tried many different ways of trying to do it but I cannot get it to work. I was told I've to use a router which acts as the Internet, rather than using a cloud. 

This is my first time asking for help, so just let me know if I need to add any extra information or anything, thank you!

 

image_2022-02-02_170426.png

 

Left router config:

Building configuration...

Current configuration : 1601 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router
!
!
!
!
!
!
!
!
no ip cef
no ipv6 cef
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface GigabitEthernet0/0
 no ip address
 ip nat inside
 duplex auto
 speed auto
!
interface GigabitEthernet0/0.10
 encapsulation dot1Q 10
 ip address 10.100.0.1 255.255.255.128
!
interface GigabitEthernet0/0.20
 encapsulation dot1Q 20
 ip address 10.100.0.129 255.255.255.224
!
interface GigabitEthernet0/0.30
 encapsulation dot1Q 30
 ip address 10.100.0.161 255.255.255.224
!
interface GigabitEthernet0/0.40
 encapsulation dot1Q 40
 ip address 10.100.0.193 255.255.255.224
!
interface GigabitEthernet0/0.50
 encapsulation dot1Q 50
 ip address 10.100.0.225 255.255.255.224
!
interface GigabitEthernet0/0.60
 encapsulation dot1Q 60
 ip address 10.100.1.1 255.255.255.240
!
interface GigabitEthernet0/0.70
 encapsulation dot1Q 70
 ip address 10.100.1.17 255.255.255.248
!
interface FastEthernet1/0
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface Serial2/0
 ip address 87.44.50.2 255.255.255.252
 ip nat outside
!
interface Serial3/0
 no ip address
 clock rate 2000000
 shutdown
!
interface FastEthernet4/0
 no ip address
 shutdown
!
router ospf 1
 log-adjacency-changes
 network 87.44.50.0 0.0.0.3 area 1
 network 87.44.50.4 0.0.0.3 area 1
!
ip nat inside source list 1 interface GigabitEthernet0/0 overload
ip classless
!
ip flow-export version 9
!
!
access-list 1 permit 10.100.0.0 0.0.255.255
!
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
 login
!
!
!
end

Right Router config:

Building configuration...

Current configuration : 1523 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Belfast
!
!
!
!
!
!
!
!
no ip cef
no ipv6 cef
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface GigabitEthernet0/0
 no ip address
 ip nat inside
 duplex auto
 speed auto
!
interface GigabitEthernet0/0.10
 encapsulation dot1Q 10
 ip address 10.100.2.1 255.255.255.224
!
interface GigabitEthernet0/0.20
 encapsulation dot1Q 20
 ip address 10.100.2.33 255.255.255.224
!
interface GigabitEthernet0/0.30
 encapsulation dot1Q 30
 ip address 10.100.2.65 255.255.255.224
!
interface GigabitEthernet0/0.40
 encapsulation dot1Q 40
 ip address 10.100.2.97 255.255.255.240
!
interface GigabitEthernet0/0.50
 encapsulation dot1Q 50
 ip address 10.100.2.113 255.255.255.248
!
interface GigabitEthernet0/0.60
 encapsulation dot1Q 60
 ip address 10.100.2.121 255.255.255.248
!
interface FastEthernet1/0
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface Serial2/0
 no ip address
 clock rate 2000000
 shutdown
!
interface Serial3/0
 ip address 87.44.50.6 255.255.255.252
 ip nat outside
 clock rate 2000000
!
interface FastEthernet4/0
 no ip address
 shutdown
!
router ospf 1
 log-adjacency-changes
 network 87.44.50.0 0.0.0.3 area 1
 network 87.44.50.4 0.0.0.3 area 1
!
ip nat inside source list 1 interface GigabitEthernet0/0 overload
ip classless
!
ip flow-export version 9
!
!
access-list 1 permit 10.100.0.0 0.0.255.255
!
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
 login
!
!
!
end

Central Router:

Building configuration...

Current configuration : 919 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router
!
!
!
!
!
!
!
!
ip cef
no ipv6 cef
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface FastEthernet1/0
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface Serial2/0
 ip address 87.44.50.1 255.255.255.252
 ip nat outside
 clock rate 2000000
!
interface Serial3/0
 ip address 87.44.50.5 255.255.255.252
 ip nat outside
!
interface FastEthernet4/0
 no ip address
 shutdown
!
interface FastEthernet5/0
 no ip address
 shutdown
!
router ospf 1
 log-adjacency-changes
 network 87.44.50.0 0.0.0.3 area 1
 network 87.44.50.4 0.0.0.3 area 1
!
ip classless
!
ip flow-export version 9
!
!
access-list 1 permit 10.100.0.0 0.0.255.255
!
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
 login
!
!
!
end
1 Accepted Solution

Accepted Solutions

Hello,

 

attached the revised file, with the OSPF and NAT fixed. Fixed in that case means: configured correctly on both the Calow and the Belfast router, but I think it is one of the quirks of Packet Tracer that it does not work end to end when NAT is configured on both sides.

 

What instructions are you following ?

View solution in original post

6 Replies 6

Hello,

 

you need to add 'ip nat inside' to each subinterface:

 

interface GigabitEthernet0/0.10
encapsulation dot1Q 10
ip address 10.100.0.1 255.255.255.128
--> ip nat inside
!
interface GigabitEthernet0/0.20
encapsulation dot1Q 20
ip address 10.100.0.129 255.255.255.224
--> ip nat inside
!
interface GigabitEthernet0/0.30
encapsulation dot1Q 30
ip address 10.100.0.161 255.255.255.224
--> ip nat inside
!
interface GigabitEthernet0/0.40
encapsulation dot1Q 40
ip address 10.100.0.193 255.255.255.224
--> ip nat inside
!
interface GigabitEthernet0/0.50
encapsulation dot1Q 50
ip address 10.100.0.225 255.255.255.224
--> ip nat inside
!
interface GigabitEthernet0/0.60
encapsulation dot1Q 60
ip address 10.100.1.1 255.255.255.240
--> ip nat inside
!
interface GigabitEthernet0/0.70
encapsulation dot1Q 70
ip address 10.100.1.17 255.255.255.248
--> ip nat inside

I still seem to be having the same issue as before. I can ping from the PCs from the Carlow side to the Serial2/0 on the Carlow Router  (87.44.50.2) but cannot ping the one on the central router (87.44.50.1) on the same serial, if that helps?

Hello,

 

post your zipped Packet Tracer project (.pkt) file...

 

Hello,

 

attached the revised file, with the OSPF and NAT fixed. Fixed in that case means: configured correctly on both the Calow and the Belfast router, but I think it is one of the quirks of Packet Tracer that it does not work end to end when NAT is configured on both sides.

 

What instructions are you following ?

That has worked perfectly! I completely forgot about the router ids, thanks a million for the help!

Review Cisco Networking for a $25 gift card