cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Ask the Expert- SD-WAN

441
Views
0
Helpful
1
Replies
Beginner

Trunk Link between Cisco and Brocade VDX Switch

Hi Folks, 

I am having a hard time to get a trunk link working between Cisco 4500X and Brocade VDX 6740

Network Diagram attached, there are currently 4 Interfaces connected between two switches as port-channel and it's access port, the new link I am connecting is a trunk link so I can test few things before converting the port-channel to a trunk.

Issue: whenever i bring the new link up all ports in the port-channel goes into error-disabled state 

Logs below 

appreciate any help on this.

Jul 26 15:44:25.443: %LINK-3-UPDOWN: Interface TenGigabitEthernet2/1/20, changed state to up
Jul 26 15:44:28.657: %LINEPROTO-5-UPDOWN: Line protocol on Interface TenGigabitEthernet2/1/20, changed state to up
Jul 26 15:44:31.038: %CDP-4-NATIVE_VLAN_MISMATCH: Native VLAN mismatch discovered on TenGigabitEthernet2/1/11 (X), with SW02 (same switch) TenGigabitEthernet2/1/20 (1).
Jul 26 15:44:32.076: %CDP-4-NATIVE_VLAN_MISMATCH: Native VLAN mismatch discovered on TenGigabitEthernet2/1/11 (X), with SW02 (same switch) TenGigabitEthernet2/1/20 (1).
Jul 26 15:44:33.058: %CDP-4-NATIVE_VLAN_MISMATCH: Native VLAN mismatch discovered on TenGigabitEthernet2/1/11 (X), with SW02 (same switch) TenGigabitEthernet2/1/20 (1).
Jul 26 15:44:34.073: %CDP-4-NATIVE_VLAN_MISMATCH: Native VLAN mismatch discovered on TenGigabitEthernet2/1/11 (X), with SW02 (same switch) TenGigabitEthernet2/1/20 (1).
Jul 26 15:44:35.067: %CDP-4-NATIVE_VLAN_MISMATCH: Native VLAN mismatch discovered on TenGigabitEthernet2/1/11 (X), with SW02 (same switch) TenGigabitEthernet2/1/20 (1).
Jul 26 15:44:35.540: %UDLD-4-UDLD_PORT_DISABLED: UDLD disabled interface Te2/1/11, neighbor mismatch detected
Jul 26 15:44:35.540: %PM-4-ERR_DISABLE: udld error detected on Te2/1/11, putting Te2/1/11 in err-disable state
Jul 26 15:44:35.542: %EC-5-UNBUNDLE: Interface Te2/1/11 left the port-channel Po10
Jul 26 15:44:36.092: %CDP-4-NATIVE_VLAN_MISMATCH: Native VLAN mismatch discovered on TenGigabitEthernet2/1/12 (X), with SW02 TenGigabitEthernet2/1/20 (1).
Jul 26 15:44:36.549: %LINEPROTO-5-UPDOWN: Line protocol on Interface TenGigabitEthernet2/1/11, changed state to down
Jul 26 15:44:35.641: %EC-5-UNBUNDLE: STANDBY:Interface Te2/1/11 left the port-channel Po10
Jul 26 15:44:37.075: %CDP-4-NATIVE_VLAN_MISMATCH: Native VLAN mismatch discovered on TenGigabitEthernet2/1/12 (X), with SW02 TenGigabitEthernet2/1/20 (1).
Jul 26 15:44:37.549: %LINK-3-UPDOWN: Interface TenGigabitEthernet2/1/11, changed state to down
Jul 26 15:44:41.037: %UDLD-4-UDLD_PORT_DISABLED: UDLD disabled interface Te2/1/12, neighbor mismatch detected
Jul 26 15:44:41.037: %PM-4-ERR_DISABLE: udld error detected on Te2/1/12, putting Te2/1/12 in err-disable state
Jul 26 15:44:41.039: %EC-5-UNBUNDLE: Interface Te2/1/12 left the port-channel Po10
Jul 26 15:44:42.045: %LINEPROTO-5-UPDOWN: Line protocol on Interface TenGigabitEthernet2/1/12, changed state to down
Jul 26 15:44:41.155: %EC-5-UNBUNDLE: STANDBY:Interface Te2/1/12 left the port-channel Po10
Jul 26 15:44:43.046: %LINK-3-UPDOWN: Interface TenGigabitEthernet2/1/12, changed state to down
Jul 26 15:44:53.046: %UDLD-4-UDLD_PORT_DISABLED: UDLD disabled interface Te1/1/12, neighbor mismatch detected
Jul 26 15:44:53.046: %PM-4-ERR_DISABLE: udld error detected on Te1/1/12, putting Te1/1/12 in err-disable state
Jul 26 15:44:53.048: %EC-5-UNBUNDLE: Interface Te1/1/12 left the port-channel Po10
Jul 26 15:44:54.051: %LINEPROTO-5-UPDOWN: Line protocol on Interface TenGigabitEthernet1/1/12, changed state to down
Jul 26 15:44:53.046: %EC-5-UNBUNDLE: STANDBY:Interface Te1/1/12 left the port-channel Po10
Jul 26 15:44:55.059: %LINK-3-UPDOWN: Interface TenGigabitEthernet1/1/12, changed state to down
Jul 26 15:45:04.061: %UDLD-4-UDLD_PORT_DISABLED: UDLD disabled interface Te2/1/20, unidirectional link detected
Jul 26 15:45:04.061: %PM-4-ERR_DISABLE: udld error detected on Te2/1/20, putting Te2/1/20 in err-disable state
Jul 26 15:45:05.068: %LINEPROTO-5-UPDOWN: Line protocol on Interface TenGigabitEthernet2/1/20, changed state to down
Jul 26 15:45:06.075: %LINK-3-UPDOWN: Interface TenGigabitEthernet2/1/20, changed state to down
Jul 26 15:45:18.058: %LINK-5-CHANGED: Interface TenGigabitEthernet2/1/20, changed state to administratively down
Jul 26 15:47:32.726: %LINK-5-CHANGED: Interface TenGigabitEthernet2/1/11, changed state to administratively down
Jul 26 15:47:36.148: %LINK-3-UPDOWN: Interface TenGigabitEthernet2/1/11, changed state to up
Jul 26 15:47:40.409: %EC-5-BUNDLE: Interface Te2/1/11 joined port-channel Po10
Jul 26 15:47:41.417: %LINEPROTO-5-UPDOWN: Line protocol on Interface TenGigabitEthernet2/1/11, changed state to up
Jul 26 15:47:40.509: %EC-5-BUNDLE: STANDBY:Interface Te2/1/11 joined port-channel Po10
Jul 26 15:47:45.043: %LINK-5-CHANGED: Interface TenGigabitEthernet2/1/12, changed state to administratively down
Jul 26 15:47:47.910: %LINK-3-UPDOWN: Interface TenGigabitEthernet2/1/12, changed state to up
Jul 26 15:47:52.154: %EC-5-BUNDLE: Interface Te2/1/12 joined port-channel Po10
Jul 26 15:47:53.155: %LINEPROTO-5-UPDOWN: Line protocol on Interface TenGigabitEthernet2/1/12, changed state to up
Jul 26 15:47:52.250: %EC-5-BUNDLE: STANDBY:Interface Te2/1/12 joined port-channel Po10
Jul 26 15:48:11.470: %LINK-5-CHANGED: Interface TenGigabitEthernet1/1/12, changed state to administratively down
Jul 26 15:48:16.426: %LINK-3-UPDOWN: Interface TenGigabitEthernet1/1/12, changed state to down
Jul 26 15:48:18.623: %LINK-3-UPDOWN: Interface TenGigabitEthernet1/1/12, changed state to up
Jul 26 15:48:22.238: %EC-5-BUNDLE: Interface Te1/1/12 joined port-channel Po10
Jul 26 15:48:23.250: %LINEPROTO-5-UPDOWN: Line protocol on Interface TenGigabitEthernet1/1/12, changed state to up
Jul 26 15:48:22.349: %EC-5-BUNDLE: STANDBY:Interface Te1/1/12 joined port-channel Po10

 

SW02#sh run int po10

interface Port-channel10
switchport
switchport access vlan X
end

SW02#sh run int te2/1/20
!
interface TenGigabitEthernet2/1/20
switchport mode trunk
shutdown
end

1 REPLY 1
Highlighted
Contributor

Re: Trunk Link between Cisco and Brocade VDX Switch

According to the error messages you just need to specify the native vlan on both sides of the trunk link.

 

it is best practice to create a unused separate native VLAN on both switches

 

ex,

 

vlan 5

name NEW_NATIVE

 

interface po 2

switchport mode trunk

swithport trunk native vlan 5

 

interface TenGigabitEthernet2/1/20
switchport mode trunk

swithport trunk native vlan 5

channel-group 2 mode (choose between ACTIVE or ON (lacp or strict))

 

 

***Do the same for the Brocade, but the commands may be different*******

 

 

HTH-

 

Vince

CreatePlease to create content
Content for Community-Ad
July's Community Spotlight Awards