cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
579
Views
0
Helpful
1
Replies

Two NAT on a single router

nilesh.jain
Level 1
Level 1

Hi, 

In attached scenerio, just want to configure two nating on R1 i.e. one for R4 ( Overload ) and another one for R2 (dynamic).

At the moment , only one nating works.

Is this possible to configure or not.

1 Reply 1

cadet alain
VIP Alumni
VIP Alumni

Hi,

yes it is doable, here is an example:

interface FastEthernet0/0

ip address 10.0.41.1 255.255.255.0

ip nat inside

interface Serial1/0

ip address 10.0.12.1 255.255.255.0

ip nat outside

interface Serial1/1

ip address 10.0.13.1 255.255.255.0

ip nat outside

ip route 2.2.2.0 255.255.255.0 10.0.12.2

ip route 3.3.3.0 255.255.255.0 10.0.13.3

ip nat pool mypool 10.0.12.4 10.0.12.8 netmask 255.255.255.0

ip nat inside source route-map NATR2 pool mypool

ip nat inside source route-map NATR3 interface Serial1/1 overload

access-list 1 permit 10.0.41.0 0.0.0.255

route-map NATR3 permit 10

match ip address 1

match interface Serial1/1

route-map NATR2 permit 10

match ip address 1

match interface Serial1/0

from R4 I ping 2.2.2.2 and 3.3.3.3 --->

R4(config-if)#do ping 2.2.2.2

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 2.2.2.2, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 20/37/72 ms

R4(config-if)#do ping 3.3.3.3

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 3.3.3.3, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 16/32/68 ms

R1(config)#do sh ip nat tra

Pro Inside global      Inside local       Outside local      Outside global

icmp 10.0.12.4:3       10.0.41.4:3        2.2.2.2:3          2.2.2.2:3

icmp 10.0.13.1:4       10.0.41.4:4        3.3.3.3:4          3.3.3.3:4

Regards

Alain

Don't forget to rate helpful posts.

Don't forget to rate helpful posts.
Review Cisco Networking for a $25 gift card