cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
728
Views
0
Helpful
7
Replies

VLAN configuration

skhirbash
Level 1
Level 1

Hi all,

I have 6 Catalyst 2950 switches that I am planning on configuring with 5 VLANS( VTP, Trunking, logical interfaces with separate subnets have been configured on the Router). The only clarification that I need is if I have to configure each VLAN with a separate subnet and if so where do I assign the ip subnet to the VLAN?

Thanks in advance.

2 Accepted Solutions

Accepted Solutions

bjornarsb
Level 4
Level 4

Hi,

The configuration you want is called router on a stick. You configure trunk on the uplink port between your switch and your router.

Then you must have trunk encapsulation on your router and its on the router you assign subnets to your subinterfaces.

On the switch you configure the same vlan on the ports that belongs to the same subnet.

In short the vlan - subnet configuration is done at your router.

HTH

Do no hesitate to post a new question if you want config examples!

Regards,

Bjornarsb

View solution in original post

Sadik

Yes you are correct that the encapsulation command on the logical inteface does specify the ID of the VLAN. This is how the assignment of subnet to VLAN takes place.

HTH

Rick

HTH

Rick

View solution in original post

7 Replies 7

Richard Burts
Hall of Fame
Hall of Fame

Sadik

Yes each VLAN should be configured with a separate subnet. The place to assign the ip subnet to the VLAN is in the logical interfaces on the router.

Each 2950 switch can have a single VLAN interface active and configured with an IP address. This is done to allow the switch to be managed remotely. Generally the switch addresses are in the same subnet and it is assigned to the management VLAN.

HTH

Rick

HTH

Rick

Hi Friend,

In addition to Rick's post 2950 is a layer 2 switch so you will not be able to create multiple logical interfaces on 2950 switch. Either you need layer 3 switch like 3550 and above or router where you can create sub interfaces for multiple vlan support.

It is always good to keep all your layer 2 switches like 2950 with same vlan interface/subnet for management purpose. As Rick updated you can only have one logical interface up and running on layer 2 switch which is 2950 in your case.

HTH

Ankur

bjornarsb
Level 4
Level 4

Hi,

The configuration you want is called router on a stick. You configure trunk on the uplink port between your switch and your router.

Then you must have trunk encapsulation on your router and its on the router you assign subnets to your subinterfaces.

On the switch you configure the same vlan on the ports that belongs to the same subnet.

In short the vlan - subnet configuration is done at your router.

HTH

Do no hesitate to post a new question if you want config examples!

Regards,

Bjornarsb

Thanks to all for the prompt and concise clarification. I was confused on how the subnet on the router corresponds to the specific VLAN, but I now know that the logical interface is assigned the subnet ip and the 802.1q encapsulation is assigned the ID number of the VLAN. I hope I am correct!

Sadik

Yes you are correct that the encapsulation command on the logical inteface does specify the ID of the VLAN. This is how the assignment of subnet to VLAN takes place.

HTH

Rick

HTH

Rick

Hi,

Yes like this:

interface fastethernet2/0.20

encapsulation isl 20

ip address 10.1.20.1 255.255.255.0

ip pim dense-mode

interface fastethernet2/0.30

encapsulation isl 30

ip address 10.1.30.1 255.255.255.0

ip pim dense-mode

HTH, please rate all helpfull posts.

BR,

Bjornarsb

In addition to Bjornarsb's post this what you need to do for 802.1q encapsulation

Router

interface FastEthernet0/0

no ip address

duplex auto

speed auto

interface FastEthernet0/0.1

encapsulation dot1Q 1 native

ip address 10.10.10.15 255.255.255.0

no snmp trap link-status

!

interface FastEthernet0/0.16

encapsulation dot1Q 16

ip address 172.16.16.1 255.255.255.0

no snmp trap link-status

!

interface FastEthernet0/0.99

encapsulation dot1Q 99

ip address 192.168.180.50 255.255.255.0

no snmp trap link-status

Switch

interface FastEthernet0/23

switchport mode trunk

no ip address

interface Vlan1

ip address 10.10.10.12 255.255.255.0

no ip route-cache

-amit singh

Review Cisco Networking for a $25 gift card