07-02-2012 07:35 AM - edited 03-07-2019 07:34 AM
Two sites withtwo switches etherchannel concept for wan link
Does it work? Please suggest
On switch1--site 1
interface GigabitEthernet1/0/1--Wan link1
no switchport
no ip address
channel-protocol lacp
channel-group 1 mode active
!
interface GigabitEthernet1/0/2--wan link2
no switchport
no ip address
channel-protocol lacp
channel-group 1 mode active
interface P01
no switchport
ip address 192.168.0.52 255.255.255.0
int valn 222
ip address 10.1.1.1 255.255.255.0
no shutdown
int vlan 333
ip address 172.18.1.1 255.255.255.0
no shutown
ip route 172.19.2.0 255.255.255.0 192.168.0.52
ip route 172.20.2.0 255.255.255.0 192.168.0.52
------------------------------------------------------------------------
On switch2--site2
interface Po1
no switchport
ip address 192.168.0.51 255.255.255.0
interface GigabitEthernet0/1--wanlink1
no switchport
no ip address
channel-protocol lacp
channel-group 1 mode active
!
interface GigabitEthernet0/2-wanlink2
no switchport
no ip address
channel-protocol lacp
channel-group 1 mode active
int valn 21
ip address 172.19.2.1 255.255.255.0
no shutdown
int valn 45
ip add 172.20.2.1 255.255.255.0
no shut
ip route 172.18.2.0 255.255.255.0 192.168.0.52
ip route 10.1.1.0 255.255.255.0 192.168.0.52
07-02-2012 08:19 AM
Hi,
yes it should work. but you need to change the Next Hop ip address on Site 1:
ip route 172.19.2.0 255.255.255.0 192.168.0.51
ip route 172.20.2.0 255.255.255.0 192.168.0.51
Hope it Helps,
Soroush.
07-02-2012 09:39 AM
Thanks
Ya typed it wrongly.
But today when i tried on My lan environement with same config from switch 1 when i traced it to
172.19.2.1 it was going to 192.1168.0.51 than to 192.168.0.52 and again to 192.168.0.51 looping taking place
Why this is happening ?
07-02-2012 10:13 AM
if you successfully setup the L3 etherchannel, and its up up. then the rest is a routing loop, could u post sh ip route sw1 and sw2? u might have typed something wrong in there
HTH,
Soroush.
07-03-2012 12:42 AM
Hi please find the config done by me
mum#sh running-config
Building configuration...
Current configuration : 1778 bytes
!
version 12.2
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname mum
!
!
no aaa new-model
switch 1 provision ws-c3750g-24ts-1u
ip subnet-zero
ip routing
!
!
!
!
no file verify auto
spanning-tree mode pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
interface Port-channel1
no switchport
ip address 192.168.0.52 255.255.255.0
!
interface GigabitEthernet1/0/1
no switchport
no ip address
channel-protocol lacp
channel-group 1 mode active
!
interface GigabitEthernet1/0/2
no switchport
no ip address
channel-protocol lacp
channel-group 1 mode active
!
interface GigabitEthernet1/0/3
!
interface GigabitEthernet1/0/4
!
interface GigabitEthernet1/0/5
switchport access vlan 500
!
interface GigabitEthernet1/0/6
switchport access vlan 501
!
interface GigabitEthernet1/0/7
!
interface GigabitEthernet1/0/8
!
interface GigabitEthernet1/0/9
!
interface GigabitEthernet1/0/10
!
interface GigabitEthernet1/0/11
!
interface GigabitEthernet1/0/12
!
interface GigabitEthernet1/0/13
!
interface GigabitEthernet1/0/14
!
interface GigabitEthernet1/0/15
!
interface GigabitEthernet1/0/16
!
interface GigabitEthernet1/0/17
!
interface GigabitEthernet1/0/18
!
interface GigabitEthernet1/0/19
!
interface GigabitEthernet1/0/20
!
interface GigabitEthernet1/0/21
!
interface GigabitEthernet1/0/22
!
interface GigabitEthernet1/0/23
!
interface GigabitEthernet1/0/24
!
interface GigabitEthernet1/0/25
!
interface GigabitEthernet1/0/26
!
interface GigabitEthernet1/0/27
!
interface GigabitEthernet1/0/28
!
interface Vlan1
no ip address
!
interface Vlan500
ip address 172.18.2.1 255.255.255.0
!
interface Vlan501
ip address 172.20.2.1 255.255.255.0
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.0.51
ip http server
!
!
control-plane
!
!
line con 0
line vty 5 15
!
!
End
pun#sh running-config
Building configuration...
Current configuration : 1841 bytes
!
! Last configuration change at 00:35:18 UTC Mon Mar 1 1993
!
version 15.0
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname pun
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
system mtu routing 1500
ip routing
!
!
!
!
!
!
!
!
spanning-tree mode pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
!
!
!
!
!
interface Port-channel1
no switchport
ip address 192.168.0.51 255.255.255.0
!
interface Port-channel5
!
interface GigabitEthernet0/1
no switchport
no ip address
channel-protocol lacp
channel-group 1 mode active
!
interface GigabitEthernet0/2
no switchport
no ip address
channel-protocol lacp
channel-group 1 mode active
!
interface GigabitEthernet0/3
!
interface GigabitEthernet0/4
!
interface GigabitEthernet0/5
switchport access vlan 666
!
interface GigabitEthernet0/6
switchport access vlan 665
!
interface GigabitEthernet0/7
!
interface GigabitEthernet0/8
!
interface GigabitEthernet0/9
!
interface GigabitEthernet0/10
!
interface GigabitEthernet0/11
!
interface GigabitEthernet0/12
!
interface GigabitEthernet0/13
!
interface GigabitEthernet0/14
!
interface GigabitEthernet0/15
!
interface GigabitEthernet0/16
!
interface GigabitEthernet0/17
!
interface GigabitEthernet0/18
!
interface GigabitEthernet0/19
!
interface GigabitEthernet0/20
!
interface GigabitEthernet0/21
!
interface GigabitEthernet0/22
!
interface GigabitEthernet0/23
!
interface GigabitEthernet0/24
!
interface GigabitEthernet0/25
!
interface GigabitEthernet0/26
!
interface GigabitEthernet0/27
!
interface GigabitEthernet0/28
!
interface Vlan1
no ip address
!
interface Vlan665
ip address 172.17.2.1 255.255.255.0
!
interface Vlan666
ip address 172.19.2.1 255.255.255.0
!
ip http server
ip http secure-server
!
ip route 0.0.0.0 0.0.0.0 192.168.0.52
!
logging esm config
!
!
line con 0
line vty 5 15
!
end
PLease replu ASAP
07-03-2012 03:50 AM
Hi Prashant,
Try extended ping with Source IP of Vlan.
Regards,
Smitesh
07-03-2012 05:55 AM
your config looks fine, with this configuration, are your ip addresses involved in the trace process, all within your local ranges already set on vlan interfaces? coz if not, a loop might occure.
try this, remove the default route and add below cmnds, see if its any success:
SW1
ip route 172.17.2.0 255.255.255.0 192.168.0.51
ip route 172.19.2.0 255.255.255.0 192.168.0.51
SW2
ip route 172.18.2.0 255.255.255.0 192.168.0.52
ip route 172.20.2.0 255.255.255.0 192.168.0.52
if it didnt work, send a show ip route and show etherchannel sum here.
HTH,
Soroush.
07-05-2012 05:16 AM
Hi All
Another problem on eteherchannel
Etherchannel for gi1/32 and gi1/0/39 is working fine
But etherchannel for gi1/33 and gi1/0/40 is not up
On site1 on site2
gi1/32(ISP 1) gi1/0/39(ISP 1)
gi1/33(ISP2) gi1/0/40(ISP2)
gi1/32 and gi1/0/39 on site1 and site2 bundled with etherchannel
gi1/33 and gi1/0/40 on site1 and site 2 are bundled withe etherchannel
Interface status
Gi1/0/39 connected routed a-full a-100 10/100/1000BaseTX
Gi1/0/40 suspended routed full 100 10/100/1000BaseTX
Gi1/32 "tata point to poi connected routed a-full a-100 10/100/1000BaseT
Gi1/33 notconnect routed full 100 10/100/1000BaseT
Note -Duplex seetings on gi1/33 and gi1/0/40 are same
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide