cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
3783
Views
0
Helpful
6
Replies

When to use encapsulation dot1Q

Paul Smith
Level 1
Level 1

Last week a colleague and changed a customers setup to start using vlans instead of just a basic LAN. I was getting ready to put the encapsulation dot1Q command into int gig 0/1 when my colleague told me that it was already working . I checked and he was right. Both new vlans were communicating through a trunk (from the switch) but I did not need to do the command. Why not?

 

interface GigabitEthernet0/1
description Customer LAN
no ip address
duplex auto
speed auto
!
interface GigabitEthernet0/1.1
description CDP LAN
encapsulation dot1Q 1 native
ip address 10.0.0.254 255.255.255.0
ip nat inside
ip virtual-reassembly in
!
interface GigabitEthernet0/1.150
description Guest LAN
encapsulation dot1Q 150
ip address 10.0.150.254 255.255.255.0
ip access-group 15 out
ip nat inside
ip virtual-reassembly in

1 Accepted Solution

Accepted Solutions

 

It is only on the main interface you don;t need the command. 

 

Look at your original configuration and you will see it is used just not on the main interface. 

 

Jon

View solution in original post

6 Replies 6

Jon Marshall
Hall of Fame
Hall of Fame

 

Which switch model ? 

 

Some more recent switches only support that encapsulation so no need to specify it. 

 

Some of the older switches supported ISL as well and the default was usually ISL so it those you usually needed to specify the encapsulation. 

 

Jon

Hi Jon,

 

Thanks so much for helping me with this. Sorry I was talking about a router (CISCO1921/K9). The trunk I was talking about is actually coming from a HP switch.

 

Do you mean add the encapsulation to the main interface on the router ? 

 

If so you don't need to do that for it work. 

 

Jon

Yep I did. The reason I ask is because on another router (see below) the command was in place.

 

interface GigabitEthernet0/1.102
description DDA L3 link to POP
bandwidth 25000
encapsulation dot1Q 102
ip address 125.254.XXX.XXX 255.255.255.252
ip nat outside
ip virtual-reassembly

 

It is only on the main interface you don;t need the command. 

 

Look at your original configuration and you will see it is used just not on the main interface. 

 

Jon

Thanks :) silly me.

Review Cisco Networking for a $25 gift card