04-25-2020 10:47 AM
Hi network,
I am building and testing an network for small business and DHCP has troubles giving IP address to workstations between different VLAN. When I put the IP address static in an workstation the computer can get on internet. It seems that there is no messages exchanged between DHCP and client. I hope that someone could help me to fix the problem.
I am using Cisco router 1841 and switch 3560 PoE-8 and Windows server 2019 and here below are the configuration:
Router
interface fastEthernet 0/0
ip address dhcp
ip nat outside
interface fastEthernet 0/1
no ip address
ip nat inside
interface fastEthernet 0/1.10
encapsulation dot1Q 10
ip address 192.168.10.1 255.255.255.0
description VLAN 10 Servers
interface fastEthernet 0/1.20
encapsulation dot1Q 20
ip address 192.168.20.1 255.255.255.0
description VLAN 20 Users
ip access-list standard NAT
permit 192.168.10.0 0.0.0.255
permit 192.168.20.0 0.0.0.255
ip nat inside source list NAT interface FastEthernet0/0 overload
Switch
vlan 10
name Servers
vlan 20
name Users
exit
interface fastEthernet 0/3
switchport mode access
switchport access vlan 20
interface fastEthernet 0/4
switchport mode access
switchport access vlan 10
interface fastEthernet 0/8
switchport trunk encapsulation dot1q
switchport mode trunk
switchport trunk allowed vlan all
Windows Server
IP 192.168.10.10/24
default-gateway 192.168.10.10
dns-server 192.168.10.10
04-25-2020 11:09 AM - edited 04-25-2020 11:22 AM
You may still need ip dhcp relay IP command on fastEthernet 0/1.20 despite the fact that it is same router just with sub-interfaces. Anytime there is a router between (separating) DHCP and hosts, you will need install DHCP Relay service (command on router orit could be actual server).
the actual Cisco command is ip helper-address x where x is IP of DHCP server
Regards, ML
**Please Rate All Helpful Responses **
04-25-2020 12:05 PM
Hi Martin,
Thanks Martin for the small adjust. it helped me indeed but instead getting IP from the server the workstation got an IP from another DHCP outside the scope. I just deleted the DNS forwarder rule so im good to go.
cheers
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide