Showing results for 
Search instead for 
Did you mean: 

Adding Route in VCS Expressway

Vysakh Sundar

This is regarding how to add route in VCS expressway through CLI


I tried commands starting with x but it is not taking 


command which i tried


: xCommand RouteAdd Address: "" PrefixLength: 32 Gateway: ""


Server is not accepting the above one


Tried this one also but the server hangs up while giving this

route add -net netmask dev eth1
route add -net netmask dev eth0






4 Replies 4

What version of VCS are you running?  In X8.5 that just recently released, they've added the ability to add static routes via the web interface.  See the VCS Release Note X8.5, pg 4 under "Other Changes".

Thanks to every one


We have Call manager version 9.1.2 ipaddr

IM and Presence with 9.1.1  ipaddr

VCS EXpress Way with 8.2.2  Expressway ipaddr

VCS Core with 8.2.2 ipaddr


In Express way two lan


LAN1 with ip and othe LAN2 with

We provided gateway add


Added the route  in expressway


route add -net netmask gw dev eth1
route add -net netmask gw dev eth0


Right now all ports are in default values 


Created Traversalsubzone


Gave same domain in VCS and presence


Internally i tried by putting manually VCS Exoressway Ip in Jabber client setting by selecting IM and presence


It is showing cannot communic\ate to server


Please help

Adam Wamsley
Cisco Employee
Cisco Employee



The command is probably wanting the interface to apply the route to.

For example:

xcommand routeadd "" prefixlength: 24 gateway: "" interface: lan2


Martin Koch

It would be more handy if you could describe your current network setup which interfaces are used on the VCS, is the dual interface option present (is a requirement as you are trying to use two interfaces), which networks and hosts are where, ...

Also which software version you use can be helpful, as well as do a small drawing.


You listed two completely different commands, first the xcommand, which can only be used when logged in as admin via the CLI, the other which are linux-shell commands, which should not be used at all anyhow, and then how you used it (like setting a default route to the interface rather than to a gateway) looks not ok.


Please check the VCS admin guide, there you will find how to configure the basic and advanced network settings



xcommand RouteAdd

*h 'xCommand RouteAdd'
"Adds and configures a new IP route (also known as a static route)."
             Address(r): <S: 1, 39> "Specifies an IP address used in conjunction with the prefix length to determine the network to which this route applies."
             PrefixLength(r): <1..128> "Specifies the number of bits of the IP address which must match when determining the network to which this route applies. Default: 32"
             Gateway(r): <S: 1, 39> "Specifies the IP address of the gateway for this route."
             Interface: <Auto/LAN1/LAN2> "Specifies the LAN interface to use for this route. Auto: the VCS will select the most appropriate interface to use. Default: Auto"




Please remember to rate helpful responses and identify

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers