cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1675
Views
5
Helpful
6
Replies

C-Series C40 Won't Accept Static IP

Patrick Sparkman
VIP Alumni
VIP Alumni

We have a C-Series C40 that doesn't want to accept the static IP we've assigned it.  I've tried changing from DHCP to static and back and forth, sometimes rebooting between changes, but it doesn't want to use the static address we're trying to give it.  We have another codec at the same location that I've copied all the network settings from (subnet and gateway), to make sure they were correct for this location.  I've even tried to upgrade the codec (both TC5.1.3 and TC5.1.4) while in DHCP and then switch to static, reboot, however still the same results.

Any ideas, thanks.

Patrick

1 Accepted Solution

Accepted Solutions

Hello,

do you have console access to the C40 to check things via root?

Can you check /var/log/console file for any error messages? Sometimes, when IP settings are incorrect the codec revers back to DHCP. Check for lines like this :

Bringing up interfaces

ethernet-speed: Speed set to auto for eth0                                                                         

Maybe the /etc/init.d/S16network script detects issue?

It can print errors as follows :

echo "Static IP chosen, but no address set.  Using DHCP." 

Or other messages. Please check /var/log/console for errors...

View solution in original post

6 Replies 6

Magnus Ohm
Cisco Employee
Cisco Employee

Hi Patrick

Have you tried to factory default the unit and then try to configure it again?

xCommand SystemUnit FactoryReset Confirm: Yes

/Magnus

Yes, I have tried a factory reset, same results.  It keeps the same DHCP address everytime.

Hello,

do you have console access to the C40 to check things via root?

Can you check /var/log/console file for any error messages? Sometimes, when IP settings are incorrect the codec revers back to DHCP. Check for lines like this :

Bringing up interfaces

ethernet-speed: Speed set to auto for eth0                                                                         

Maybe the /etc/init.d/S16network script detects issue?

It can print errors as follows :

echo "Static IP chosen, but no address set.  Using DHCP." 

Or other messages. Please check /var/log/console for errors...

Thanks Danny!  According to the logs the subnet was inncorrect and the codec refused to use the static address, so it reverted back to DHCP.  Strange though, that the other codec at that location was using the same subnet that this one was trying to use, but was working. 

Refusing to set inconsistent network settings
IP address(*.*.76.137/25) and Gateway(*.*.76.1) is not on the same subnet!

Hi Patrick!

If your error message is correct, then the endpoint is also right.

*.*.76.137/25 allows hosts from *.*.76-129 - *.*.76.254 and *.*.76.1 is outside that range.

So maybe you have some typo or wrong info in one of the settings.

Maybe the other endpoint is configured correctly or double wrong, for exampe if you would

use /24 instead of /25 it would not show the error.

Please remember to rate helpful responses and identify

Just noticed I had a typo in my previous message, it's the gateway that was incorrect, not the subnet.  The error message threw me off when I was typing.

Both codecs are using 135 and 137 addresses.  So the other codec that was working under the .1 gateway was really in the wrong subnet.  Our network admin didn't have an explanation to how it was working, it just was.