03-20-2017 11:33 AM - edited 03-18-2019 12:54 PM
I am looking for some conformation / guidance on some QoS configuration.
I have attached a diagram of the network example for what I am looking to do.
I am looking at configuring QoS for IP Surveillance through a network. Now because the IP Camera I am using does not have a place to configure QoS DSCP settings I am doing it on the switchport. So I will set the CoS to 5 for that. Next I need to trust the CoS value on the trunk uplinks between the switches so I will configure those ports to Trust the CoS value. Next on the link to the server I will set the CoS value there just like I do on the IP Cameras for the video playback to the viewing stations. I was thinking I would need to set the CoS value on the ports connected to the Viewing stations but I am now thinking I do not need to do that because the traffic going to the station not coming from the station, am I correct in my thinking here?
I used this as a reference.
Here is what I am looking to configure.
IP Surveillance QOS setup
**************************************
Enable QOS on IDF and MDF switches
config t
mls qos
**************************************
Configure switchport for Camera
config t
int gix/x or gix/x/x
description IP Surveillance Camera
switchport mode access
switchport access vlan 45
mls qos cos 5
spanning-tree portfast
no shut
************************************
Configure trunk uplinks between switches
Do this on each side of the uplink.
config t
int gix/x or gix/x/x
mls qos trust ip-precedence
************************************
Thanks,
Mike
03-20-2017 12:35 PM
I would do exactly what you have done.
03-21-2017 04:14 AM
Great Thank you!
Go All Blacks!
Mike
03-21-2017 05:36 AM
One more configuration. For the servers where the video is stored and viewed from I was going to configure this. Goal of this is to give priority to traffic for the video viewing and mark that as CS5 and all other traffic like the control type traffic from the server marked as CS3.
class-map match-all VIEW_HTTP
match access-group name HTTP
Policy-map NVR
class VIEW_HTTP
set dscp cs5
class class-default
set dscp cs3
ip access-list extended HTTP
permit tcp any eq www any
Then on the interface where the server is connected.
interface gi1/0/1
description NVR Server
switchport mode access
switchport access vlan 45
priority-queue out
spanning-tree portfast
service-policy input NVR
Thanks,
Mike
03-21-2017 07:49 AM
Looks good to me.
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide