Showing results for 
Search instead for 
Did you mean: 

VCS Bakup to a replacement device

Steve Deslandes
Level 1
Level 1

I took the backup from my VCS a few months ago. My VCS died last week and I got a replacement from CISCO. When I try to use my backup in the new device, I get the error:

SYSTEM ERROR: Failed to find required information for the VCS application in the backup.

There is also a warning that states:

The backup you are attempting to restore was made from another VCS (52AXXXXX). Any option keys will not be valid, and this may result in duplicate IP addresses in your network.

My question is, is it possible to use the backup from a previous device and download it into a replacement device?

11 Replies 11

Tomonori Taniguchi
Cisco Employee
Cisco Employee

Yes, you may restore backup file to different VCS HW (although there is warning message because SN mismatch).

This warning message is for noticing user restoring backup file on different VCS hardware only.

One important point that makes sure you have same feature option key before attempt restore backup file.

Tomonori Taniguchi
Cisco Employee
Cisco Employee

Also make sure replace VCS run with same software version that backup file created.

I tried doing the restore and made sure both the backup and the device were at the same version. Yet, it doesn't seem to work. I get the warning so then I select "Go ahead anyways". But then it comes back with that error:

SYSTEM ERROR: Failed to find required information for the VCS application in the backup

And with that error there, I cannot go ahead with the restore. The only option available afterwards is "cancel attempt for restore"

What was software version when you took system backup file from original VCS?

I opened the original backup file and it was at X6.1. My replacement was at version X6.0 so I upgraded it to match.

I suspect this will be X6.1 where there was an issue when the file structure changed.

In the backup file the directories /tandberg/persistent/oti and /tandberg/persistent/management probably do not exist, but the restore task believes they should and is most likely failing as they aren’t there.

To be able to restore this backup you will need to open the backup tar.gz and inserting folders into the above paths. Create two empty folders in the compressed archive, one called oti and the other management and then use this modified archive for the restore.

Thank you. I will try this. What software should I use to re-create the .tar file and the .gz file after modification? Any recommandations?

You will still use same software version to restore the backup file.

As Guy mention, there was an issue on X6.1 backup file creation and required to modify the backup file in order to restore back on VCS.

This has already fixed with X7 software version.

I've just used 7Zip in the past - you can open the archive then right click in it and select create folder. then when you close 7 zip it will tell you that the archieve has been modified and do you want to update it - then you can just select ok and everything should be good.

Thank you Guy. the modification seems to have worked properly by using your procedure with 7Zip. I will have my customer attempt the restore and will keep you posted. Thank you all for your assistance with this. Always something new to learn every day :-)

This worked for me to allow a restore with the error:

System error: Failed to find required information for the management framework in the backup.

Looks to be related to x6.1