Showing results for 
Search instead for 
Did you mean: 

TC7.3.0 codec fails after reset and power cycle - failed: dns lookup failed (CUCM registered)

Have a couple of codec's in the lab here that will work sometimes, and sometimes won't. They're running the latest 7.3.0 code and registering to CUCM 10.5.1SU1.  I've tried factory resetting them and get the same result.  I've manually configured the CUCM provisioning address in the system, and it immediately pulls down the correct SIP URI.  Sometimes power cycling the unit will allow it to register.  I have DNS running in this lab, A records created for all relevant hosts. 


Anybody seen this before?

Everyone's tags (1)

Hi Ryan, what kind of codec

Hi Ryan,

 what kind of codec are you using?

 When you said that sometimes they won't work, you are saying that sometimes they unregistered from CUCM?


This was for two C20's.  I

This was for two C20's.  I think I found the issue. About 1 out of every 3 reset/power cycles they would work the rest they would not.


Basically, I was using DHCP to assign IP, but manually assigning DNS.  You are able to do this on most machines, but the way the Codec handles this is different. It simply appends your manual DNS configuration, including the DNS domain, to the list obtained from DHCP.  In a packet capture I was able to see where it would query all 3 DNS servers (1 manual 2 from DHCP) and it would query based on my manual domain and the DHCP domain.  It appears to round-robin the response it uses, as all DNS servers responded in one fashion or another, it just picked one to listen to.  In this manner, it had about a 33% chance of picking the correct response.

After statically assigning the IP address, the problem went away as the only DNS server was the one manually assigned.

I take this all with a grain of salt though, as our internal team is using the TC7.2.1 code and they get the DNS issue every once in a while regardless of the DHCP/DNS configuration.  There may be more to this, but I can say with certainty that using DHCP and manual DNS configuration at the same time is not recommended.


Excellent news!!!As you

Excellent news!!!

As you described, it makes senses that the DHCP/DNS problem was causing the problem.